Probleme mit externen Monitoren nach dem Update der Dell Pro Dock-Firmware
Zusammenfassung: Erfahren Sie mehr über Probleme mit der Bildanzeige oder der Auflösung auf einem Monitor nach dem Update eines Dell Pro Dock WD25 oder Dell Pro Smart Dock SD25 auf die Firmwareversion 01.01.13.01. ...
Symptome
Bei einem externen Monitor, der mit einem Dell Pro Dock WD25 oder Dell Pro Smart Dock SD25 verbunden ist, treten möglicherweise Anzeige- oder Auflösungsprobleme auf. Dies geschieht, wenn der Monitor über einen HDMI-zu-DVI- oder DisplayPort-zu-DVI-Dongle angeschlossen ist. Das DVI-Ende des Dongles ist mit dem DVI-Anschluss des Monitors verbunden. Die Dockingstation wird auf Version 01.01.13.01 aktualisiert. Dieses Problem tritt bei der Firmware-Version 01.01.11.01 nicht auf.
Betroffene Plattformen:
- Dell Pro Dockingstation WD25
- Dell Pro Smart Dock SD25
- Dell Pro Thunderbolt 4 Dock WD25TB4
- Dell Pro Thunderbolt 4 Smart Dock SD25TB4
- Dell Pro Thunderbolt 5 Dock WD25TB5
- Dell Pro Thunderbolt 5 Smart Dock SD25TB5
Ursache
Einige Monitore, die über den DVI-Anschluss angeschlossen sind, versuchen möglicherweise, den DVI-Modus zu verwenden, was zu keiner Videoausgabe führt.
Lösung
Langfristige Lösung:
Die technische Abteilung arbeitet an einer Korrektur, die in der Dell Dockingstation-Firmwareversion 01.01.15.01 und höher veröffentlicht werden soll. Die aktualisierte Firmware wird auf der Supportseite des Computers veröffentlicht, sobald sie verfügbar ist. Die Firmwareversion 01.01.15.01 wird voraussichtlich Ende September 2026 veröffentlicht.
Problemumgehungen:
Ändern Sie entweder die Kabelverbindung zur Dockingstation oder führen Sie ein Downgrade der Dockingstation-Firmware durch.
Ändern der Kabelverbindung zur Dockingstation
- Verwenden Sie eine HDMI- oder DisplayPort-Verbindung, wenn der Monitor einen dieser Anschlüsse unterstützt. Schließen Sie den Monitor über ein HDMI- oder DisplayPort-Kabel direkt an die Dockingstation an und vermeiden Sie die Verwendung von Dongles.
- Wenn die Verbindung konvertiert werden muss, verwenden Sie HDMI-zu-VGA- oder DisplayPort-zu-VGA-Dongles.
- Wenn Sie eine Thunderbolt-Dockingstation (TBT) verwenden, verwenden Sie den TBT-Typ-C-Port mit einem Typ-C-zu-DVI- oder Typ-C-zu-VGA-Dongle.
- Der Monitor kann direkt an den Laptop angeschlossen werden, wenn kein anderer Dongle oder anderes Kabel verfügbar ist.
Downgrade der Dockfirmware
- Sichern Sie alle persönlichen Daten. Weitere Informationen finden Sie unter Backup und Wiederherstellung.
- Schließen Sie den Netzadapter an.
Ein Downgrade des Dienstprogramms für das Firmwareupdate des Dell Dock WD19/WD22/HD22/WD25/SD25 auf Version 01.01.11.01 behebt das Problem. Um die Firmware herunterzuladen und zu installieren, gehen Sie zu Dell Treiber und Downloads, suchen Sie nach der entsprechenden Dockingstation, suchen Sie das Dienstprogramm für das Dell Dock WD19/WD22/HD22/WD25/SD25 und wählen Sie dann Vollständige Treiberdetails anzeigen aus. Laden Sie unter Andere verfügbare Versionen die Firmwareversion 01.01.11.01 herunter.
Die Firmware muss nach dem Herunterladen über eine Befehlszeilenschnittstelle (CLI) installiert werden.
- Öffnen Sie den Windows Explorer-Ordner, in dem die Firmware Update Utility-Datei gespeichert ist. Klicken Sie in die Adressleiste von Windows Explorer, geben Sie cmd ein und drücken Sie dann die Eingabetaste, um die Eingabeaufforderung zu öffnen.
Hinweis: Öffnen Sie alternativ die Eingabeaufforderung und verwenden Sie die
cd, um zu dem Ordner zu wechseln, in dem das Firmwarepaket gespeichert ist. Wenn das Firmwarepaket beispielsweise im VerzeichnisDownloadsOrdner, geben Sie Folgendes eincd %USERPROFILE%\Downloadsein, und drücken Sie anschließend die Eingabetaste. - Geben Sie
DellDockFirmwarePackage_WD19_WD22_HD22_WD25_SD25_01.01.11.exe /fein, und drücken Sie anschließend die Eingabetaste.
Prävention:
Um zu verhindern, dass Dell Command Update auf die neueste Firmware aktualisiert wird, lesen Sie Anleitung zur Verwendung der Dell Command Update-Blockierlistenfunktion.