Isilon: Gen6 DE peer-nodpar (H400, A200, A2000) genererar händelser och konsolmeddelanden som indikerar problem med NTB-länken efter byte eller flytt av beräkningsmodul
Zusammenfassung: Ett Gen6 DE peer-nodpar (H400, A200, A2000) kan ibland börja generera felmeddelanden som indikerar problem med NTB-länken. Fel kan omfatta upprepade "NTB link up/down-meddelanden" och länkhastighetsförhandlingsfel. ...
Dieser Artikel gilt für
Dieser Artikel gilt nicht für
Dieser Artikel ist nicht an ein bestimmtes Produkt gebunden.
In diesem Artikel werden nicht alle Produktversionen aufgeführt.
Symptome
Ett Gen6 DE peer-nodpar (H400, A200, A2000) kan ibland börja generera felmeddelanden som indikerar problem med NTB-länken. Fel kan omfatta upprepade "link up/down"-meddelanden och länkhastighetsförhandlingsfel, till exempel:
mnv0: HW link down event mnv0: HW link up event mnv0: Failed to negotiate PCIe lane speed; expected 3 lane speed, got 2. mnv0: transport link up mnv0: peer up
Alternativt kan loggarna och/eller konsolen helt enkelt visa NTB-länken som nere och inte komma igång. Det verkar för närvarande finnas flera möjliga orsaker till problemet, och vissa är fortfarande under utredning. Om en eller båda av de berörda noderna nyligen har flyttats till en annan chassiplats, eller om deras beräkningsmodul har bytts ut, kan problemet och lösningen som dokumenteras i denna KB gälla. Det här problemet påverkar inte EP-noder (F800, H600, H500).
Ursache
Peer-noder kommunicerar med varandra via en särskild kommunikationskanal som kallas NTB (NonTransparent Bridge) och är inbäddad i chassits bakplan. I normal drift måste båda noderna i ett peer-par ha ett annat PPD-värde för att kunna kommunicera med varandra via NTB. PPD-värden tilldelas baserat på nodens kortplats-ID i chassit. Problemet orsakas av att nodens BIOS behåller nodens gamla kortplats-ID när en nod eller beräkningsmodul växlas till en annan plats än den ursprungligen kom från, i stället för att det nya kortplats-ID:t upptäcks. Det kan leda till att PPD-värdet ställs in felaktigt, vilket orsakar en konflikt som hindrar noderna från att upprätta en NTB-länk.
Lösung
Kör följande kommando på båda noderna i det berörda peer-paret för att kontrollera om problemet som beskrivs i denna KB är tillämpligt:
# sysctl dev.ntb_hw.0.debug_info.ppd Varje nod
svarar med antingen:
dev.ntb_hw.0.debug_info.ppd: 73
Eller:
dev.ntb_hw.0.debug_info.ppd: 93
Om ett nodpar svarar med 73 och den andra svarar med 93 påverkas inte dessa noder för närvarande av problemet som beskrivs i denna KB.
Kontakta EMC Isilons tekniska support om du behöver ytterligare hjälp.
– Om båda noderna svarar med samma nummer, oavsett om de är 73 eller 93, påverkas de av problemet som dokumenteras i denna KB. Problemet har åtgärdats i den uppdaterade fasta nodprogramvaran som ingår i Node Firmware Package 10.1.6 och senare, samt i en kodkorrigering som ingår i OneFS 8.1.0.4 och senare. Varje enskild uppdatering åtgärdar problemet, men båda innehåller andra viktiga korrigeringar, så vi rekommenderar att du installerar båda.
# sysctl dev.ntb_hw.0.debug_info.ppd Varje nod
svarar med antingen:
dev.ntb_hw.0.debug_info.ppd: 73
Eller:
dev.ntb_hw.0.debug_info.ppd: 93
Om ett nodpar svarar med 73 och den andra svarar med 93 påverkas inte dessa noder för närvarande av problemet som beskrivs i denna KB.
Kontakta EMC Isilons tekniska support om du behöver ytterligare hjälp.
– Om båda noderna svarar med samma nummer, oavsett om de är 73 eller 93, påverkas de av problemet som dokumenteras i denna KB. Problemet har åtgärdats i den uppdaterade fasta nodprogramvaran som ingår i Node Firmware Package 10.1.6 och senare, samt i en kodkorrigering som ingår i OneFS 8.1.0.4 och senare. Varje enskild uppdatering åtgärdar problemet, men båda innehåller andra viktiga korrigeringar, så vi rekommenderar att du installerar båda.
Betroffene Produkte
Isilon, Isilon Gen6Artikeleigenschaften
Artikelnummer: 000056963
Artikeltyp: Solution
Zuletzt geändert: 28 Juni 2023
Version: 6
Antworten auf Ihre Fragen erhalten Sie von anderen Dell NutzerInnen
Support Services
Prüfen Sie, ob Ihr Gerät durch Support Services abgedeckt ist.