NetWorker. Появляется ошибка «Невозможно установить привилегии пользователя на основе токена пользователя для account_name на nw_server_name»
Zusammenfassung: Эта ошибка может возникнуть, если истек срок действия проверки подлинности маркера на основе времени, используемой сервером authc сервера NetWorker. Это будет наблюдаться при попытке выполнения команд NetWorker с сервера NetWorker. ...
Dieser Artikel gilt für
Dieser Artikel gilt nicht für
Dieser Artikel ist nicht an ein bestimmtes Produkt gebunden.
In diesem Artikel werden nicht alle Produktversionen aufgeführt.
Symptome
При попытке выполнения команд NetWorker на сервере NetWorker появляется всплывающее окно с сообщением о том, что серверу NetWorker не удалось проверить маркер безопасности.
Пример:
C:\>nsrim -X
C:\>nsrim -X
10074:nsrim: не удается выполнить привязку к сервису NSR на имени сервера 144502:nsrd: Невозможно установить привилегии пользователя на основе токена пользователя для account_name в nw_server_name: Не удалось проверить токен безопасности.
Ursache
NetWorker использует маркеры проверки подлинности на основе времени. Если nsrlogin был выполнен ранее для учетной записи пользователя NetWorker, вы не сможете выполнять команды NetWorker после истечения срока действия маркера. Потребуется выпустить новый маркер или использовать nsrlogout для возврата к проверке подлинности на уровне ОС. Аутентификация на уровне ОС позволяет запускать команды NetWorker только из командной строки администратора или сеанса root.
Lösung
(Вариант 1) Возврат к устаревшей аутентификации:
- Если эта проблема возникает только при попытке выполнения команд сервера NetWorker, можно вернуться к (устаревшей) проверке подлинности на основе ОС, используемой NetWorker. Эта проблема возникает, так как на сервере NetWorker была запущена команда nsrlogin, а срок действия маркера истек. Чтобы вернуться к устаревшей проверке подлинности, выполните nsrlogout на сервере NetWorker.
(Вариант 2) Выпустите новый токен authc:
- Чтобы отправить новый токен серверу NetWorker, выполните следующую команду:
Учетная запись администратора — это учетная запись администратора NetWorker и пароль по умолчанию; Однако любая учетная запись пользователя NetWorker сможет выпустить маркер с nsrlogin, если пользователь имеет роли администратора приложений и администратора безопасности.
Если настроена внешняя аутентификация LDAP/AD, необходимо указать домен и клиента (если клиент по умолчанию не использовался).
- Если эта проблема возникает только при попытке выполнения команд сервера NetWorker, можно вернуться к (устаревшей) проверке подлинности на основе ОС, используемой NetWorker. Эта проблема возникает, так как на сервере NetWorker была запущена команда nsrlogin, а срок действия маркера истек. Чтобы вернуться к устаревшей проверке подлинности, выполните nsrlogout на сервере NetWorker.
(Вариант 2) Выпустите новый токен authc:
- Чтобы отправить новый токен серверу NetWorker, выполните следующую команду:
Синтаксис: nsrlogin [-s NetWorker_server] [-H authentication_host] [порт -P] [-t tenant] [-d logindomain] -u username [-p "password"]
Пример: nsrlogin -u Administrator -p password
Пример: nsrlogin -u Administrator -p password
Учетная запись администратора — это учетная запись администратора NetWorker и пароль по умолчанию; Однако любая учетная запись пользователя NetWorker сможет выпустить маркер с nsrlogin, если пользователь имеет роли администратора приложений и администратора безопасности.
Если настроена внешняя аутентификация LDAP/AD, необходимо указать домен и клиента (если клиент по умолчанию не использовался).
Weitere Informationen
Дополнительные сведения о nsrlogin можно найти в Справочном руководстве по командам NetWorker ируководствах администратора NetWorker, доступных по адресу: https://www.dell.com/support/home/product-support/product/networker/docs
Betroffene Produkte
NetWorkerProdukte
NetWorkerArtikeleigenschaften
Artikelnummer: 000065549
Artikeltyp: Solution
Zuletzt geändert: 10 Juni 2025
Version: 4
Antworten auf Ihre Fragen erhalten Sie von anderen Dell NutzerInnen
Support Services
Prüfen Sie, ob Ihr Gerät durch Support Services abgedeckt ist.