Troubleshooting von Problemen beim Entladen der Bandbibliothek in NetWorker
Zusammenfassung: Dieser Artikel hilft Supportern und Backupadministratoren bei der Behebung von Problemen beim Entladen von Bibliotheken auf Bibliotheks- oder Anwendungsebene. Es gibt an, ob es sich um ein logisches oder physikalisches Problem handelt und ob der Roboter, das Laufwerk oder die Medienkassette betroffen ist. ...
Symptome
- Sporadische oder konsistente Fehler beim Entladen von Bandkassetten von Laufwerken
- Kompromittierte Backupzeitfenster aufgrund von Entladefehlern
- In Laufwerken steckende Bandkassetten
- Bibliothek ist erkennbar, funktionsfähig und bereit
- Lade- und Kennzeichnungsvorgänge können durchgeführt, aber nicht entladen werden
- Mögliche ASC/ASCQ/SCSI SENSE-Fehler oder -Meldungen in System- oder Anwendungsprotokollen
Ursache
Wenn die Bibliothekskonfiguration zuvor funktioniert hat und plötzlich ein Problem auftritt, sollten Sie mögliche Änderungen in Betracht ziehen, die die Erkennung und Konfiguration erschweren könnten:
- Änderung von Roboter-, Switch- oder Adapter-Firmware, -Treiber oder -Konfiguration
- Hinzufügen, Ersetzen oder Entfernen von Laufwerken, Bandkassetten oder anderen Bibliothekskomponenten
- Änderung der NetWorker-Softwareversion, Betriebssystem-Patches
- Hardwareereignisse wie Stromausfall oder Neustart einer Komponente im Datenpfad
- Diskrepanzen zwischen NetWorker-Konfiguration und -Bibliothek (z. B. Bandkassetten, die außerhalb der Kontrolle von NetWorker verschoben wurden)
Wenn die Bibliothek noch nie funktioniert hat, vergewissern Sie sich, dass die Hardware im NetWorker-Hardwarekompatibilitätsleitfaden unterstützt wird. Denken Sie daran, dass es möglich ist, dass eine Bibliothek teilweise funktionsfähig ist. Die Erkennung allein ist keine Garantie für die Benutzerfreundlichkeit oder Unterstützbarkeit.
Bekannte Ursachen für Probleme beim Entladen von Bibliotheken:
- Verstehen und Troubleshooting beim Entladen von Medien aus einer Bandbibliothek (Zum Anzeigen dieses Artikels ist ein Dell Supportkonto erforderlich)
- Band-Volumes können zeitweise nicht ausgeworfen werden
Lösung
Nachdem Sie die letzten Änderungen überprüft haben, beheben Sie Probleme beim Entladen der Bibliothek, indem Sie den Prozess in grundlegende Komponenten aufteilen und jede einzeln testen.
Die erforderlichen Daten werden von NSRGet erfasst, wenn es mit dem Schalter "-o:d" ausgeführt wird. Das Skript schließt Vorgänge aus, die bei automatischer Ausführung gefährlich sein können, z. B. solche, die nicht sicher über den Collector durchgeführt werden können.
Entladen der Bibliothek: Kommunikation
- Stellen Sie erneut sicher, dass die Bibliothek reagiert und Bänder laden kann, bevor Sie fortfahren. Wenn nicht:
- Troubleshooting von Problemen beim Laden der Bandbibliothek in NetWorker (Zum Anzeigen dieses Artikels ist ein Dell Supportkonto erforderlich)
- Troubleshooting von Problemen mit der Bandbibliotheksbereitschaft in NetWorker
- Troubleshooting von Problemen mit dem Zugriff auf die Bandbibliothek in NetWorker
- Troubleshooting von Problemen bei der Bandbibliothekserkennung in NetWorker
- Troubleshooting von Hardwareproblemen mit der Bandbibliothek in NetWorker
Entladen der Bibliothek: Ladevorbereitung
- Um sich auf einen der folgenden Tests vorzubereiten, bereiten Sie das Laden eines Test-Volumes vor. Entladen Sie zunächst alle Geräte, um Verwechslungen zu vermeiden:
nsrjb -HHvvvvv
- Stellen Sie sicher, dass die Geräte leer sind, indem Sie sowohl NetWorker als auch den Roboter direkt abfragen. Suchen Sie auch einen Steckplatz mit einem verfügbaren Volume:
nsrjb -C sjirdtag <robot SCSI address>
- Legen Sie die NSR-Jukebox-EigenschaftIdle Device Timeout der Bandbibliothek, die Sie verwenden, auf 0 fest, um unerwartete Entladevorgänge zu deaktivieren
- Laden Sie ein Volume mithilfe normaler NetWorker-Befehle in ein Gerät, wobei idealerweise bei beiden Seiten Entladeprobleme aufgetreten sind:
nsrjb -lnvvvvv -f <NetWorker device name> -S <slot number>
- Vergewissern Sie sich, dass das Volume auf dem gerade geladenen Gerät angezeigt wird, indem Sie den Befehl auf dem entsprechenden Host ausführen:
mt -f <local device name> status nsrmm -pvvvvv -f <full NetWorker device name>
- Wenn es eine Diskrepanz mit den Volumes gibt, überprüfen Sie, ob das Laden und Mounten erfolgreich war. Wenn das Mounten fehlschlägt und das Volume sofort ausgeworfen wird, können Sie mit dem Troubleshooting von Mount-Fehlern über Linkfehler bei Problemen beim Mounten von Medien in NetWorker fortfahren. Wenn Sie unabhängig vom Troubleshooting von Entladefehlern fortfahren möchten, können Sie es erneut versuchen, indem Sie ohne Mount laden ("nsrjb -lnvvvvv" anstelle von "nsrjb -lvvvv" oben)
Entladen der Bibliothek: Physischer Betrieb (Auswurf)
- Um die Auswurffunktion der im vorherigen Schritt eingelegten Bandkassette zu testen, verwenden Sie den nativen (oder Windows-portierten) Befehl "mt" (Sie können auch das CDI-Befehlsäquivalent verwenden, das zusätzlichen NetWorker-Code verwendet, aber die Verwendung der Variablen "CDI_DEBUG" zulässt)
mt -f <local device name> offline cdi_load_unload -u -f /dev/nst0 -vvvvvv
- Überprüfen Sie die Ausgabe und bestätigen Sie, dass der Auswurf tatsächlich abgeschlossen wurde, indem Sie entweder den nativen/portierten Befehl "mt" oder den entsprechenden CDI-Befehl verwenden:
mt -f <local device name> status cdi_get_status -f /dev/nst0 -vvvvvv
- Laden Sie das Volume erneut in das Bandgerät, bevor Sie versuchen, es vollständig zu entladen:
cdi_load_unload -l -f /dev/nst0 -vvvvvv
- Wenn der Auswurfvorgang keine nativen oder CDI-Befehlsvorgänge verwendet, sollten Sie die Möglichkeit von Problemen mit dem Laufwerk oder der Bandkassette in Betracht ziehen und den Test mit Mechanismen auf niedrigerer Ebene unterhalb der Treiberebene durchführen:
- Versuchen Sie, das Volume aus der Steuerungsschnittstelle des Roboters heraus zu verschieben
- Versuchen Sie, das Volume vom LCD-Bildschirm einer physischen Bibliothek zu verschieben.
- Versuchen Sie, das Volume über die Befehlszeilenschnittstelle einer virtuellen Bibliothek zu verschieben
- Versuchen Sie den gleichen Vorgang erneut mit einem anderen Laufwerk und einer anderen Bandkassette, um den Umfang des Problems zu testen
- Planen Sie einen Anbieteranruf, wenn bei den oben genannten Auswurf-/Verschiebeversuchen Probleme auftreten
- Wenn der Auswurfvorgang fehlschlägt, aber die Low-Level-Schnittstellen Bandkassetten bewegen können, hängt das Problem wahrscheinlich mit dem Treiber zusammen
- Überprüfen Sie die Protokolle und Ausgaben des Betriebssystems (
dmesg,messages,errpt -a,syslog, Systemereignisprotokoll) - Berücksichtigen Sie Probleme bei der Laufwerksreihenfolge
- Überprüfen Sie die Protokolle und Ausgaben des Betriebssystems (
Entladen der Bibliothek: Physischer Betrieb (Bandkassette verschieben)
- Überprüfen Sie, ob der Bibliotheksbetrieb auf einer grundlegenden Ebene physisch möglich ist. Stellen Sie sicher, dass die Tests durchgeführt werden, wenn die Bibliothek anderweitig nicht aktiv ist, und bestätigen Sie, dass die Testbandkassette von oben dort ist, wo Sie sie gelassen haben, sowohl im Roboter als auch in der Konfiguration von NetWorker:
sjirdtag <changer address> nsrjb -C
- Ziehen Sie dann die Bandkassetten aus dem Laufwerkselement in einen Steckplatz und wieder zurück:
sjimm <changer address> drive <element_number> slot <element_number> sjimm <changer address> slot <element_number> drive <element_number>
- Insbesondere – wenn das Verschieben vom Laufwerk zum Steckplatz fehlschlägt – ist autoeject (autooffline auf einer Data Domain-VTL) wahrscheinlich nicht für die Bibliothek aktiviert. Sie können dies bestätigen, indem Sie zuerst das Volume auswerfen (vorheriger Abschnitt) und den Verschiebevorgang erneut versuchen. Verschieben Sie das Volume nach Abschluss zurück.
Bibliothek entladen: Logischer Vorgang (Entladen aus NetWorker)
Sobald wir festgestellt haben, dass physische Vorgänge (zumindest oberflächlich) fehlerfrei sind, können wir versuchen, das Problem in NetWorker nachzuvollziehen.
- Vergewissern Sie sich noch einmal, dass der Bibliotheksroboter und NetWorker sich hinsichtlich des Speicherorts der Bandkassetten einig sind:
nsrjb [<-j library_name>] -C sjirdtag <changer address>
- Versuchen Sie, das Testband mit hoher Ausführlichkeit zu entladen:
nsrjb [<-j library_name>] -uvvvvv -f <device_handle>
Wenn die Bibliothek erfolgreich über Geräte und Kassetten hinweg entladen wird, kann das Problem situationsbedingt sein. Isolieren Sie die Bedingung, die den Fehler verursacht, und beginnen Sie mit dem Debuggen. - Wenn Entladevorgänge fehlschlagen und Volumes als "nicht etikettiert" gekennzeichnet sind, ist es am wahrscheinlichsten, dass die NSR-Jukebox: Überprüfen Sie, ob die Einstellung Beim Entladen etikettieren aufgrund eines Lesefehlers vor dem Entladevorgang stört. Deaktivieren Sie die Einstellung und versuchen Sie es erneut.
- Legen Sie die NSR-Jukebox-EigenschaftenEject Sleep und Unload Sleep auf 60 fest und versuchen Sie es erneut. Wenn dies fehlerfreie Entladungen ermöglicht, verringern Sie den Ruhemodus sukzessive, bis die Fehler wieder auftreten.
Bibliothek entladen: Debugging
Wenn alle Stricke reißen, sammeln Sie die entsprechenden Daten, um das Debuggen des Problems zu erleichtern, bevor Sie SMEs konsultieren:
- Bevor Sie das Problem in NetWorker reproduzieren, ändern Sie das Debug-Trace-Level in der NSR-Jukebox-Ressource auf 5
- Verwenden Sie außerdem "dbgcommand", um das Debug-Level der ausgeführten Prozesse "nsrd" und "nsrmmgd" auf 5 zu erhöhen
- Erwägen Sie "truss/tusc/strace", "pstack", "gcore/gencore" auf dem entsprechenden "nsrlcpd" vor oder während des Problemereignisses
- Legen Sie die Debug-Variablen in der Systemumgebung (Windows) oder im Startskript (UNIX) fest, um umfangreichere Debugging-Daten zu erhalten:
SJI_DEBUG=9LUS_DEBUG=9CDI_DEBUG=9SCSI_DEBUG=9JBDEBUG=9
WARNUNG: Die Debugging-Protokollierung kann übermäßig werden, es sei denn, das Problem wird kurz nach dem Start reproduziert und Services werden heruntergefahren, um die Umgebungsvariablen zu löschen.Wenn die Vorschläge nicht weiterhelfen, wenden Sie sich an den Support Ihres Bibliotheksanbieters, wenn die Debug-Daten interne Anomalien zeigen. Andernfalls eskalieren Sie die Debug-Ausgabe an den NetWorker-Support, um einen möglichen Codefehler zu untersuchen.
Weitere Informationen
Dieser Artikel gehört zu einer Serie in Troubleshooting von Bandbibliotheken mit NetWorker. Die Liste finden Sie hier:
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