PowerStore: Prüfliste für Appliance-Lizenzierung

Zusammenfassung: In diesem Artikel wird erläutert, wie Sie Lizenzierungsprobleme für PowerStore-Produkte abrufen, aktivieren und beheben.

Dieser Artikel gilt für Dieser Artikel gilt nicht für Dieser Artikel ist nicht an ein bestimmtes Produkt gebunden. In diesem Artikel werden nicht alle Produktversionen aufgeführt.

Symptome

Nach der Installation verfügen alle Appliances über eine 30-tägige Testlizenz, damit die Konfiguration fortgesetzt werden kann, bis die Lizenzierung abgeschlossen werden kann.

PowerStore versucht alle 24 Stunden, eine Verbindung zu Dell herzustellen, um die Lizenz zu aktivieren. Wenn der externe Internetzugang nicht zulässig ist, wird im Folgenden ein manuelles Verfahren zum Abrufen der Lizenz beschrieben.

Ursache

PowerStore-Lizenzen sind:
  • Alles inklusive
  • Lassen Sie nicht ablaufen.
  • Ausgestellt pro Appliance
 
Hinweis: Das Hinzufügen neuer Appliances zu einem vorhandenen PowerStore-Cluster kann dazu führen, dass der gesamte Cluster auf die Testlizenzierung zurückgesetzt wird, bis die neu hinzugefügte Appliance dauerhaft lizenziert ist.

Lösung

Themen:


Überprüfen des Lizenzstatus in PowerStore Manager

Wählen Sie in der PowerStore Manager-BenutzeroberflächeSettings > Licensing aus.
 
Beispiel: Die Lizenzierung wurde erfolgreich abgeschlossen.
 
GUI der PowerStore-Lizenzierung – Prüfung
 
Beispiel: Lizenz nicht aktiviert, immer noch Testlizenz.
 
PowerStore-GUI-Lizenzinstallation

ClusterlizenzierungBildBild

    Jede Appliance wird einzeln lizenziert. Sobald alle Mitglieder im Cluster lizenziert sind, wird die Benutzeroberfläche für die Lizenzierung als Aktiv angezeigt.

    Verwenden Sie die Funktion svc_license_status list, um zu ermitteln, ob der Lizenzierungsstatus der einzelnen Appliance gilt. Im folgenden Beispiel wird eine Appliance hervorgehoben, die nicht lizenziert ist.
    [SVC:service@ABC1234-B user]$ svc_license_status list
     appliance_sn | days_remain | is_licensed
    --------------+-------------+-------------
     ABC1234      |     2048998 | t
     ZYX1234      |     2048998 | t
     CBA1234      |     2048998 | t
     XYZ1234      |          59 | f
    (4 rows)
    

      Automatische Lizenzierung

      Die Appliance versucht automatisch, alle 24 Stunden die Online-e-License-Server zu erreichen, um Lizenzen abzurufen und zu installieren, wenn eine aktive Internetverbindung verfügbar ist.

      Für Systeme, die direkt mit Dell Connectivity Services verbunden sind, werden PowerStore-Lizenzen automatisch abgerufen und während der Erstkonfiguration auf allen Appliances im Cluster installiert. Die Lizenz beinhaltet den Zugriff auf alle PowerStore-Funktionen.

      PowerStore verwendet die dynamische Lizenzierung in den Versionen 4.3 und höher. Dynamic Licensing bietet ein optimiertes, Cloud-basiertes Management von Dell Produktlizenzen. Sie unterstützt den gesamten Lizenzlebenszyklus – einschließlich Erweiterungen, Erweiterungen und zentralem Management über Standorte und Produkte hinweg. Bei der Methode " Dynamic Licensing-Connected" werden Lizenzen automatisch auf dem System abgerufen und installiert.

       

      Hinweis: Wenn Ihre Lizenz vor dem Upgrade auf PowerStoreOS 4.3 oder höher erfolgreich installiert wurde, sind keine weiteren Maßnahmen erforderlich.
       

      Um Lizenzen automatisch während oder nach der Erstkonfiguration abzurufen, stellen Sie sicher, dass Port 443 geöffnet ist oder dass Supportkonnektivität konfiguriert ist. Der Cluster kommuniziert über Port 443 oder den sicheren Tunnel der Supportkonnektivität mit dem Dell Lizenzierungsportal, um die Lizenzdatei abzurufen.

      Wenn ein Problem beim Abrufen der Lizenz auftritt, wird der Cluster in einem 30-tägigen Testzeitraum betrieben. Das System versucht, eine Lizenz automatisch alle 24 Stunden abzurufen, bis dies erfolgreich ist.

      Um den Lizenzstatus in PowerStore Manager zu überprüfen, gehen Sie zu Einstellungen → Lizenzierung. Der Status Active gibt an, dass der Cluster über eine gültige Lizenz verfügt.

      Wenn Sie noch keine aktive Lizenz haben, klicken Sie auf der Seite Licensing in PowerStore Manager auf Refresh , um den automatischen Abruf zu versuchen.

      Wenn das System angezeigt wird, befindet es sich im Testmodus:

      Klicken Sie auf den Link Aktualisieren , um einen Versuch zum Abrufen der Lizenzen mithilfe von Online-eLicense-Servern auszulösen. Wenn dies nach mehreren Versuchen fehlschlägt, lesen Sie den Abschnitt "Manuelle Lizenzierung" unten.

      Troubleshooting von Fehlern bei der automatischen Lizenzierung in PowerStore

       
      Hinweis: Die automatische Lizenzierung bietet keine Unterstützung für TLA-Lizenzen (Transformational License Agreement). Dieser Lizenztyp muss manuell aktiviert werden.
       
      1. Vergewissern Sie sich, dass Sie den DNS-Namen des Lizenzservers auflösen können. ssgosge.emc.com und stellen Sie von jedem Windows- oder Linux-System in der Umgebung eine Verbindung zu Port 443 her.
      • ncat ist für viele Betriebssysteme als Open Source verfügbar, https://nmap.org/ncat/.
      • ncat ist für den Servicenutzer auf PowerStore nicht verfügbar.
      • Der Lizenzserver reagiert nicht auf ping.
      nc -vz ssgosge.emc.com 443
      Ncat: Version 7.50 ( https://nmap.org/ncat )
      Ncat: Connected to 168.159.208.38:443  <<Successful Connection
      Ncat: 0 bytes sent, 0 bytes received in 0.07 seconds.
      
      nc -vz ssgosge123.emc.com 443
      Ncat: Version 7.50 ( https://nmap.org/ncat )
      Ncat: Could not resolve hostname "ssgosge123.emc.com": Name or service not known. QUITTING.  <<Cannot resolve DNS name
      
      nc -vz ssgosge.emc.com 440
      Ncat: Version 7.50 ( https://nmap.org/ncat )
      Ncat: Connection timed out.  <<Failed connection to port

      Wenn die oben genannten Schritte keinen Einblick in ein Problem liefern, wenden Sie sich an einen Mitarbeiter des technischen Supports von Dell und verweisen Sie auf diesen Artikel.

      Manuelle Lizenzierung

      Für Systeme, die nicht direkt mit Dell Connectivity Services verbunden sind, können Sie manuell eine Lizenz installieren.

      • Für Systeme auf PowerStoreOS 4.2 und früher wird eine Lizenzaktivierungsdatei verwendet, um die Lizenz vom Dell Lizenzierungsportal abzurufen. Die Aktivierungsdatei kann von der Lizenzierungsseite in PowerStore Manager heruntergeladen werden.
      • PowerStoreOS 4.3 und höher verwendet die Methode "Dynamische Lizenzierung offline (getrennt) ". Registrieren Sie Ihr Produkt im Dell Lizenzierungsportal, um die Lizenzregistrierungsdatei zu erhalten.

      Verwenden Sie nach Erhalt der Lizenz aus dem Dell Lizenzierungsportal die Option Lizenz installieren auf der Seite Lizenzierung in PowerStore Manager, um die Lizenz zu aktivieren.

      Eine manuelle Lizenzierung ist erforderlich, wenn die Appliance an einem Ort ohne verfügbare Internetverbindung installiert oder TLA-Lizenzierung verwendet wird.

      1. Navigieren Sie zum Software Licensing Central Portal (Anmeldung erforderlich).
      2. Melden Sie sich mit Ihren Kontozugangsdaten an.
      3. Wählen Sie Software und Lizenzen > Lizenzen anzeigen und verwalten aus.
      4. Geben Sie in der Suchleiste das Service-Tag der PowerStore-Appliance ein und klicken Sie auf Search by LAC.
       
      Hinweis: Bei Systemen, die ein Transformational License Agreement (TLA) verwenden, wird der Aktivierungscode in das TLA-ID-Feld eingetragen.
       
        1. Vergewissern Sie sich, dass das Element PowerStore Base SW ausgewählt ist, und klicken Sie dann auf Actions> View Entitlement details.
        2. Der Lizenzaktivierungsprozess kann nach Produktlinie oder LAC angezeigt werden.
        3. Bestätigen Sie Sales Order #, SKU/Angebots-ID und Berechtigungs-ID. 
        4. Wenn Änderungen vorgenommen werden müssen, klicken Sie unter Aktionen auf Anzeigen .
        5. Bestätigen Sie Sperr-IDs/Service-Tags und klicken Sie unter Aktionen auf Schlüssel neu generieren .
        6. Überprüfen Sie alle Informationen. Bestätigen Sie die E-Mail-Adresse , an die die Lizenzschlüsseldatei gesendet werden soll, und weitere E-Mail-Adressen, an die Lizenzschlüssel gesendet werden sollen. Fügen Sie dieser Transaktion eine Nachricht hinzu.
        7. Klicken Sie auf Complete.
        8. Überprüfen Sie Ihr E-Mail-Postfach auf die Aktivierungsdatei. Die Datei befindet sich im Anhang.
        9. Klicken Sie auf Lizenz herunterladen , um den Lizenzschlüssel herunterzuladen.  
        Wenn die oben genannten Schritte keine Lösung liefern, wenden Sie sich an einen Mitarbeiter des technischen Supports von Dell und verweisen Sie auf diesen Artikel.

        Troubleshooting von Fehlern bei der manuellen Lizenzierung in PowerStore

        1. Bestätigen Sie die Lizenzdateierweiterung (*.xml) hochgeladen wird.
        2. Öffnen Sie das Menü *.xml und inspizieren Sie den Inhalt.
        • Bestätigen Sie BEIDE <LockingID> Und <MachineName> Die Werte enthalten NUR das Service-Tag der PowerStore-Appliance. (Nur in GROSSBUCHSTABEN)
        • Wenn diese nicht übereinstimmen, korrigieren Sie die Werte im Software Licensing Central Portal (Anmeldung erforderlich) und erfassen Sie die korrigierte Lizenzdatei.

        Wenn die oben genannten Punkte keinen Einblick in das Problem geben, wenden Sie sich an einen Mitarbeiter des technischen Supports von Dell und verweisen Sie auf diesen Artikel.

          Abrufen von Lizenzdateien, falls zuvor aktiviert

          Wenn das Produkt zuvor aktiviert wurde, können Sie die folgende Schritte ausführen, um die ursprüngliche Lizenzdatei herunterzuladen:
          1. Navigieren Sie zum Software Licensing Central Portal (Anmeldung erforderlich).
          2. Melden Sie sich mit Ihren Kontozugangsdaten an.
          3. Wählen Sie Zertifikate > Zertifikate anzeigen und verwalten aus.
          4. Geben Sie in der Suchleiste das Service-Tag der PowerStore-Appliance ein und klicken Sie auf Search by LAC.
          5. Klicken Sie im Feld Certificate auf View , um das vorhandene Zertifikat anzuzeigen.
          6. Um eine lokale Kopie der Lizenz herunterzuladen, klicken Sie auf Lizenz herunterladen.
          7. Laden Sie die Lizenzdatei in PowerStore Manager hoch.
            1. Menü "Einstellungen"
            2. Wählen Sie Licensing aus.
            3. Klicken Sie auf Install License.
            4. Klicken Sie in Schritt 3 auf die Schaltfläche Choose File.
            5. Laden Sie die .xml-Datei hoch, die Sie zuvor in der E-Mail erhalten haben.
            6. Überprüfen Sie, dass sich der Status auf Active geändert hat.
          Wenn die oben genannten Schritte keine Lösung liefern, wenden Sie sich an einen Mitarbeiter des technischen Supports von Dell und verweisen Sie auf diesen Artikel.

          Betroffene Produkte

          PowerStore
          Artikeleigenschaften
          Artikelnummer: 000123660
          Artikeltyp: Solution
          Zuletzt geändert: 11 März 2026
          Version:  24
          Antworten auf Ihre Fragen erhalten Sie von anderen Dell NutzerInnen
          Support Services
          Prüfen Sie, ob Ihr Gerät durch Support Services abgedeckt ist.