PowerStore: Prüfliste für Appliance-Lizenzierung
Zusammenfassung: In diesem Artikel wird erläutert, wie Sie Lizenzierungsprobleme für PowerStore-Produkte abrufen, aktivieren und beheben.
Symptome
PowerStore versucht alle 24 Stunden, eine Verbindung zu Dell herzustellen, um die Lizenz zu aktivieren. Wenn der externe Internetzugang nicht zulässig ist, wird im Folgenden ein manuelles Verfahren zum Abrufen der Lizenz beschrieben.
Ursache
- Alles inklusive
- Lassen Sie nicht ablaufen.
- Ausgestellt pro Appliance
Lösung
Themen:
- Überprüfen des Lizenzstatus in PowerStore Manager
- Clusterlizenzierung
- Automatische Lizenzierung
- Troubleshooting von Fehlern bei der automatischen Lizenzierung in PowerStore
- Manuelle Lizenzierung
- Troubleshooting von Fehlern bei der manuellen Lizenzierung in PowerStore
- Abrufen von Lizenzdateien aus einer früheren Aktivierung
Überprüfen des Lizenzstatus in PowerStore Manager
Clusterlizenzierung

Verwenden Sie die Funktion
svc_license_status list, um zu ermitteln, ob der Lizenzierungsstatus der einzelnen Appliance gilt. Im folgenden Beispiel wird eine Appliance hervorgehoben, die nicht lizenziert ist.
[SVC:service@ABC1234-B user]$ svc_license_status list
appliance_sn | days_remain | is_licensed
--------------+-------------+-------------
ABC1234 | 2048998 | t
ZYX1234 | 2048998 | t
CBA1234 | 2048998 | t
XYZ1234 | 59 | f
(4 rows)
Automatische Lizenzierung
Für Systeme, die direkt mit Dell Connectivity Services verbunden sind, werden PowerStore-Lizenzen automatisch abgerufen und während der Erstkonfiguration auf allen Appliances im Cluster installiert. Die Lizenz beinhaltet den Zugriff auf alle PowerStore-Funktionen.
PowerStore verwendet die dynamische Lizenzierung in den Versionen 4.3 und höher. Dynamic Licensing bietet ein optimiertes, Cloud-basiertes Management von Dell Produktlizenzen. Sie unterstützt den gesamten Lizenzlebenszyklus – einschließlich Erweiterungen, Erweiterungen und zentralem Management über Standorte und Produkte hinweg. Bei der Methode " Dynamic Licensing-Connected" werden Lizenzen automatisch auf dem System abgerufen und installiert.
Um Lizenzen automatisch während oder nach der Erstkonfiguration abzurufen, stellen Sie sicher, dass Port 443 geöffnet ist oder dass Supportkonnektivität konfiguriert ist. Der Cluster kommuniziert über Port 443 oder den sicheren Tunnel der Supportkonnektivität mit dem Dell Lizenzierungsportal, um die Lizenzdatei abzurufen.
Wenn ein Problem beim Abrufen der Lizenz auftritt, wird der Cluster in einem 30-tägigen Testzeitraum betrieben. Das System versucht, eine Lizenz automatisch alle 24 Stunden abzurufen, bis dies erfolgreich ist.
Um den Lizenzstatus in PowerStore Manager zu überprüfen, gehen Sie zu Einstellungen → Lizenzierung. Der Status Active gibt an, dass der Cluster über eine gültige Lizenz verfügt.
Wenn Sie noch keine aktive Lizenz haben, klicken Sie auf der Seite Licensing in PowerStore Manager auf Refresh , um den automatischen Abruf zu versuchen.
Wenn das System angezeigt wird, befindet es sich im Testmodus:
Troubleshooting von Fehlern bei der automatischen Lizenzierung in PowerStore
- Vergewissern Sie sich, dass Sie den DNS-Namen des Lizenzservers auflösen können.
ssgosge.emc.comund stellen Sie von jedem Windows- oder Linux-System in der Umgebung eine Verbindung zu Port 443 her.
ncatist für viele Betriebssysteme als Open Source verfügbar,https://nmap.org/ncat/.ncatist für den Servicenutzer auf PowerStore nicht verfügbar.- Der Lizenzserver reagiert nicht auf
ping.
nc -vz ssgosge.emc.com 443 Ncat: Version 7.50 ( https://nmap.org/ncat ) Ncat: Connected to 168.159.208.38:443 <<Successful Connection Ncat: 0 bytes sent, 0 bytes received in 0.07 seconds. nc -vz ssgosge123.emc.com 443 Ncat: Version 7.50 ( https://nmap.org/ncat ) Ncat: Could not resolve hostname "ssgosge123.emc.com": Name or service not known. QUITTING. <<Cannot resolve DNS name nc -vz ssgosge.emc.com 440 Ncat: Version 7.50 ( https://nmap.org/ncat ) Ncat: Connection timed out. <<Failed connection to port
Wenn die oben genannten Schritte keinen Einblick in ein Problem liefern, wenden Sie sich an einen Mitarbeiter des technischen Supports von Dell und verweisen Sie auf diesen Artikel.
Manuelle Lizenzierung
Für Systeme, die nicht direkt mit Dell Connectivity Services verbunden sind, können Sie manuell eine Lizenz installieren.
- Für Systeme auf PowerStoreOS 4.2 und früher wird eine Lizenzaktivierungsdatei verwendet, um die Lizenz vom Dell Lizenzierungsportal abzurufen. Die Aktivierungsdatei kann von der Lizenzierungsseite in PowerStore Manager heruntergeladen werden.
- PowerStoreOS 4.3 und höher verwendet die Methode "Dynamische Lizenzierung offline (getrennt) ". Registrieren Sie Ihr Produkt im Dell Lizenzierungsportal, um die Lizenzregistrierungsdatei zu erhalten.
Verwenden Sie nach Erhalt der Lizenz aus dem Dell Lizenzierungsportal die Option Lizenz installieren auf der Seite Lizenzierung in PowerStore Manager, um die Lizenz zu aktivieren.
Eine manuelle Lizenzierung ist erforderlich, wenn die Appliance an einem Ort ohne verfügbare Internetverbindung installiert oder TLA-Lizenzierung verwendet wird.
- Navigieren Sie zum Software Licensing Central Portal (Anmeldung erforderlich).
- Melden Sie sich mit Ihren Kontozugangsdaten an.
- Wählen Sie Software und Lizenzen > Lizenzen anzeigen und verwalten aus.
- Geben Sie in der Suchleiste das Service-Tag der PowerStore-Appliance ein und klicken Sie auf Search by LAC.
- Vergewissern Sie sich, dass das Element PowerStore Base SW ausgewählt ist, und klicken Sie dann auf Actions> View Entitlement details.
- Der Lizenzaktivierungsprozess kann nach Produktlinie oder LAC angezeigt werden.
- Bestätigen Sie Sales Order #, SKU/Angebots-ID und Berechtigungs-ID.
- Wenn Änderungen vorgenommen werden müssen, klicken Sie unter Aktionen auf Anzeigen .
- Bestätigen Sie Sperr-IDs/Service-Tags und klicken Sie unter Aktionen auf Schlüssel neu generieren .
- Überprüfen Sie alle Informationen. Bestätigen Sie die E-Mail-Adresse , an die die Lizenzschlüsseldatei gesendet werden soll, und weitere E-Mail-Adressen, an die Lizenzschlüssel gesendet werden sollen. Fügen Sie dieser Transaktion eine Nachricht hinzu.
- Klicken Sie auf Complete.
- Überprüfen Sie Ihr E-Mail-Postfach auf die Aktivierungsdatei. Die Datei befindet sich im Anhang.
- Klicken Sie auf Lizenz herunterladen , um den Lizenzschlüssel herunterzuladen.
Troubleshooting von Fehlern bei der manuellen Lizenzierung in PowerStore
- Bestätigen Sie die Lizenzdateierweiterung (
*.xml) hochgeladen wird. - Öffnen Sie das Menü
*.xmlund inspizieren Sie den Inhalt.
- Bestätigen Sie BEIDE <
LockingID> Und <MachineName> Die Werte enthalten NUR das Service-Tag der PowerStore-Appliance. (Nur in GROSSBUCHSTABEN) - Wenn diese nicht übereinstimmen, korrigieren Sie die Werte im Software Licensing Central Portal (Anmeldung erforderlich) und erfassen Sie die korrigierte Lizenzdatei.
Wenn die oben genannten Punkte keinen Einblick in das Problem geben, wenden Sie sich an einen Mitarbeiter des technischen Supports von Dell und verweisen Sie auf diesen Artikel.
Abrufen von Lizenzdateien, falls zuvor aktiviert
- Navigieren Sie zum Software Licensing Central Portal (Anmeldung erforderlich).
- Melden Sie sich mit Ihren Kontozugangsdaten an.
- Wählen Sie Zertifikate > Zertifikate anzeigen und verwalten aus.
- Geben Sie in der Suchleiste das Service-Tag der PowerStore-Appliance ein und klicken Sie auf Search by LAC.
- Klicken Sie im Feld Certificate auf View , um das vorhandene Zertifikat anzuzeigen.
- Um eine lokale Kopie der Lizenz herunterzuladen, klicken Sie auf Lizenz herunterladen.
- Laden Sie die Lizenzdatei in PowerStore Manager hoch.
- Menü "Einstellungen"
- Wählen Sie Licensing aus.
- Klicken Sie auf Install License.
- Klicken Sie in Schritt 3 auf die Schaltfläche Choose File.
- Laden Sie die .xml-Datei hoch, die Sie zuvor in der E-Mail erhalten haben.
- Überprüfen Sie, dass sich der Status auf Active geändert hat.