NVP vProxy: vSphere Web Client Plugin meldet erfolgreiche Installation, wird aber nicht angezeigt
Zusammenfassung: vSphere Web Client Plugin meldet erfolgreiche Installation, wird jedoch nicht angezeigt
Dieser Artikel gilt für
Dieser Artikel gilt nicht für
Dieser Artikel ist nicht an ein bestimmtes Produkt gebunden.
In diesem Artikel werden nicht alle Produktversionen aufgeführt.
Symptome
Die Integration von NetWorker VMware Protection wird mit der vProxy-Appliance konfiguriert. Der vCenter-Server wird unter der VMware-Ansicht in der NetWorker Management Console (NMC) ausgewählt, um das vCenter-Plug-in zu installieren. Die Ergebnisse der vCenter Plug-in-Installation zeigen an, dass es erfolgreich installiert wurde, aber der vSphere-Webclient zeigt das Dell EMC NetWorker-Plug-in nicht an.
Ursache
Das vSphere Web Client Plugin wurde möglicherweise in einem inkonsistenten Zustand installiert oder vorherige Plug-in-Installationsdateien beeinträchtigen die Installation des neuen Plug-ins.
Lösung
Entfernen Sie die vorhandenen Dell NetWorker-Plug-in-Registrierungen vom vCenter-Server. Die Anweisungen finden Sie auch im Abschnitt "Entfernen des Flash-basierten vCenter-Plug-ins aus dem vSphere Web Client" des Dell EMC NetWorker VMware-Integrationshandbuchs. Der KB-Artikel enthält detailliertere Schritte zum Entfernen der Registrierung des Dell EMC NetWorker-Plug-ins.
1) Melden Sie sich mit dem konto administrator@vsphere.local beim vCenter Managed Object Browser (MOB) an. Der ZUGRIFF auf das GANG kann über einen Webbrowser erfolgen, der den Hostnamen/die IP-Adresse des vCenter erreichen kann: https://vcenter_name/thunderbolt
Hinweis: Wenn "Method Invocation Result: void" angezeigt wird, können Sie das nächste Plug-in angeben und entfernen. Wiederholen Sie diese Methode für jeden com.emc.networker... Plugins.
2) Melden Sie sich über SSH beim vCenter-Server an.
3) Starten Sie den vSphere Web Client-Service auf dem vCenter Server neu, siehe: https://docs.vmware.com/en/VMware-vSphere/7.0/com.vmware.vsphere.vcenter.configuration.doc/GUID-A0BB46B0-DE71-4C62-A5BF-22B17ED8AA98.html
1) Melden Sie sich mit dem konto administrator@vsphere.local beim vCenter Managed Object Browser (MOB) an. Der ZUGRIFF auf das GANG kann über einen Webbrowser erfolgen, der den Hostnamen/die IP-Adresse des vCenter erreichen kann: https://vcenter_name/thunderbolt
a) Wählen Sie bei der Anmeldung am MOB Inhalt
b) Wählen Sie im Fenster "Service Content" die Option "ExtensionManager
c" aus. Wählen Sie im Fenster "ExtensionList" mehr aus...
d) Es gibt 3 Erweiterungen für das NetWorker vSphere-Webclient-Plug-in, diese müssen entfernt werden:
b) Wählen Sie im Fenster "Service Content" die Option "ExtensionManager
c" aus. Wählen Sie im Fenster "ExtensionList" mehr aus...
d) Es gibt 3 Erweiterungen für das NetWorker vSphere-Webclient-Plug-in, diese müssen entfernt werden:
e) Wählen Sie unter Methoden die Option UnregisterExtension
f) Geben Sie im Fenster UnregisterExtension den Erweiterungsnamen ein und wählen Sie Methode aufrufen aus:
f) Geben Sie im Fenster UnregisterExtension den Erweiterungsnamen ein und wählen Sie Methode aufrufen aus:
Hinweis: Wenn "Method Invocation Result: void" angezeigt wird, können Sie das nächste Plug-in angeben und entfernen. Wiederholen Sie diese Methode für jeden com.emc.networker... Plugins.
g) Aktualisieren Sie das Fenster GPU ExtensionManager. Die Plug-ins com.emc.networker sollten aus der Erweiterungsliste entfernt werden.
2) Melden Sie sich über SSH beim vCenter-Server an.
a) Die Datei com.emc.networker.. dir muss aus der Serenity-DB des vCenter Servers entfernt werden.
Linux: /etc/vmware/vsphere-client/vc-packages/vsphere-client-serenity
Hinweis: Dieser Speicherort kann je nach vCenter-Version variieren. Weitere Informationen zu Pfaden finden Sie in der VMware-Dokumentation, wenn das Plug-in oben nicht gefunden werden kann.
Z. B.:
Hinweis: Dieser Speicherort kann je nach vCenter-Version variieren. Weitere Informationen zu Pfaden finden Sie in der VMware-Dokumentation, wenn das Plug-in oben nicht gefunden werden kann.
Z. B.:
root@vcenter65 [ ~ ]# ls -l /etc/vmware/vsphere-client/vc-packages/vsphere-client-serenity
total 8
drwxr-xr-x 3 vsphere-client users 4096 Nov 6 17:02 com.emc.networker-9.2.1246
drwxr-xr-x 3 vsphere-client users 4096 Jul 6 17:06 com.vmware.vsan.health-6.5.0
b) Das Plug-in kann durch Löschen des Ordners com.emc.networker entfernt werden.
3) Starten Sie den vSphere Web Client-Service auf dem vCenter Server neu, siehe: https://docs.vmware.com/en/VMware-vSphere/7.0/com.vmware.vsphere.vcenter.configuration.doc/GUID-A0BB46B0-DE71-4C62-A5BF-22B17ED8AA98.html
4) Warten Sie, bis die vSphere Web Client Services gestartet wurden. Sie können sich beim vSphere Web Client anmelden.
5) Melden Sie sich beim NMC an und versuchen Sie erneut, das Plug-in zu installieren.
6) Melden Sie sich beim vSphere-Webclient ab und melden Sie sich wieder an.
5) Melden Sie sich beim NMC an und versuchen Sie erneut, das Plug-in zu installieren.
6) Melden Sie sich beim vSphere-Webclient ab und melden Sie sich wieder an.
Betroffene Produkte
NetWorkerProdukte
NetWorkerArtikeleigenschaften
Artikelnummer: 000166557
Artikeltyp: Solution
Zuletzt geändert: 30 Apr. 2025
Version: 5
Antworten auf Ihre Fragen erhalten Sie von anderen Dell NutzerInnen
Support Services
Prüfen Sie, ob Ihr Gerät durch Support Services abgedeckt ist.