Zu den Hauptinhalten
  • Bestellungen schnell und einfach aufgeben
  • Bestellungen anzeigen und den Versandstatus verfolgen
  • Erstellen Sie eine Liste Ihrer Produkte, auf die Sie jederzeit zugreifen können.
  • Verwalten Sie mit der Unternehmensverwaltung Ihre Dell EMC Seiten, Produkte und produktspezifischen Kontakte.

Fejlfinding for fejl af typen "RPC-server ikke tilgængelig"

Zusammenfassung: Denne artikel beskriver løsninger på fejlen "RPC-server ikke tilgængelig" i Windows Server-operativsystemer.

Dieser Artikel wurde möglicherweise automatisch übersetzt. Wenn Sie eine Rückmeldung bezüglich dessen Qualität geben möchten, teilen Sie uns diese über das Formular unten auf dieser Seite mit.

Artikelinhalt


Symptome
Rpc-tjenestenavn-løsningsproblemer



stoppetTraffic blokeret af problemer med firewalltilslutning

Ursache
Se løsningsafsnittet.
Lösung

Indholdsfortegnelse

  1. Indledning
  2. RPC-tjeneste stoppet
  3. Problemer med navneoversættelse
  4. Trafik blokeret af firewall
  5. Tilslutningsproblemer

1. Indledning

"RPC-serveren er ikke tilgængelig" er en almindelig fejl i Windows, der opstår i en lang række situationer, hvoraf de fleste involverer kommunikation mellem to maskiner via et netværk. Det kan også forekomme under lokale handlinger på en maskine. For tydeligheds skyld betegnes den maskine, der i denne artikel starter RPC-kommunikation, klienten, og den maskine, som den kommunikerer med, er serveren.

Remote Procedure Call (RPC) er en mekanisme, der gør Windows-processer i mulighed for at kommunikere enten mellem en klient og en server på tværs af et netværk eller på en enkelt computer. Mange integrerede Windows-komponenter bruger RPC. RPC bruger dynamiske porte til kommunikation mellem computere, men en statisk port (TCP-port 135) skal også bruges som udgangspunkt for kommunikationen. RPC-slutpunktsmapperen lytter på denne statiske port.

I en typisk RPC-session kontakter en klient en servers slutpunktsmapper på TCP-port 135 og anmoder om det dynamiske portnummer, der er tildelt en bestemt tjeneste. Serveren svarer med den IP-adresse og det portnummer, som tjenesten registrerede hos RPC, da den startede. Klienten kontakter derefter tjenesten på denne IP-adresse og port.

Mulige årsager til fejlen "RPC-server utilgængelig" kan være følgende:        

  • RPC-tjeneste stoppet: Hvis RPC-tjenesten på serveren ikke kører, kan klienten ikke få adgang til den.
  • Navnefortolkningsproblemer: RPC-serverens navn kan være løsningen på den forkerte IP-adresse, hvilket resulterer i, at klienten kontakter den forkerte server eller forsøger at kontakte en IP-adresse, der ikke er i brug. Alternativt er serverens navn slet ikke løsningen på problemet.
  • Trafik blokeret af firewall: En firewall eller et andet sikkerhedsprogram på serveren eller en netværks firewallenhed mellem klienten og serveren kan forhindre trafikken i at nå frem til serveren på TCP-port 135.
  • Forbindelsesproblemer: Klienten kan muligvis ikke få adgang til serveren på grund af et generelt netværksproblem.
     

Følgende trin kan være nyttige ved fejlfinding af problemet. Trinnene kategoriseres efter årsag.


2. RPC-tjeneste stoppet

  1. Åbn Tjeneste-konsollen på serveren.
  2. Find RPC-tjenesten (Remote Procedure Call), og sørg for, at den kører.
    BEMÆRK: Rpc-Locator-tjenesten (Remote Procedure Call) kører typisk ikke.
  3. Hvis tjenesten er stoppet, skal du forsøge at starte den manuelt.
     

3. Navneoversættelsesproblemer

  1. Ping serveren efter navn fra klienten for at bekræfte, at navnet oversætter til den rigtige IP-adresse. Hvis den gør, er det formodentligt ikke navneoversættelsen, der forårsager problemet, og resten af trinene i dette afsnit kan springes over.
  2. Hvis klienten og serveren er medlemmer af et Active Directory-domæne (AD), bruges DNS til navneoversættelse. Kontrollér, at klienten og serveren begge anvender de rigtige DNS-servere, der skal være inden for domænet og typisk er domænecontrollere.
  3. Hvis de korrekte DNS-servere bruges, skal du bruge DNS Management-konsollen på disse servere til at kontrollere, at RPC-serveren har en eller flere korrekte poster registreret i DNS. Kommandoen ipconfig /registerdns kan om nødvendigt bruges på RPC-serveren til at genregistrere dens DNS-poster.
  4. Hvis et AD-domæne ikke er tilgængeligt, kan WINS anvendes til navneoversættelse. Ipconfig/all-kommandolisten indeholder bl.a. WINS-servere, der bruges af RPC-serveren. Kontroller WINS-databasen på disse servere for at kontrollere, at de poster, der er registreret for RPC-serveren, er korrekte. Kommandoen nbtstat -RR kan om nødvendigt køre på RPC-serveren for at genregistrere dens WINS-poster.
     

4. Trafik blokeret af firewall

  1. Kontroller Windows Firewall-indstillingerne på RPC-serveren.
  2. Hvis firewallen er aktiveret, skal du sørge for, at trafikken på TCP-port 135 kan passere.
    1. Hvis serveren kører Windows Server 2003, håndterer Windows Firewall muligvis ikke den dynamiske RPC-porttildeling korrekt. Hvis det er tilfældet, kan det være nødvendigt at deaktivere Windows Firewall eller begrænse de porte, der bruges af RPC (se trin 4).
    2. Hvis serveren kører Windows Server 2008 eller nyere, skal du kontrollere, at Windows Firewall-tjenesten kører. Windows Firewall i Windows Server 2008 og nyere bør som standard håndtere RPC-trafik korrekt. Men hvis dette skal konfigureres manuelt, skal du se denne TechNet-artikel for at få instruktioner: Tillade indgående netværkstrafik, der bruger dynamisk RPC.
      Hvis Windows Firewall skal deaktiveres i Windows Server 2008 eller nyere, skal du ikke stoppe Windows Firewall-tjenesten. Følg i stedet trinnene i Sådan deaktiveres Windows Firewall i Windows Server 2008 og nyere korrekt.
  3. Hvis tredjeparts firewallsoftware, et andet sikkerhedsprogram eller et firewallprogram til netværk er installeret, skal du se i dokumentationen til programmet eller udstyret for at afgøre, om det er korrekt konfigureret til at kunne håndtere RPC-trafik.
  4. Hvis firewallsoftwaren, et andet sikkerhedsprogram eller netværksenhed ikke kan konfigureres til at håndtere dynamisk RPC-trafik korrekt, kan det portinterval, der bruges af RPC, begrænses, og dette interval kan derefter åbnes i firewallen eller sikkerhedsprogrammet. Se Hvordan konfigureres dynamisk porttildeling i RPC til at virke med firewalls for at begrænse det portinterval, som RPC benytter.
     

5. Tilslutningsproblemer

  1. Brug kommandoen ping til at teste grundlæggende tilslutningsmuligheder mellem RPC-klienten og serveren. Bemærk, at testen ikke er endegyldig, så det er muligt for en firewall at blokere ICMP-trafik og samtidig tillade anden trafik at passere. (ICMP eller Internet Control Message Protocol er den protokol, der bruges af ping- og tracert-kommandoerne).
  2. Kommandolinjeværktøjet PortQry kan bruges til at teste tilslutningsmulighederne fra klienten til serveren og bestemme, hvilke porte der er åbne på serveren. Den omfatter understøttelse af RPC og kan bruges til at bestemme, hvilke tjenester der har dynamiske porte, der er registreret med RPC, og hvilke specifikke porte de bruger. Detaljerede oplysninger om PortQry version 2.0 er tilgængelig her: Nye funktioner i PortQry version 2.0.
  3. Hvis klienten og serveren er på forskellige undernet, skal du kontrollere, at trafikken styres korrekt mellem de to. Hvis de befinder sig på forskellige fysiske placeringer, skal du kontrollere, at forbindelsen mellem stederne er åben og lader trafikken passere frit.


Du kan finde yderligere oplysninger om fejlfinding af denne fejl under Fejlfinding af "RPC-serveren er ikke tilgængelig".

Du kan få generelle oplysninger om RPC under Hvad er RPC?
 


 
Weitere Informationen
 
 

Support uden for garantien Er garantien udløbet? Intet problem. Gå til webstedet Dell.com/support, og indtast din Dell-servicekode for at se vores tilbud.

BEMÆRK: Tilbud er kun tilgængelige for pc-kunder i USA, Canada, Storbritannien og Nordirland, Frankrig, Tyskland og Kina. Server og storage er ikke omfattet.

Artikeleigenschaften


Betroffenes Produkt

Servers

Letztes Veröffentlichungsdatum

14 Feb 2022

Version

6

Artikeltyp

Solution