Zu den Hauptinhalten
  • Bestellungen schnell und einfach aufgeben
  • Bestellungen anzeigen und den Versandstatus verfolgen
  • Erstellen Sie eine Liste Ihrer Produkte, auf die Sie jederzeit zugreifen können.
  • Verwalten Sie mit der Unternehmensverwaltung Ihre Dell EMC Seiten, Produkte und produktspezifischen Kontakte.

Felsökning av feltypen RPC-servern är inte tillgänglig

Zusammenfassung: I den här artikeln beskrivs lösningarna på felet "RPC Server unavailable" (RPC-servern är inte tillgänglig) i Windows Server-operativsystem.

Dieser Artikel wurde möglicherweise automatisch übersetzt. Wenn Sie eine Rückmeldung bezüglich dessen Qualität geben möchten, teilen Sie uns diese über das Formular unten auf dieser Seite mit.

Artikelinhalt


Symptome
Stoppad RPC-problemlösning



blockerad av brandväggsanslutningsproblem

Ursache
Läs mer i avsnittet Upplösning.
Lösung

Innehållsförteckning

  1. Introduktion
  2. Stoppad RPC-tjänst
  3. Namnmatchningsproblem
  4. Trafiken blockeras av brandväggen
  5. Anslutningsproblem

1. Introduktion

"RPC-servern är inte tillgänglig" är ett vanligt fel i Windows som uppstår i en mängd olika situationer, de flesta innefattar kommunikation mellan två datorer i ett nätverk. Det kan också inträffa under lokala åtgärder på en dator. För tydlighetens skull kallas maskinen som initierar RPC-kommunikationen för klienten och datorn som den kommunicerar med servern för.

Remote Procedure Call (RPC) är en mekanism som gör att Windows-processer kan kommunicera, antingen mellan en klient och server i ett nätverk eller inom en enda dator. Många integrerade Windows-komponenter använder RPC. RPC använder dynamiska portar för kommunikation mellan datorer, men en statisk port (TCP-port 135) måste också användas som kommunikationsstart. RPC-slutpunktsmappningen lyssnar på den här statiska porten.

I en typisk RPC-session kontaktar klienten serverns slutpunktsmappning på TCP-port 135 och begär det dynamiska portnumret som är tilldelat till en viss tjänst. Servern svarar med den IP-adress och det portnummer som tjänsten registrerade när RPC startades. Klienten kontaktar sedan tjänsten med den IP-adressen och -porten.

Möjliga orsaker till felet "RPC-servern är inte tillgänglig" omfattar följande:        

  • Stoppad RPC-tjänst: Om RPC-tjänsten på servern inte körs kan klienten självklart inte nå den.
  • Namnmatchningsproblem: RPC-serverns namn kan matcha fel IP-adress, vilket leder till att klienten kontaktar fel server eller försöker kontakta en IP-adress som inte används. Eller så kanske servernamnet inte hittas.
  • Trafiken blockeras av brandväggen: En brandvägg eller något annat säkerhetsprogram på servern eller en nätverksbrandvägg mellan klienten och servern kan hindra trafiken från att nå servern på TCP-port 135.
  • Anslutningsproblem: Klienten kanske inte kan nå servern alls på grund av ett allmänt nätverksproblem.
     

Följande steg kan vara användbara vid felsökning av problemet. Stegen är kategoriserade efter orsak.


2. Stoppad RPC-tjänst

  1. Öppna tjänstekonsolen på servern.
  2. Leta upp tjänsten Remote Procedure Call (RPC) och kontrollera att den körs.
    OBS! Tjänsten Remote Procedure Call (RPC) Locator körs normalt inte.
  3. Om tjänsten har stoppats försöker du starta den manuellt.
     

3. Namnmatchningsproblem

  1. Anropa servern efter namn från klienten för att kontrollera att namnet leder till rätt IP-adress. I så fall rör det sig troligen inte om ett namnmatchningsproblem och du kan hoppa över stegen i det här avsnittet.
  2. Om klienten och servern ingår i en Active Directory (AD)-domän används DNS för namnmatchning. Kontrollera att klienten och servern båda använder rätt DNS-servrar. De bör finnas i domänen och är vanligtvis domänstyrenheter.
  3. Om rätt DNS-servrar används använder du DNS-hanteringskonsolen på dessa servrar för att kontrollera att RPC-servern har en eller flera korrekta poster registrerade i DNS. Vid behov kan kommandot ipconfig /registerdns användas på RPC-servern för att registrera dess DNS-poster på nytt.
  4. Om en AD-domän saknas kan WINS användas för namnmatchning. I kommandolistan ipconfig /all, bland annat, de WINS-servrar som används av RPC-servern. Kontrollera WINS-databasen på dessa servrar för att kontrollera att de poster som är registrerade för RPC-servern är korrekta. Vid behov kan kommandot nbtstat -RR köras på RPC-servern för att registrera om WINS-posterna.
     

4. Trafiken blockeras av brandväggen

  1. Kontrollera inställningarna för Windows-brandväggen på RPC-servern.
  2. Om brandväggen är aktiverad kontrollerar du att trafiken på TCP-port 135 tillåts passera.
    1. Om servern kör Windows Server 2003 kanske Windows-brandväggen inte kan hantera fördelningen av dynamiska RPC-portar. I det här fallet kan det bli nödvändigt att avaktivera Windows-brandväggen eller begränsa de portar som används av RPC (se steg 4).
    2. Om servern kör Windows Server 2008 eller senare kan du kontrollera att Windows-brandväggen är igång. Windows-brandväggen i Windows Server 2008 och senare bör hantera RPC-trafik som standard. Men om detta måste konfigureras manuellt kan du läsa Den här TechNet-artikeln för instruktioner: Tillåta inkommande nätverkstrafik som använder dynamisk RPC.
      Om Windows-brandväggen måste avaktiveras i Windows Server 2008 eller senare ska du inte stoppa tjänsten Windows-brandväggen. Följ istället stegen i Stänga av Windows-brandväggen i Windows Server 2008 och senare.
  3. Om brandväggsprogram av tredje part, andra säkerhetsprogram eller nätverksbrandväggar har installerats kan du läsa programmens eller utrustningens dokumentation för att fastställa om de kan konfigureras för RPC-trafik.
  4. Om brandväggsprogrammet, andra säkerhetsprogram eller nätverksanordningar inte kan konfigureras för att hantera dynamisk RPC-trafik kan det portintervall som används av RPC begränsas, och det intervallet kan sedan öppnas i brandväggen eller säkerhetsprogrammet. Läs Så konfigurerar du fördelningen av dynamiska RPC-portar när du vill arbeta med brandväggar om du vill begränsa det portintervall som används av RPC.
     

5. Problem med nätverksanslutningen

  1. Använd kommandot ping om du vill testa grundläggande anslutning mellan RPC-klient och server. Observera att det här testet kanske inte är avgörande, eftersom brandväggar kan blockera ICMP-trafik fastän annan trafik får passera. (ICMP eller Internet Control Message Protocol är det protokoll som används av ping- och tracert-kommandona.)
  2. Kommandoradsverktyget PortQry kan användas för att testa anslutningen från klienten till servern och bestämma vilka portar som är öppna på servern. Det omfattar stöd för RPC och kan användas för att avgöra vilka tjänster som har dynamiska portar som är registrerade med RPC och vilka specifika portar de använder. Detaljerad information om PortQry version 2.0 finns tillgänglig här: Nya funktioner i PortQry version 2.0.
  3. Om klienten och servern ligger på olika subnät bör du kontrollera att trafiken skickas rätt mellan dem. Om de finns på olika fysiska platser kontrollerar du att länken mellan platserna är uppe och låter trafiken passera fritt.


Ytterligare anvisningar om hur du felsöker det här felet finns i Felsökning av "RPC-servern är inte tillgänglig".

Allmän information om RPC finns i Vad är RPC?
 


 
Weitere Informationen
 
 

Support efter garantin Har garantin upphört att gälla? Inga problem. Gå till webbplatsen Dell.com/support och ange ditt Dell Service Tag-nummer för att se våra erbjudanden.

OBS! Erbjudanden är endast tillgängliga för kunder i USA, Kanada, Storbritannien, Frankrike, Tyskland och Kina som köper en personlig dator. Det här gäller inte servrar och lagring.

Artikeleigenschaften


Betroffenes Produkt

Servers

Letztes Veröffentlichungsdatum

14 Feb 2022

Version

6

Artikeltyp

Solution