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Risoluzione degli errori di server RPC non disponibile

Zusammenfassung: Questo articolo illustra le soluzioni per l'errore "Rpc Server Unavailable" nei sistemi operativi Windows Server.

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Artikelinhalt


Symptome
Interruzione dei problemi di risoluzione dei nomi

di servizio

RPCTraffic bloccato da problemi di connessione del firewall

Ursache
Consultare la sezione Risoluzione.
Lösung

Sommario

  1. Introduzione
  2. Servizio RPC interrotto
  3. Problemi di risoluzione dei nomi
  4. Traffico bloccato dal firewall
  5. Problemi di connettività

1. Introduzione

"Il server RPC non è disponibile" è un errore comune in Windows che si verifica in un'ampia varietà di situazioni, la maggior parte delle quali comporta la comunicazione tra due computer all'interno di una rete. Può anche verificarsi durante le operazioni locali su un computer. Per chiarezza, in questo articolo, il computer che avvia la comunicazione RPC è definito client e il computer con cui comunica è il server.

RPC (Remote Procedure Call) è un meccanismo che consente ai processi di Windows di comunicare tra un client e un server in rete o all'interno di un singolo computer. Numerosi componenti integrati di Windows utilizzano RPC. RPC utilizza porte dinamiche per la comunicazione tra computer, ma anche una porta statica (porta TCP 135) deve essere utilizzata come punto di partenza per la comunicazione. Il mapper degli endpoint RPC è in ascolto su questa porta statica.

In una sessione RPC tipica, un client contatta il mapper degli endpoint di un server sulla porta TCP 135 e richiede il numero di porta dinamica assegnato a un particolare servizio. Il server risponde con l'indirizzo IP e il numero di porta che il servizio ha registrato con RPC al momento dell'avvio. Il client contatta quindi il servizio su indirizzo IP e porta.

Le possibili cause dell'errore di server RPC non disponibile sono le seguenti:        

  • Servizio RPC interrotto: Se il servizio RPC sul server non è in esecuzione, il client non è ovviamente in grado di raggiungerlo.
  • Problemi di risoluzione dei nomi: Il nome del server RPC potrebbe risolvere l'indirizzo IP errato e di conseguenza il client contatta il server errato o tenta di contattare un indirizzo IP non in uso. In alternativa, il nome del server potrebbe non essere risolto affatto.
  • Traffico bloccato dal firewall: Un firewall o un'altra applicazione di sicurezza sul server o un appliance firewall di rete tra il client e il server potrebbero impedire al traffico di raggiungere il server sulla porta TCP 135.
  • Problemi di connettività: Il client potrebbe non essere in grado di raggiungere il server a causa di un problema di rete generale.
     

La procedura riportata di seguito può essere utile per risolvere il problema. I passaggi sono suddivisi in categorie per causa.


2. Servizio RPC interrotto

  1. Accedere alla console dei servizi sul server.
  2. Individuare il servizio RPC (Remote Procedure Call) e verificare che sia in esecuzione.
    NOTA: Il servizio Remote Procedure Call (RPC) Locator in genere non è in esecuzione.
  3. Se il servizio è interrotto, provare a riavviarlo manualmente.
     

3. Problemi di risoluzione dei nomi

  1. Effettuare il ping del server dal client per verificare che il nome si risolva nell'indirizzo IP corretto. In caso affermativo, probabilmente la causa del problema non è la risoluzione dei nomi ed è possibile ignorare le altre operazioni descritte in questa sezione.
  2. Se il client e il server sono membri di un dominio di Active Directory (AD), per la risoluzione dei nomi viene utilizzato il DNS. Verificare che il client e il server stiano entrambi utilizzando i server DNS corretti, i quali devono trovarsi all'interno del dominio e sono in genere controller di dominio.
  3. Se vengono utilizzati i server DNS corretti, utilizzare la console di gestione DNS su tali server per verificare che nel server RPC siano registrati uno o più record corretti nel DNS. Se necessario, è possibile immettere il comando ipconfig /registerdns sul server RPC per registrare nuovamente i relativi record DNS.
  4. Se non è presente alcun dominio AD, è possibile utilizzare WINS per la risoluzione dei nomi. L'elenco dei comandi ipconfig /all, tra le altre cose, i server WINS utilizzati dal server RPC. Controllare il database WINS su questi server per verificare che i record registrati per il server RPC siano corretti. Se necessario, è possibile eseguire il comando nbtstat -RR sul server RPC per registrare nuovamente i relativi record WINS.
     

4. Traffico bloccato dal firewall

  1. Controllare le impostazioni di Windows Firewall sul server RPC.
  2. Se il firewall è abilitato, assicurarsi che sia consentito il passaggio del traffico sulla porta TCP 135.
    1. Se il server esegue Windows Server 2003, è possibile che Windows Firewall non gestisca correttamente l'allocazione delle porte dinamiche RPC. In questo caso, potrebbe essere necessario disattivare Windows Firewall o limitare le porte utilizzate da RPC (vedere il passaggio 4).
    2. Se il server esegue Windows Server 2008 o versione successiva, verificare che il servizio Windows Firewall sia in esecuzione. Windows Firewall in Windows Server 2008 e versioni successive deve gestire correttamente il traffico RPC per impostazione predefinita; Tuttavia, se è necessario configurarlo manualmente, consultare questo articolo di TechNet per istruzioni: Consentire il traffico di rete in entrata che utilizza LA RPC dinamica.
      Se è necessario disabilitare Windows Firewall in Windows Server 2008 o versioni successive, non arrestare il servizio Windows Firewall. e seguire invece la procedura descritta in Windows Server: come disattivare correttamente Windows Firewall in Windows Server 2008 e versioni successive (in inglese).
  3. Se è in uso un software firewall di terze parti, un'altra applicazione di sicurezza o un appliance firewall di rete, consultare la relativa documentazione per verificare se sia possibile configurare correttamente l'applicazione o l'appliance per gestire il traffico RPC.
  4. Se il software firewall, l'altra applicazione di sicurezza o l'appliance di rete non possono essere configurati per gestire correttamente il traffico RPC dinamico, l'intervallo di porte utilizzato da RPC può essere limitato e questo intervallo può essere aperto sul firewall o sull'applicazione di sicurezza. Per limitare l'intervallo di porte utilizzato da RPC, consultare l'articolo Configurazione dell'allocazione delle porte dinamiche RPC perché funzionino con i firewall.
     

5. Problemi di connettività di rete

  1. Utilizzare il comando ping per testare la connettività di base tra il server e il client RPC. Si noti che questo test potrebbe non essere decisivo, in quanto è possibile che un firewall blocchi il traffico ICMP consentendo al contempo il passaggio di altro traffico ICMP, o Internet Control Message Protocol, è il protocollo utilizzato dai comandi ping e tracert.
  2. È possibile utilizzare l'utility da riga di comando PortQry per testare la connettività dal client al server e determinare quali sono le porte aperte sul server. Include il supporto per RPC e può essere utilizzato per determinare quali servizi dispongono di porte dinamiche registrate con RPC e quali porte specifiche utilizzano. Le informazioni dettagliate su PortQry versione 2.0 sono disponibili qui: Nuove funzioni e funzionalità in PortQry versione 2.0.
  3. Se il client e il server si trovano su subnet diverse, verificare che il traffico sia indirizzato correttamente tra le due subnet. Se si trovano in posizioni fisiche diverse, verificare che il collegamento tra i siti sia attivo e che consenta il libero passaggio del traffico.


Per ulteriori istruzioni sulla risoluzione di questo errore, vedere Risoluzione dei problemi del server RPC non disponibile.

Per informazioni generali su RPC, vedere Che cos'è RPC?
 


 
Weitere Informationen
 
 

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Artikeleigenschaften


Betroffenes Produkt

Servers

Letztes Veröffentlichungsdatum

14 Feb 2022

Version

6

Artikeltyp

Solution