Módulo de NetWorker para bases de datos y aplicaciones: El respaldo en línea de DB2 falla con el error "SQL2413N respaldo en línea no se permite porque la base de datos no se puede recuperar"

Zusammenfassung: El respaldo en línea de DB2 de NMDA falla con un error nsrdasv: no se puede respaldar la base de datos de muestra debido a una falla en la solicitud de respaldo SQLCODE: -2413, no se permite SQL2413N respaldo en línea porque la base de datos no se puede recuperar. ...

Dieser Artikel gilt für Dieser Artikel gilt nicht für Dieser Artikel ist nicht an ein bestimmtes Produkt gebunden. In diesem Artikel werden nicht alle Produktversionen aufgeführt.

Symptome

Un respaldo de DB2 de NetWorker Module for Databases and Applications (NMDA) que se realiza desde NetWorker Management Console (NMC) o desde el servidor DB2 falla con el siguiente error:
"SQL2413N respaldo en línea no se permite porque la base de datos no se puede recuperar".

Ursache

Cada base de datos DB2 instalada se encuentra en el registro circular de forma predeterminada. Los respaldos en línea no son posibles en el registro circular.

Lösung

Habilite el registro de archivo de DB2.

Los pasos de ejemplo que se muestran a continuación son para una base de datos DB2 denominada 'Db4'.
1. Abra la ventana de comandos de DB2 en el cliente.
2. Compruebe el modo de registro de DB2 mediante el comando, como se muestra en la captura de pantalla siguiente: 
image.png

3. Actualice logarchmeth y logarchopt con un valor distinto de "OFF". Por ejemplo:
image.png
 
4. Con NMDA, los registros de transacciones de DB2 se pueden archivar automáticamente en el almacenamiento de Data Domain. Consulte la guía de administración de NMDA para conocer los pasos detallados.
 

Weitere Informationen

La Guía de administración del módulo de NetWorker para bases de datos y aplicaciones está disponible en el soporte de Dell en: https://www.dell.com/support/home/product-support/product/networker-module-for-databases-and-applications/docs.
Artikeleigenschaften
Artikelnummer: 000191364
Artikeltyp: Solution
Zuletzt geändert: 09 März 2022
Version:  1
Antworten auf Ihre Fragen erhalten Sie von anderen Dell NutzerInnen
Support Services
Prüfen Sie, ob Ihr Gerät durch Support Services abgedeckt ist.