VxRail: Feilsøkingsveiledning for VMware ESXi-verter i tilstanden Svarer ikke
Zusammenfassung: Denne artikkelen gir svar på problemer med virtuelle maskiner (VM-er) som befinner seg på ESXi-verter som ikke svarer, og hjelper til med å sette ESXi-vertene tilbake til en stabil tilstand. ...
Symptome
- ESXi-verten rapporterte at han ikke svarer på vSphere-webklienten.
- Kan ikke administrere ESXi-verter fra en vSphere-webklient.
- Kunne pinge ESXi-verten som ikke svarer og de virtuelle maskinene på den.
- Har tilgang til virtuelle maskiner via SSH eller Remote Desktop Protocol (RDP) som kjører på ESXi-verten.
Ursache
En av administrasjonstjenestene på verten kan ha mislyktes eller gått inn i tilstanden Svarer ikke.
Dette krever rotårsaksanalyse om hvorfor administrasjonstjenestene mislyktes eller sluttet å svare. Samle inn vCenter-serveren og ESXi-vertsloggene ved å referere til VMware-artikkelen Innsamling av diagnoseinformasjon for VMware ESXi før klyngen og ESXi bringes til en stabil tilstand.
Noen ganger er dette umulig, siden noden ikke svarer på kommandoene for å samle inn logger. Se gjennom informasjonen i Løsning-delen i denne artikkelen. Logger kan analyseres via Dells kundestøtte hvis det er nødvendig for å forstå hovedårsaken for å kontrollere om de kjente problemene nedenfor er relatert til problemet.
Lösung
Starte hostd eller vpxa på verten kan bidra til å bringe tilbake vertsadministrasjonen på vSphere-klienten. Dette gjøres ved hjelp av en SSH-økt til ESXi-verten.
Et annet svar til en ESXi-vert som ikke svarer, er å starte administrasjonsagentene på ESXi-vertene på nytt.
services.sh Start på nytt, kommando Omstart av vertens administrasjonsagenter kan påvirke kjørende oppgaver, inkludert innvirkning på gjeste-VM-ene på verten.
Omstart av administrasjonsagenter for ESXi-verter gjøres direkte ved hjelp av en CLI- eller SSH-økt til ESXi (hvis SSH er aktivert før problemet).
Hvis SSH ikke er aktivert, får du tilgang til BMC-iDRAC-porten som gir tilgang til ESXi DCUI-skjermen, der administrasjonstjenestene kan startes på nytt. Se VMware-artikkelen 1003490 for å starte administrasjonsagentene på nytt i ESXi.
DCUI kan slutte å svare. Manuell avslutning av virtuelle maskiner ved hjelp av SSH eller RDP er det eneste andre alternativet for å bringe miljøet tilbake til en stabil tilstand. Når du er ferdig, bruker du BMC-iDRAC Power Control til å slå ESXi-verten av og på for å få ESXi-verten til en stabil tilstand.
Registrer de virtuelle maskinene til stabile verter rett etter at du har slått av de virtuelle maskinene, og reduser dermed nedetiden for VM-er før du starter ESXi-verten som ikke svarer på nytt. (Deretter kan ESXi-verten med problemer startes på nytt.) Følg VMware-artikkelen om hvordan du registrerer eller legger til en virtuell maskin (VM) i vSphere-beholdningen i vCenter Server
Hvis du ikke får slått av de virtuelle maskinene ved hjelp av SSH eller RDP, må du avslutte en virtuell maskin via ESXi-vertsøkten for SSH. Se VMware-artikkelen Unable to power off a virtual machine in an ESXi host
Problemer med virtuell maskin:
- Kan ikke slå av de virtuelle maskinene i en ESXi-vert – 1014165
- Slå av en VM som ikke svarer på en ESXi-vert – 1004340
- VM-er vises som ugyldige eller isolerte i vCenter Server – 1003742
- VM-er ser ut til å kjøre eller registreres på flere ESX-/ESXi-servere – 319918
- Slå på en virtuell maskin fra kommandolinjen når verten ikke kan administreres med vSphere Client – 1038043
- Feilsøke en VM som har sluttet å svare – 1007819