OMSA: 10.1 Antwortet nicht auf WMI- und SNMP-Abfragen von DELL_CM
Zusammenfassung: Dell OpenManage Server Administrator 10.1.0 und höher reagiert nicht mehr auf direkte WMI- oder SNMP-Abfragen von sechs DELL_CMxxxx Klassen verschiedener Systembestandselemente. Dies ist auf die Entscheidung eines Dell Technikers zurückzuführen, das zugrunde liegende IC-Modul (Inventory Collector) aus Sicherheits- und Installationspaketgrößenbeschränkungen zu entfernen. ...
Symptome
Die Abfrage der folgenden Klassen von Dell OpenManage Server Administrator (OMSA) 10.1.0 und höher gibt jetzt Nullergebnisse zurück:
DELL_CMApplicationDELL_CMDeviceDELL_CMDeviceApplicationDELL_CMInventoryDELL_CMOSDELL_CMProductInfo
Diese Klassen bieten verschiedene Bestandsinformationen, wie z. B. aktuelle Firmware- und Treiberversionen von Systemkomponenten, grundlegende Betriebssysteminformationen usw.
Ursache
Die technische Abteilung von Dell hat beschlossen, das IC-Modul (Inventory Collector) nicht mehr zu bündeln, da veraltete Versionen in OMSA verbleiben, große Installationsgrößen- und Bandbreiteneinschränkungen sowie Sicherheitsbedenken bestehen. In früheren Jahren unterstützte IC in erster Linie sowohl Dell IT Assistant als auch Dell OpenManage Essentials. OMSA 9.5 war die letzte Bundle-Version von IC. Beide Produkte werden nicht mehr unterstützt und werden durch Dell OpenManage Enterprise ersetzt, das für diese Bestandsaufnahme auf iDRAC anstelle von OMSA basiert.
Lösung
Wenn Bestandsdaten aus diesen Klassen weiterhin für die direkte WMI- oder SNMP-Programmierung mit OMSA erforderlich sind, laden Sie das IC-Modul manuell unter den folgenden Pfaden herunter und installieren Sie es. Der OMSA Shared Service sollte dann aktiviert und neu gestartet werden:
Windows:
- Erstellen Sie die Ordner "cm" und "
invcol" innerhalb vonC:\Program Files\Dell\SysMgt\ - Laden Sie IC für Windows herunter unter: https://downloads.dell.com/FOLDER07847532M/1/invcol_8YPK7_WIN64_21_12_200_1196_A00.exe
- Benennen Sie den Download in invcol.exe um und verschieben Sie ihn zu
C:\Program Files\Dell\SysMgt\cm\invcol\ - Starten Sie DSM SA Shared Services neu und warten Sie bis zu 10 Minuten, bis IC die erste Bestandsaufnahme abgeschlossen hat.
Linux:
- Laden Sie IC für Linux herunter unter: https://downloads.dell.com/FOLDER07847525M/1/invcol_8YPK7_LN64_21_12_200_1196_A00.BIN
- Umbenennen in
invcolund verschieben Sie nach/opt/dell/srvadmin/sbin/lx64/. - Führen Sie an der Shell-Eingabeaufforderung den folgenden Befehl aus:
srvadmin-services restart