PowerFlex: Fehler bei aktiviertem RMcache

Zusammenfassung: Anwendungen, die PowerFlex-Volumes verwenden, melden eine Beschädigung, wenn RMcache aktiviert ist.

Dieser Artikel gilt für Dieser Artikel gilt nicht für Dieser Artikel ist nicht an ein bestimmtes Produkt gebunden. In diesem Artikel werden nicht alle Produktversionen aufgeführt.

Symptome

Anwendungen, die PowerFlex-Volumes verwenden, melden Beschädigungen, wenn RMcache und Zero Padding nach dem Upgrade des PowerFlex-Codes aktiviert sind.

Festplatte mit aktiviertem RMcache 

RMcache ist nur bei HDDs nützlich. Nicht mit SSDs verwenden.

 

Problem

Beschädigungen sind in den PowerFlex-Protokollen nicht ersichtlich.

Host-SDC-Protokolle melden Ereignisse im Zusammenhang mit Beschädigungen. Die folgende Ausgabe stammt von einem ESXi-SDC:

2022-08-07T02:27:58.992Z cpu15:5421692)SESparse: 1895: Corrupt GTE GTE [valid: 3 gCluster: 117465940656700 gResource: 2304 unused: 1] ;
2022-08-07T02:27:58.993Z cpu15:5421692)BC: 414: read from 36a81bc9-<vm_name>-000001-sesparse.vmdk (def5 24 2b62 3 b1822de0 4309 3 0 0 0 0 0 0 0) 98304 bytes failed: Corrupt RedoLog

 

Auswirkungen

Datenintegrität

Ursache

Wenn von einer Anwendung Daten in den Cache geschrieben werden, werden nur diese Daten gelöscht, sodass andere Nicht-Null-Daten im Cache bleiben.

RMcache-Daten, die nicht gelöscht wurden, können im Rahmen eines nachfolgenden Lesevorgangs an den Client zurückgegeben werden, was zu einem Fehler führt.


 

 

Lösung

Deaktivieren Sie RMcache.

Führen Sie ein Upgrade auf eine neuere PowerFlex-Version durch, die die Korrektur enthält.

 

Betroffene Versionen

3.6.0.4 HF1

3.6.0.5

3.5.1.7

4.0

Behoben in Version

3.6.0.4 HF2

3.6.0Weiter

3.5.1Weiter

4.0.1

 

Betroffene Produkte

PowerFlex Software

Produkte

VxFlex Product Family, VxFlex Ready Node, Ready Node Series
Artikeleigenschaften
Artikelnummer: 000202877
Artikeltyp: Solution
Zuletzt geändert: 27 Nov. 2025
Version:  8
Antworten auf Ihre Fragen erhalten Sie von anderen Dell NutzerInnen
Support Services
Prüfen Sie, ob Ihr Gerät durch Support Services abgedeckt ist.