NetWorker-Modul für Microsoft: SQL AlwaysOn-Verfügbarkeitsgruppencluster mit zwei Nodes: Der Clientassistent konfiguriert listener oder cluster name nicht.

Zusammenfassung: SQL AlwaysOn Availability Group (AAG)-Cluster mit zwei Nodes: Der Clientassistent konfiguriert den Listener- oder Clusternamen nicht.

Dieser Artikel gilt für Dieser Artikel gilt nicht für Dieser Artikel ist nicht an ein bestimmtes Produkt gebunden. In diesem Artikel werden nicht alle Produktversionen aufgeführt.

Symptome

NetWorker Module for Microsoft (NMM) SQL ALlwaysOn Availability Group (AAG) Cluster mit zwei Nodes, Azure, Client Wizard kann Listener- oder Clusternamen nicht konfigurieren.

Das Backup schlägt auch mit dem manuell konfigurierten Client fehl. Beenden Sie Code 1.

Der Assistent schlägt mit dem Meldungsfeld Dispatcher timed out fehl.

Ursache

Da sich der NetWorker-Server im selben Subnetz wie die beiden SQL-Clients befindet, z. B. alle IP-Adressen im selben Subnetz n.n.n.0, verursachen Firewalls dies nicht.

Beachten Sie in der Datei daemon.raw des Servers die folgende Meldung:
2023-09-28 07:02:59 AM   BACKUPSERVER nsrexecd error Unable to create the connection with 'nsrexec' to host 'LISTENER_FQDN'  with address 'N.N.N.X' at port number 7940.
Investigation hat festgestellt, dass der Serviceportbereich auf dem nsrexecd-Service auf einem der Clients zu klein war. Zum Beispiel:
SERVER PORT RANGE is CORRECT DEFAULTS

service ports: 7937-9936;
type: NSR system port ranges;

CLIENT 01 IS CORRECT 
service ports: 7937-9936;
type: NSR system port ranges;

CLIENT NODE 02 IS TOO SMALL 
service ports: 7937-7944;
type: NSR system port ranges;

Lösung

Schritte zur Behebung dieses Fehlers:
  1. Führen Sie den folgenden Befehl sofort auf dem Node mit dem Problem aus:
  nsrports -S  7937-9936
  1. Starten Sie als Vorsichtsmaßnahme den nsrexecd-Service auf demselben Node neu.
  2. Führen Sie den Backup- oder Clientassistenten aus.
Artikeleigenschaften
Artikelnummer: 000218108
Artikeltyp: Solution
Zuletzt geändert: 06 Okt. 2023
Version:  2
Antworten auf Ihre Fragen erhalten Sie von anderen Dell NutzerInnen
Support Services
Prüfen Sie, ob Ihr Gerät durch Support Services abgedeckt ist.