SDNAS do PowerStore: Os arquivos aparecem ocultos quando salvos no compartilhamento SMB de clients MacOS
Zusammenfassung: Os arquivos criados por alguns aplicativos do macOS, como MS Office ou Adobe, aparecem ocultos quando salvos em um compartilhamento SMB no equipamento PowerStore.
Dieser Artikel gilt für
Dieser Artikel gilt nicht für
Dieser Artikel ist nicht an ein bestimmtes Produkt gebunden.
In diesem Artikel werden nicht alle Produktversionen aufgeführt.
Symptome
Os arquivos criados por alguns aplicativos do macOS, como MS Office ou Adobe, aparecem ocultos quando salvos em um compartilhamento SMB no equipamento PowerStore.
Ursache
Alguns aplicativos em execução no MacOS usam SetInfo para remover o atributo de arquivo oculto temporário por meio do ADS (Alternate Data Stream) em vez do arquivo primário quando os arquivos são criados/salvos em um compartilhamento SMB. No PowerStore, quando SetInfo é usado no ADS de um arquivo para remover o indicador oculto, o indicador oculto permanece ativado no próprio arquivo.
Lösung
Solução temporária:
Desative os Oplocks no file system na GUI do PowerStore Manager.
Nota: essa solução temporária pode causar problemas de desempenho em alguns aplicativos, como o Matlab.
Corrigir:
Um hotfix para esse problema foi incluído no PowerStoreOS 3.2.1.1-2206186.
Entre em contato com o suporte técnico Dell para obter o hotfix ou, se precisar de assistência, desative os Oplocks e consulte este artigo.
Desative os Oplocks no file system na GUI do PowerStore Manager.
Nota: essa solução temporária pode causar problemas de desempenho em alguns aplicativos, como o Matlab.
Corrigir:
Um hotfix para esse problema foi incluído no PowerStoreOS 3.2.1.1-2206186.
Entre em contato com o suporte técnico Dell para obter o hotfix ou, se precisar de assistência, desative os Oplocks e consulte este artigo.
Betroffene Produkte
PowerStoreArtikeleigenschaften
Artikelnummer: 000220780
Artikeltyp: Solution
Zuletzt geändert: 01 März 2024
Version: 2
Antworten auf Ihre Fragen erhalten Sie von anderen Dell NutzerInnen
Support Services
Prüfen Sie, ob Ihr Gerät durch Support Services abgedeckt ist.