NetWorker: Windows Backup Server'da Yer alan VesyaMQ Sorunları Nedeniyle Veri Kullanılamıyor

Zusammenfassung: Yedekleme sunucusundaki rpmMQ sorunları nedeniyle Veri Kullanılamıyor.

Dieser Artikel gilt für Dieser Artikel gilt nicht für Dieser Artikel ist nicht an ein bestimmtes Produkt gebunden. In diesem Artikel werden nicht alle Produktversionen aufgeführt.

Symptome

  • NetWorker sunucu yazılımı bir Microsoft Windows sunucusuna kurulur.
  • NetWorker sunucusunun yeni bir yükseltmesinden sonra hizmetler başlar; ancak nsrwatch ve NetWorker Yönetim Konsolu (NMC) yedeklemeleri gösterememektedir ve yedeklemelerin manuel olarak başlatılması başarısız olur.
  • NMC uyarı penceresi ve NMC gstd.raw raporu:
Linux: /opt/lgtonmc/logs/gstd.raw
Windows: C:\Program Files\EMC NetWorker\Management\GST\logs\gstd.raw

ERROR generated: "Message bus unable to open socket connection to host 'BACKUP-SRV' on port 5672: a socket error occurred" in file "D:/views/nw/19.8/nsrwebui/modules/nsm/gstnsm.c" line #11364

NetWorker: nsr_render_log'u kullanma

  • Bağlantı noktası 5672 veya 5671, NetWorker sunucusunu dinlemez:
nsrports -t localhost -p PORT
netstat -ano | findstr PORT

NOT: Bağlantı noktası 5672, ESKI SSL olmayan bağlantı noktasıdır. Bağlantı noktası 5671, SSL için kullanılır. NetWorker 19.7.x ve sonraki sürümlerde 5672 numaralı bağlantı noktası devre dışı bırakılır ve 5671 numaralı bağlantı noktası üzerinden 5671 numaralı bağlantı noktası üzerinden bu trafik gönderilir.
  • komutu çalıştırarak bu komutu çalıştırdı ve çıktı şu şekildedir:
Configuring logger redirection
Logger - error: {removed_failing_handler,rabbit_log}
13:46:52.589 [error] Error in process <0.206.0> on node rabbit_prelaunch_3804@localhost with exit value:
{eacces,[{erlang,open_port,[{spawn,"inet_gethost 4 "},[{packet,4},eof,binary]],[{file,"erlang.erl"},{line,2258}]},{inet_gethost_native,server_init,2,[{file,"inet_gethost_native.erl"},{line,184}]}]}
13:46:52.589 [error] Supervisor inet_gethost_native_sup had child at module inet_gethost_native at <0.206.0> exit with reason {eacces,[{erlang,open_port,[{spawn,"inet_gethost 4 "},[{packet,4},eof,binary]],[{file,"erlang.erl"},{line,2258}]},{inet_gethost_native,server_init,2,[{file,"inet_gethost_native.erl"},{line,184}]}]} in context child_terminated
13:46:52.589 [error] gen_server inet_gethost_native_sup terminated with reason: {eacces,[{erlang,open_port,[{spawn,"inet_gethost 4 "},[{packet,4},eof,binary]],[{file,"erlang.erl"},{line,2258}]},{inet_gethost_native,server_init,2,[{file,"inet_gethost_native.erl"},{line,184}]}]}
13:46:52.589 [error] CRASH REPORT Process inet_gethost_native_sup with 0 neighbours exited with reason: {eacces,[{erlang,open_port,[{spawn,"inet_gethost 4 "},[{packet,4},eof,binary]],[{file,"erlang.erl"},{line,2258}]},{inet_gethost_native,server_init,2,[{file,"inet_gethost_native.erl"},{line,184}]}]} in gen_server:handle_common_reply/8 line 805
13:46:52.589 [error] Supervisor kernel_safe_sup had child inet_gethost_native_sup started with {inet_gethost_native,start_link,undefined} at <0.205.0> exit with reason {eacces,[{erlang,open_port,[{spawn,"inet_gethost 4 "},[{packet,4},eof,binary]],[{file,"erlang.erl"},{line,2258}]},{inet_gethost_native,server_init,2,[{file,"inet_gethost_native.erl"},{line,184}]}]} in context child_terminated
13:46:52.605 [error] Error in process <0.206.0> on node rabbit_prelaunch_3804@localhost with exit value:
{eacces,[{erlang,open_port,[{spawn,"inet_gethost 4 "},[{packet,4},eof,binary]],[{file,"erlang.erl"},{line,2258}]},{inet_gethost_native,server_init,2,[{file,"inet_gethost_native.erl"},{line,184}]}]}
13:46:52.636 [error] 

13:46:52.636 [error] BOOT FAILED
BOOT FAILED
13:46:52.636 [error] ===========
===========
13:46:52.636 [error] ERROR: epmd error for host BACKUP-SRV: {could_not_start_server,inet_gethost_native} (unknown POSIX error)
ERROR: epmd error for host BACKUP-SRV: {could_not_start_server,inet_gethost_native} (unknown POSIX error)
13:46:52.636 [error] 

13:46:53.647 [error] Supervisor rabbit_prelaunch_sup had child prelaunch started with rabbit_prelaunch:run_prelaunch_first_phase() at undefined exit with reason {epmd_error,"BACKUP-SRV",{could_not_start_server,inet_gethost_native}} in context start_error
13:46:53.647 [error] CRASH REPORT Process <0.151.0> with 0 neighbours exited with reason: {{shutdown,{failed_to_start_child,prelaunch,{epmd_error,"BACKUP-SRV",{could_not_start_server,inet_gethost_native}}}},{rabbit_prelaunch_app,start,[normal,[]]}} in application_master:init/4 line 138
{"Kernel pid terminated",application_controller,"{application_start_failure,rabbitmq_prelaunch,{{shutdown,{failed_to_start_child,prelaunch,{epmd_error,\"BACKUP-SRV\",{could_not_start_server,inet_gethost_native}}}},{rabbit_prelaunch_app,start,[normal,[]]}}}"}
Kernel pid terminated (application_controller) ({application_start_failure,rabbitmq_prelaunch,{{shutdown,{failed_to_start_child,prelaunch,{epmd_error,"BACKUP-SRV",{could_not_start_server,inet_gethost

Crash dump is being written to: erl_crash.dump...done

Ursache

Bu sorun, NetWorker'ın yüklü olduğu birimin kökünde "program" adlı bir rogue dosya veya dizin varsa ortaya çıkabilir. Bu dosya veya dizin gizlenmiş olabilir.

Lösung

Herhangi bir birimin kökünde "program" adlı bir dosyanın veya dizinin mevcut olduğunu tanımlayın. Bu durumda, dosyayı veya dizini silin veya yeniden adlandırın:
  1. Yönetici olarak çalıştır'ı kullanarak bir CMDistemi açın.
  2. Disk bölümünün köküne gidin.
Örnek:
cd D:\
  1. Gizli nesneler de dahil olmak üzere nesneleri görüntülemek için aşağıdaki komutu çalıştırın.
dir /a
  1. Bir "Program" bulunursa nesneyi silin veya yeniden adlandırin.
  2. Diğer birimler veya sürücü harfleri için 1- 4. adımları tekrarlayın.
  3. Hizmeti yeniden başlatın
net stop nsrexecd /y
net start nsrd
NMC aynı sisteme takılıysa:
net start gstd
  1. Bir sonraki fırsatta ana bilgisayarı yeniden başlatın.

Betroffene Produkte

Data Protection, NetWorker Family, NetWorker, NetWorker Management Console

Produkte

NetWorker Management Console
Artikeleigenschaften
Artikelnummer: 000220828
Artikeltyp: Solution
Zuletzt geändert: 09 Okt. 2024
Version:  3
Antworten auf Ihre Fragen erhalten Sie von anderen Dell NutzerInnen
Support Services
Prüfen Sie, ob Ihr Gerät durch Support Services abgedeckt ist.