NetWorker: Data niet beschikbaar vanwege RabbitMQ-problemen op Windows Backup Server

Zusammenfassung: Data niet beschikbaar vanwege rabbitMQ-problemen op de back-upserver.

Dieser Artikel gilt für Dieser Artikel gilt nicht für Dieser Artikel ist nicht an ein bestimmtes Produkt gebunden. In diesem Artikel werden nicht alle Produktversionen aufgeführt.

Symptome

  • De NetWorker-serversoftware is geïnstalleerd op een Microsoft Windows-server.
  • Na een recente upgrade van de NetWorker server, starten de services; nsrwatch en de NetWorker Management Console (NMC) geven echter geen back-ups weer en het handmatig starten van back-ups mislukt.
  • Het NMC-waarschuwingsvenster en het NMC gstd.raw-rapport:
Linux: /opt/lgtonmc/logs/gstd.raw
Windows: C:\Program Files\EMC NetWorker\Management\GST\logs\gstd.raw

ERROR generated: "Message bus unable to open socket connection to host 'BACKUP-SRV' on port 5672: a socket error occurred" in file "D:/views/nw/19.8/nsrwebui/modules/nsm/gstnsm.c" line #11364

NetWorker: Het gebruik van nsr_render_log

  • Poort 5672 of 5671 luistert niet op de NetWorker server:
nsrports -t localhost -p PORT
netstat -ano | findstr PORT

OPMERKING: Poort 5672 is de legacy niet-SSL-poort. Poort 5671 wordt gebruikt voor SSL. In NetWorker 19.7.x en hoger is poort 5672 uitgeschakeld en wordt rabbitmq-verkeer verzonden via poort 5671.
  • Voer de opdracht uit om de rabbitmq-server te starten en dit was de uitvoer:
Configuring logger redirection
Logger - error: {removed_failing_handler,rabbit_log}
13:46:52.589 [error] Error in process <0.206.0> on node rabbit_prelaunch_3804@localhost with exit value:
{eacces,[{erlang,open_port,[{spawn,"inet_gethost 4 "},[{packet,4},eof,binary]],[{file,"erlang.erl"},{line,2258}]},{inet_gethost_native,server_init,2,[{file,"inet_gethost_native.erl"},{line,184}]}]}
13:46:52.589 [error] Supervisor inet_gethost_native_sup had child at module inet_gethost_native at <0.206.0> exit with reason {eacces,[{erlang,open_port,[{spawn,"inet_gethost 4 "},[{packet,4},eof,binary]],[{file,"erlang.erl"},{line,2258}]},{inet_gethost_native,server_init,2,[{file,"inet_gethost_native.erl"},{line,184}]}]} in context child_terminated
13:46:52.589 [error] gen_server inet_gethost_native_sup terminated with reason: {eacces,[{erlang,open_port,[{spawn,"inet_gethost 4 "},[{packet,4},eof,binary]],[{file,"erlang.erl"},{line,2258}]},{inet_gethost_native,server_init,2,[{file,"inet_gethost_native.erl"},{line,184}]}]}
13:46:52.589 [error] CRASH REPORT Process inet_gethost_native_sup with 0 neighbours exited with reason: {eacces,[{erlang,open_port,[{spawn,"inet_gethost 4 "},[{packet,4},eof,binary]],[{file,"erlang.erl"},{line,2258}]},{inet_gethost_native,server_init,2,[{file,"inet_gethost_native.erl"},{line,184}]}]} in gen_server:handle_common_reply/8 line 805
13:46:52.589 [error] Supervisor kernel_safe_sup had child inet_gethost_native_sup started with {inet_gethost_native,start_link,undefined} at <0.205.0> exit with reason {eacces,[{erlang,open_port,[{spawn,"inet_gethost 4 "},[{packet,4},eof,binary]],[{file,"erlang.erl"},{line,2258}]},{inet_gethost_native,server_init,2,[{file,"inet_gethost_native.erl"},{line,184}]}]} in context child_terminated
13:46:52.605 [error] Error in process <0.206.0> on node rabbit_prelaunch_3804@localhost with exit value:
{eacces,[{erlang,open_port,[{spawn,"inet_gethost 4 "},[{packet,4},eof,binary]],[{file,"erlang.erl"},{line,2258}]},{inet_gethost_native,server_init,2,[{file,"inet_gethost_native.erl"},{line,184}]}]}
13:46:52.636 [error] 

13:46:52.636 [error] BOOT FAILED
BOOT FAILED
13:46:52.636 [error] ===========
===========
13:46:52.636 [error] ERROR: epmd error for host BACKUP-SRV: {could_not_start_server,inet_gethost_native} (unknown POSIX error)
ERROR: epmd error for host BACKUP-SRV: {could_not_start_server,inet_gethost_native} (unknown POSIX error)
13:46:52.636 [error] 

13:46:53.647 [error] Supervisor rabbit_prelaunch_sup had child prelaunch started with rabbit_prelaunch:run_prelaunch_first_phase() at undefined exit with reason {epmd_error,"BACKUP-SRV",{could_not_start_server,inet_gethost_native}} in context start_error
13:46:53.647 [error] CRASH REPORT Process <0.151.0> with 0 neighbours exited with reason: {{shutdown,{failed_to_start_child,prelaunch,{epmd_error,"BACKUP-SRV",{could_not_start_server,inet_gethost_native}}}},{rabbit_prelaunch_app,start,[normal,[]]}} in application_master:init/4 line 138
{"Kernel pid terminated",application_controller,"{application_start_failure,rabbitmq_prelaunch,{{shutdown,{failed_to_start_child,prelaunch,{epmd_error,\"BACKUP-SRV\",{could_not_start_server,inet_gethost_native}}}},{rabbit_prelaunch_app,start,[normal,[]]}}}"}
Kernel pid terminated (application_controller) ({application_start_failure,rabbitmq_prelaunch,{{shutdown,{failed_to_start_child,prelaunch,{epmd_error,"BACKUP-SRV",{could_not_start_server,inet_gethost

Crash dump is being written to: erl_crash.dump...done

Ursache

Dit probleem kan zich voordoen wanneer een rogue-bestand of map met de naam 'programma' bestaat in de hoofdmap van het volume waarop NetWorker is geïnstalleerd. Dit bestand of de map is mogelijk verborgen.

Lösung

Bepaal of er een bestand of map met de naam 'programma' bestaat in de hoofdmap van een volume. Zo ja, verwijder of wijzig de naam van het bestand of de map:
  1. Open een CMD-prompt met behulp van Uitvoeren als administrator.
  2. Ga naar de hoofdmap van het volume.
Voorbeeld:
cd D:\
  1. Voer de volgende opdracht uit om objecten weer te geven, inclusief verborgen objecten.
dir /a
  1. Als een 'Programma' wordt gevonden, verwijdert of wijzigt u de naam van het object.
  2. Herhaal stap 1 - 4 voor andere volumes of stationsletters.
  3. Start de service opnieuw op: 
net stop nsrexecd /y
net start nsrd
Als NMC op hetzelfde systeem is geïnstalleerd:
net start gstd
  1. Start de host opnieuw op bij de volgende gelegenheid.

Betroffene Produkte

Data Protection, NetWorker Family, NetWorker, NetWorker Management Console

Produkte

NetWorker Management Console
Artikeleigenschaften
Artikelnummer: 000220828
Artikeltyp: Solution
Zuletzt geändert: 09 Okt. 2024
Version:  3
Antworten auf Ihre Fragen erhalten Sie von anderen Dell NutzerInnen
Support Services
Prüfen Sie, ob Ihr Gerät durch Support Services abgedeckt ist.