Der CSM-Operator zeigt "fehlgeschlagen" an, da es sich nicht um den berechneten Status handelt, wenn der Treiber als eigenständiger Treiber installiert ist

Zusammenfassung: Für den Container Storage Module (CSM)-Operator wird kein Status berechnet, wenn der CSI-Treiber (Container Storage Module) eigenständig installiert ist.

Dieser Artikel gilt für Dieser Artikel gilt nicht für Dieser Artikel ist nicht an ein bestimmtes Produkt gebunden. In diesem Artikel werden nicht alle Produktversionen aufgeführt.

Symptome

Wenn der CSI-Treiber bereitgestellt wird, ohne dass zusätzliche CSM-Module den CSM-Operator verwenden, kann der CSM-Operator den Status nicht berechnen. Der Status befindet sich in einem fehlerhaften Zustand, obwohl der Treiber erfolgreich bereitgestellt wurde.

Das Ausführen von kubectl describe für das CSM-Objekt, das dem Treiber zugeordnet ist, zeigt den Controller- und Node-Status als erfolgreich an, aber der Gesamtstatus zeigt "fehlgeschlagen" an.
kubectl describe csm -n vxflexos vxflexos
Status:
  Controller Status:
    Available:  1
    Desired:    1
    Failed:     0
  Node Status:
    Available:  2
    Desired:    2
    Failed:     0
  State:        Failed

kubectl get csm -A
NAMESPACE   NAME       CREATIONTIME   CSIDRIVERTYPE   CONFIGVERSION   STATE
vxflexos    vxflexos   13m            powerflex       v2.9.0          Failed

 

Nachdem die Korrektur als erfolgreich angezeigt wurde:
NAMESPACE    NAME     CREATIONTIME CSIDRIVERTYPE CONFIGVERSION STATE
vxflexos     vxflexos 13s          powerflex     v2.9.0        Succeeded

Ursache

Der Operator-Statuscode berücksichtigte nicht die Treiberinstallation ohne Module.

Lösung

Lösung:
Das Engineering hat dieses Problem in Dell Container Storage Modules (CSM) v1.9.2 behoben.
Der Operator wurde aktualisiert, um den Status einer Treiberbereitstellung ohne Module zu berechnen.



Produkte

Container Storage Modules Family, Container Storage Modules
Artikeleigenschaften
Artikelnummer: 000221974
Artikeltyp: Solution
Zuletzt geändert: 03 Sept. 2025
Version:  3
Antworten auf Ihre Fragen erhalten Sie von anderen Dell NutzerInnen
Support Services
Prüfen Sie, ob Ihr Gerät durch Support Services abgedeckt ist.