PowerFlex 3.x: GW ervaart een Java-fout - OutOfMemoryError

Zusammenfassung: De Gateway (GW) werkt niet goed.

Dieser Artikel gilt für Dieser Artikel gilt nicht für Dieser Artikel ist nicht an ein bestimmtes Produkt gebunden. In diesem Artikel werden nicht alle Produktversionen aufgeführt.

Symptome

In de logboeken van GW wordt "OutOfMemoryError: Java heap space" berichten:

scaleio-trace.log

2024-03-31 05:37:27,674 [https-jsse-nio-443-exec-6] ERROR c.e.s.s.s.ConnectionServiceImpl - Error invoking connection call to server
java.lang.IllegalStateException: java.io.IOException: java.lang.reflect.InvocationTargetException
        at org.apache.catalina.webresources.AbstractSingleArchiveResourceSet.getArchiveEntry(AbstractSingleArchiveResourceSet.java:99)
... ...
Caused by: java.lang.OutOfMemoryError: Java heap space

 

scaleio.log

2024-03-19 00:41:45,534 [command-service-0-ReceiveLoop-1319392906] ERROR c.e.e.n.c.LayeredProtocolConnection - LPC-1319392906 #ea7ca146fa916e54 [10.14.226.11:6611]: OutOfMemoryError in receive loop
java.lang.OutOfMemoryError: Java heap space

 

Impact

GW REST API reageerde niet en er treedt een time-out op. 

Ursache

De eigenschap sessionCacheSize heeft een limiet die de snelheid van geheugenlekken kan vertragen. Door deze limiet in te stellen op 2000, worden problemen voorkomen die verband houden met snelle API-aanroepen.

Lösung

1. Bewerk het volgende bestand op de GW:

/opt/emc/scaleio/gateway/conf/server.xml

 

2. Voeg de volgende tekenreeks hieronder toe voordat u maxHttpHeaderSize="16384" (bv. regel 103):

sessionCacheSize="2000"

Bijvoorbeeld:

sessionCacheSize
3. Sla de wijziging op en start de GW-service opnieuw:

systemctl restart scaleio-gateway

 

Versies waarop dit van toepassing is

PowerFlex 3.6.2.x-3.6.4.x

Opgelost in versie

PowerFlex 3.6.5

Betroffene Produkte

PowerFlex Software
Artikeleigenschaften
Artikelnummer: 000227121
Artikeltyp: Solution
Zuletzt geändert: 08 Juli 2025
Version:  4
Antworten auf Ihre Fragen erhalten Sie von anderen Dell NutzerInnen
Support Services
Prüfen Sie, ob Ihr Gerät durch Support Services abgedeckt ist.