Connectrix Brocade:FOS 升級失敗,並顯示事件代碼「語法錯誤接近非預期權杖」=~」

Zusammenfassung: FOS 升級失敗,並顯示事件代碼「語法錯誤接近非預期權杖」和「$duplicates_exists =~ ERROR」。

Dieser Artikel gilt für Dieser Artikel gilt nicht für Dieser Artikel ist nicht an ein bestimmtes Produkt gebunden. In diesem Artikel werden nicht alle Produktversionen aufgeführt.

Symptome

BrocadeSwitch:admin> firmwaredownload
伺服器名稱或 IP 位址:172.xxx.xxx.xxx
使用者名稱:ftpuser
檔案名稱: v9.1.1d1_G6_ENTRY
網路通訊協定 (1-自動選取、2-FTP、3-SCP、4-SFTP) [1]:2
密碼:
伺服器 IP:172.xxx.xxx.xxx、通訊協定 IPv4
正在檢查系統設定的韌體下載...
您是否接受並同意本產品的終端使用者授權合約 (EULA) 中概述的條款?
請回覆 (Y/y) 以接受、(N/n) 表示不接受,或 (D/d) 以顯示 EULA):y
/tmp/fwdl-1139/preinst: line 3454: 條件二進位運算子預期
/tmp/fwdl-1139/preinst:第 3454 行:在非預期標記“=~”附近出現語法錯誤
/tmp/FWDL-1139/preinst: 行 3454:' 如果 [[ $duplicates_存在 =~ 錯誤]] 則'

下載指定的韌體之前,請解決下列問題:

韌體下載失敗。
BrocadeSwitch:admin>

Ursache

使用「韌體下載」命令時,在升級路徑中跳過躍點時,就會發生此問題。
例如,在此案例中,FOS 升級會嘗試從版本 8.2.3c 直接移至版本 9.1.1d1,略過 9.0.x 版本。

Lösung

若要避免此問題,請按照下列步驟進行不中斷升級:
 

  1. 從 Fabric OS v8.2.x 升級至 Fabric OS 9.0.x。

  2. 從 Fabric OS 9.0.x 升級至 Fabric OS 9.1.x (確認您擁有有效的 Brocade TruFOS 憑證)。

  3. 從 Fabric OS 9.1.x 升級至 Fabric OS 9.2.0.x。

  4. 最後,請從 Fabric OS 9.2.0.x 升級至 Fabric OS 9.2.1

此順序可確保升級過程順利穩定。

Weitere Informationen

Fabric OS 軟體不支援從比安裝版本早於一個主要版本的任何版本進行無中斷升級。
例如,只有 Fabric OS v9.2.0x 支援 Fabric OS v9.2.1 的不中斷升級。
從舊版的 Fabric OS (例如 Fabric OS v9.1.x) 升級時,只能以中斷的方式進行。

 

您可以使用「firmwaredownload -s」命令執行干擾性直接升級,在單一 CP 模式下從 Fabric OS v9.0.1x 移至 v9.2.1。

參考手冊:
https://techdocs.broadcom.com/content/dam/broadcom/techdocs/us/en/pdf/fc-networking/software-upgrade/fos-92x-upg.pdf
第三方廠商連結圖示
https://techdocs.broadcom.com/content/dam/broadcom/techdocs/us/en/pdf/fc-networking/software-upgrade/fos-91x-upg.pdf 第三方廠商連結圖示
https://techdocs.broadcom.com/content/dam/broadcom/techdocs/us/en/pdf/fc-networking/software-upgrade/fos-90x-upg.pdf 第三方廠商連結圖示

Betroffene Produkte

Connectrix B-Series Fabric OS 9.X
Artikeleigenschaften
Artikelnummer: 000227492
Artikeltyp: Solution
Zuletzt geändert: 02 Aug. 2024
Version:  1
Antworten auf Ihre Fragen erhalten Sie von anderen Dell NutzerInnen
Support Services
Prüfen Sie, ob Ihr Gerät durch Support Services abgedeckt ist.