PowerFlex Management Platform – Seite "Notification Policies" kann nicht geladen werden

Zusammenfassung: Wenn Sie die Seite "Benachrichtigungsrichtlinien" in der Benutzeroberfläche aufrufen, kann sie nicht geladen werden.

Dieser Artikel gilt für Dieser Artikel gilt nicht für Dieser Artikel ist nicht an ein bestimmtes Produkt gebunden. In diesem Artikel werden nicht alle Produktversionen aufgeführt.

Symptome

Der Bildschirm "Benachrichtigungsrichtlinien" kann nicht über die Benutzeroberfläche geladen werden.

Das Löschen des Cache und der Cookies kann anfangs hilfreich sein, aber nach einiger Zeit wird es nicht mehr geladen:

Benachrichtigungsrichtlinie

Notifier-Protokolle zeigen "invalid request block size" gefolgt von "Connection reset by peer" an: Hinweis: Die Standardpuffergröße für den Notifier-Service beträgt 4096.

invalid request block size: 4477 (max 4096)...skip
[uwsgi-http key: pfxm-customer.com client_addr: 127.0.0.1 client_port: 37568] hr_instance_read(): Connection reset by peer [plugins/http/http.c line 647]
invalid request block size: 4487 (max 4096)...skip
[uwsgi-http key: pfxm-customer.com client_addr: 127.0.0.1 client_port: 40128] hr_instance_read(): Connection reset by peer [plugins/http/http.c line 647]
invalid request block size: 4479 (max 4096)...skip
[uwsgi-http key: pfxm-customer.com client_addr: 127.0.0.1 client_port: 40640] hr_instance_read(): Connection reset by peer [plugins/http/http.c line 647]

Um den Notifier-Protokollen beim Zugriff auf die Benutzeroberfläche für Benachrichtigungs-Policies zu folgen, führen Sie die folgenden Befehle aus:

 x=$(kubectl get pods -n powerflex|grep -i notifier|awk '{print $1}'); kubectl logs --follow $x -n powerflex

Auswirkung: Die Seite für Benachrichtigungsrichtlinien in der Benutzeroberfläche kann nicht geladen oder verwaltet werden.

Ursache

 

Ein nicht identifiziertes Element im System des Kunden fügt den API-Aufrufen für Benachrichtigungsrichtlinien zusätzliche Blöcke hinzu, was zu einer Blockgröße führt, die größer als der Standardwert 4096 ist.

Die Puffergröße muss in notifier.ini erhöht werden, um eine höhere Blockgröße als erwartet zu ermöglichen.

Die Verwendung eines Browsers von einem Jump-Server aus wird höchstwahrscheinlich gut funktionieren.

 

Lösung

1) Öffnen Sie eine Shell für den Notifier-Pod:

 x=$(kubectl get pods -n powerflex|grep -i notifier|awk '{print $1}'); kubectl exec -it -n powerflex $x -- bash

2) Erhöhen Sie den Wert für die Puffergröße. 2.a) Bearbeiten Sie die notifier.ini Datei:

vi /app/notifier.ini

b) "Erhöhen Sie den Wert für die Puffergröße unter dem http-Feld (doppelte Puffergröße - 8192):

Erhöhen Sie den Wert für die Puffergröße l

 3) Laden Sie die notifier.ini Datei erneut:

uwsgi --reload /app/notifier.ini

4) Starten Sie den Notifier-Service neu:

supervisorctl restart all

Fehler können bedenkenlos ignoriert werden.

Starten Sie den Notifier-Service neu

 

5) Der Zugriff auf die Seite "Benachrichtigungsrichtlinien" in der Benutzeroberfläche sollte jetzt funktionieren.

 Wenn der Benachrichtigungs-Pod neu gestartet wird, wird der Wert für die Puffergröße auf die Standardeinstellung zurückgesetzt.

Weitere Informationen

Bei PowerFlex 4.6.1 ist das gleiche Problem aufgetreten:

ck3-lab214-mvm01:~ # k logs notifier-6c554cd66c-g9s57 | grep invalid
invalid request block size: 8298 (max 8096)...skip

Das Erhöhen der Puffergröße auf 9120 wurde behoben.

Betroffene Produkte

PowerFlex rack, PowerFlex rack RCM Software, PowerFlex Software
Artikeleigenschaften
Artikelnummer: 000237311
Artikeltyp: Solution
Zuletzt geändert: 04 Sept. 2025
Version:  5
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