Verschiedene Dell Produktausfälle aufgrund der BIOS-"In-Band-Management"-Einstellung, die IPMI deaktiviert

Zusammenfassung: Verschiedene Dell Enterprise-Produkte verhalten sich unerwartet, wenn IPMI absichtlich für die Kommunikation zwischen dem Betriebssystem und iDRAC deaktiviert wurde. Dies kann durch Deaktivieren der Einstellung "In-Band Management Interface" in den BIOS-Systemsicherheitseinstellungen erfolgen. ...

Dieser Artikel gilt für Dieser Artikel gilt nicht für Dieser Artikel ist nicht an ein bestimmtes Produkt gebunden. In diesem Artikel werden nicht alle Produktversionen aufgeführt.

Symptome

Verschiedene Dell Enterprise-Softwareprodukte sind auf die Kommunikation zwischen iDRAC und dem IPMI-Treiber des Betriebssystems angewiesen. Im Folgenden sind beliebte Dell Produkte aufgeführt, aber dies ist keine vollständige Liste:

  • Dell Update Packages (DUP): Erfordert, dass IPMI Firmware-Payloads an den iDRAC weiterleitet, damit iDRAC beim Neustart angewendet werden kann
  • Dell OpenManage Server Administrator (OMSA): Erfordert IPMI für die meisten Komponentenüberwachungen, die von iDRAC verwaltet werden, z. B. Lüfter, Stromversorgung usw.
  • iDRAC-Tools: Racadm und ipmitool erfordern IPMI für die lokale iDRAC-Kommunikation
  • iDRAC-Servicemodul (iSM): Erfordert, dass IPMI eine vertrauenswürdige Hochgeschwindigkeitskommunikation mit iDRAC über das erstellte USB-Netzwerkgerät herstellt
  • Dell System Update (DSU): Der zugrunde liegende Inventory Collector von DSU verlässt sich auf IPMI, um bestimmte Komponenten und Firmwareversionen zu erkennen, und muss das entsprechende DUP anwenden
Wenn IPMI unter Windows deaktiviert ist, wird in der Regel ein Warnungsereignis im Windows-Systemereignisprotokoll protokolliert. Wenn IPMI unter Linux deaktiviert ist, wird der folgende Fehler angezeigt:
Could not open device at /dev/ipmi0 or /dev/ipmi/0 or /dev/ipmidev/0 

Ursache

Ein möglicher Grund für das Fehlschlagen von IPMI und damit auch das Dell Produkt ist die absichtliche Deaktivierung der Einstellungen für die bandinterne Managementschnittstelle, die in den BIOS-Einstellungen unter "Systemsicherheit" zu finden sind. Dadurch wird der IPMI-Bus zum iDRAC vollständig vor dem Betriebssystem verborgen.

Ein weiterer Grund könnte sein, dass der IPMI-Treiber in Windows deaktiviert oder das IPMI-Modul in Linux gestoppt wurde.

Lösung

Der native IPMI-Treiber von Windows muss aktiviert und geladen sein. Dies kann bestätigt werden:

  1. Öffnen Sie den Geräte-Manager und wählen Sie dann Anzeigen > Ausgeblendete Geräte anzeigen aus.
  2. Öffnen Sie im Abschnitt Systemgeräte Microsoft Generic IPMI Compliant Device.
  3. Überprüfen Sie, ob der Gerätestatus fehlerfrei ist

Stellen Sie für Linux sicher, dass die IPMI-Module aktiv sind und geladen sind mit "lsmod | grep -i ipmi", insbesondere das ipmi_si-Modul.

Überprüfen Sie außerdem in den BIOS-Einstellungen, ob die In-Band-Managementschnittstelle für Systemsicherheit > aktiviert ist.

Betroffene Produkte

Dell System Update, OpenManage Server Administrator, Update Packages, iDRAC Service Module
Artikeleigenschaften
Artikelnummer: 000247770
Artikeltyp: Solution
Zuletzt geändert: 10 Juli 2025
Version:  2
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