Data Domain: REST-API-Fehler – REST-Service ist deaktiviert

Zusammenfassung: So beheben Sie REST-API-Fehler (Application Programming Interface).

Dieser Artikel gilt für Dieser Artikel gilt nicht für Dieser Artikel ist nicht an ein bestimmtes Produkt gebunden. In diesem Artikel werden nicht alle Produktversionen aufgeführt.

Symptome

Erkannte Symptome

Folgende Symptome wurden identifiziert:

  • Fehler der Cyber-Recovery-Benutzeroberfläche
    • Fehlermeldung "Got HTTP response code 400 Bad Request while login to DD using REST API"
  • Fehlermeldung "REST-Service ist deaktiviert" beim Versuch, über einen Browser oder API-Aufruf eine Verbindung zu DD auf Port 3009 herzustellen

Ursache

Ursache des Problems

Die Ursache des Problems ist, dass der REST-Service auf der Data Domain deaktiviert ist.

Dies kann darauf zurückzuführen sein, dass der Webdienst deaktiviert ist, was für die Ausführung des REST-Dienstes erforderlich ist.

  • REST-Service ist deaktiviert
  • Webservice ist deaktiviert

Relevante Fehlermeldungen

Zu den relevanten Fehlermeldungen, die auf die Ursache des Problems hinweisen, gehören:

  • "REST-Service ist deaktiviert"
  • "Received HTTP response code 400 Bad Request while login to DD using REST API"
# Relevant command to check the status of the web service
$ adminaccess enable web-service

Lösung

Aktivieren des REST-Service auf Data Domain

Um den REST API-Fehler zu beheben, muss der REST-Service auf der Data Domain ausgeführt werden. Dies kann durch die Aktivierung des Webdienstes erreicht werden.

# Enable web service using the following CLI command
adminaccess enable web-service

Sobald der Webservice aktiviert ist, wird der REST-Service ausgeführt, sodass REST-API-Aufrufe erfolgreich abgeschlossen werden können.

Überprüfen der Lösung

Um zu überprüfen, ob das Problem behoben wurde, versuchen Sie, mithilfe eines Browsers oder API-Aufrufs eine Verbindung zur Data Domain auf Port 3009 herzustellen. Wenn der REST-Dienst ausgeführt wird, wird der Fehler "REST-Dienst ist deaktiviert" nicht angezeigt.

Achtung: Wenn die Probleme weiterhin auftreten, wenden Sie sich an den Dell Support.

Betroffene Produkte

PowerProtect Cyber Recovery, DD OS
Artikeleigenschaften
Artikelnummer: 000353903
Artikeltyp: Solution
Zuletzt geändert: 23 Mai 2026
Version:  2
Antworten auf Ihre Fragen erhalten Sie von anderen Dell NutzerInnen
Support Services
Prüfen Sie, ob Ihr Gerät durch Support Services abgedeckt ist.