PowerFlex 4.x: MDM-Trace-Protokolle mit INVALID_SESSION Ereignissen überflutet
Zusammenfassung: MDM-Trace-Protokolle zeigen möglicherweise viele INVALID_SESSION Meldungen an. Diese Meldungen wirken sich nicht auf die Systemleistung oder -funktionalität aus, können jedoch übermäßiges Protokollrauschen verursachen. ...
Symptome
Beispiel
- MDM ist mit einem PowerFlex Manager 4.x-System verbunden
- Das PowerFlex Core-System ist auf Version 4.x
MDM-Trace-Protokolle zeigen Folgendes an:
2025/08/11 10:15:14.823907 LOW:7fd7b05b7db0:authSession_GetSessionFromTokenForReadOrWrite:00260: Failed to get session - isWrite: 1, sessionIndex: 0, rc: INVALID_SESSION 2025/08/11 10:15:14.823913 LOW:7fd7b05b7db0:authMgr_GetUserInfoFromToken:00814: Failed to find session for authentication. rc=INVALID_SESSION 2025/08/11 10:15:14.823916 LOW:7fd7b05b7db0:cliMsg_AuthenticateSession:02080: Failed getting user role (INVALID_SESSION) authorized: 0
Auswirkungen
- Kein funktionales Problem, PowerFlex Gateway (GW)-Verbindungen und -Vorgänge sind nicht betroffen.
- Ablaufverfolgungsprotokolle werden stark mit dieser Meldung gefüllt, was zu einer übermäßigen Protokollrotation und der Möglichkeit anderer Protokolleinträge führen kann.
- Kein zusätzlicher Verarbeitungsaufwand; Diese Meldungen führen nicht zu Performance- oder Latenzproblemen für den MDM.
- Die Meldung kann aus funktionaler Sicht bedenkenlos ignoriert werden, aber das Protokollrauschen kann dennoch eine betriebliche Überlegung sein.
Ursache
In Version 4.x verwendet das Gateway keine sitzungsbasierte Authentifizierung mehr, wenn eine Verbindung zum MDM hergestellt wird. Stattdessen erfolgt die Authentifizierung über eine neuere Methode, die keine Sitzungsdetails sendet.
Der MDM enthält jedoch weiterhin Legacy-Code (3.x), der versucht, eine Sitzung für bestimmte eingehende Anforderungen nachzuschlagen. Wenn keine Sitzung gefunden wird (wie für GW 4.x-Datenverkehr erwartet), protokolliert der MDM die INVALID_SESSION -Ereignis, aber die Gateway-Anfrage wird weiterhin verarbeitet.
Dieser Protokolleintrag ist kein Fehler und zeigt kein Problem mit der Gateway-Konnektivität oder -Authentifizierung an. Es handelt sich um ein Überbleibsel aus älteren Versionen.
Lösung
Aktualisieren Sie das System auf eine Version, die die Korrektur enthält.
Weitere Informationen
Betroffene Versionen:
PowerFlex 4.x
Behoben in Version:
PowerFlex 4.8