「SQL Serverをインストールできません」エラー終了コード2061893606 SSDを使用
Zusammenfassung: SQL Server を SSD にインストールできず、「SQL Server をインストールできません」というエラーと終了コード 2061893606 が発生した場合の対処方法について説明します。
Symptome
Microsoftインボックス ドライバーを使用してオペレーティング システムをインストールすると、Windows 11にMicrosoft SQL Serverをインストールできない場合があります。これは、BIOS SATA動作設定が[RAID On]ではなく[AHCI]に設定されている場合に発生する可能性があります。SQL Server をインストールしようとすると、"SQL Server をインストールできません (setup.exe)を使用するシステムで一般的に行われる、繰り返しのプログラムおよび消去サイクルによって劣化しやすい傾向があります。終了コード(10進数): -2061893606エラーの説明: データベース エンジンの復旧ハンドルの待機に失敗しました。SQL Serverのエラー ログで考えられる原因を確認してください。
PowerShellでは、次のように入力して物理セクター サイズを確認できます Get-Disk | Select Number, FriendlyName, LogicalSectorSize, PhysicalSectorSize をクリックし、Enter キーを押します。この問題は、 PhysicalSectorSize は 4096 ではありません。
影響を受けるプラットフォーム:
- Alienwareデスクトップ
- Alienwareノートパソコン
- Dell製デスクトップ
- Dellノートパソコン
- Dell ProノートPC
- Dell Proデスクトップ
- Dell Pro Maxデスクトップ
- Dell Pro Maxノートパソコン
- Dell Pro RuggedノートPC
- Inspironノートパソコン
- Inspironデスクトップ
- Latitude
- OptiPlex
- Dell Precisionノートパソコン
- Precisionデスクトップ
- XPSノートパソコン
影響を受けるSSDおよびDellパーツ ナンバー(DPN):
- サンディスクSN5000S
- 512 GB:DPN
2RF37- ファームウェアバージョン34012143以下 - 1 TB:DPN
645DW- ファームウェアバージョン34012143以下 - 2 TB:DPN
05GJH- ファームウェアバージョン34012143以下
- 512 GB:DPN
- サンディスクSN5100S
- 512 GB:DPN
9D0TT- ファームウェアバージョン35012201以下 - 1 TB:DPN
F6R4V- ファームウェアバージョン35012201以下 - 2 TB:DPN
CJ5M9- ファームウェアバージョン35012201以下
- 512 GB:DPN
- サンディスクSN7100S
- 256 GB:DPN
6DJG6- ファームウェアバージョン76012001以下 - 512 GB:DPN
WYMVY- ファームウェアバージョン76012101以下 - 1 TB:DPN
78KXH- ファームウェアバージョン76012101以下
- 256 GB:DPN
- SanDisk SN8000S非SED
- 512 GB:DPN
DVK06- ファームウェアバージョン63012102以下 - 1 TB:DPN
H1CNH- ファームウェアバージョン63012102以下 - 2 TB:DPN
50KMR- ファームウェアバージョン63012102以下
- 512 GB:DPN
- SanDisk SN8000S SED
- 512 GB:DPN
N1KT3- ファームウェアバージョン63112102以下 - 1 TB:DPN
0XH6P- ファームウェアバージョン63112102以下 - 2 TB:DPN
4PF9M- ファームウェアバージョン63112102以下 - 4 TB:DPN
4FN86- ファームウェアバージョン63112102以下
- 512 GB:DPN
影響を受けるオペレーティング システム:
- Windows 11
影響を受けるアプリケーション:
- SQL Server 2022
- SQL Server 2019
- SQL Server 2017
- SQL Server 2016
Ursache
Windows 11の受信トレイ ストレージ ドライバーとハード ドライブの間の問題により、このエラーが発生します。
Lösung
長期的な解決策
- すべての個人データをバックアップします。詳細については、「 バックアップとリカバリ」を参照してください。
- ノートパソコンでアップデートが実行されている場合は、ACアダプターを接続します。
- SanDisk SN5000S(Dellパーツ ナンバー
2RF37、645DWと05GJHを使用):コンピューターでSanDisk SN5000S SSDのファームウェアをバージョン3401.2144、A04以降にアップデートすると、問題が解決します。ファームウェアをダウンロードしてインストールするには、「 Dellドライバーおよびファームウェアをダウンロードしてインストールする方法」を参照してください。 - SanDisk SN8000S non-SED(Dellパーツ ナンバー
DVK06、H1CNHと50KMRを使用):コンピューターでSanDisk SN8000s SSDファームウェア アップデートをバージョン6301.2103、A03以降にアップデートすると、問題が解決します。ファームウェアをダウンロードしてインストールするには、「 Dellドライバーおよびファームウェアをダウンロードしてインストールする方法」を参照してください。 - SanDisk SN8000S SED(Dellパーツ ナンバー
N1KT3、0xH6P、4PF9Mと4FN86を使用):コンピューターでSanDisk SN8000s SSDファームウェア アップデートをバージョン6311.2103、A03以降にアップデートすると、問題が解決します。ファームウェアをダウンロードしてインストールするには、「 Dellドライバーおよびファームウェアをダウンロードしてインストールする方法」を参照してください。
対策
お使いのハード ドライブがまだリストに記載されておらず、長期的な解決策がない場合は、Microsoftで回避策を参照してください。「オペレーティング システムのディスク セクター サイズが4 KBより大きい場合のトラブルシューティング」の「SQL Serverのディスク セクター サイズ エラーの解決手順」セクションを参照してください。