Błąd "Unable to install SQL Server" Kod zakończenia 2061893606 z dyskiem SSD
Zusammenfassung: Poniższy artykuł zawiera informacje na temat czynności, które należy wykonać, gdy nie można zainstalować programu SQL Server na dysku SSD. Zgłasza błąd "Unable to install SQL Server" z kodem zakończenia 2061893606. ...
Symptome
Jeśli system operacyjny jest instalowany przy użyciu sterownika Microsoft Inbox, instalacja programu Microsoft SQL Server w systemie Windows 11 może być niemożliwa. Może się tak zdarzyć, gdy ustawienie operacji BIOS Serial ATA (SATA) jest ustawione na Advanced Host Controller Interface (AHCI) zamiast RAID On. Podczas próby zainstalowania programu SQL Server zostanie wyświetlony następujący komunikat o błędzie:
"Unable to install SQL Server (setup.exe).
Exit code (Decimal): -2061893606Error description:
Wait on the Database Engine recovery handle failed.
Check the SQL Server error log for potential causes."
W programie PowerShell sprawdź rozmiar sektora fizycznego, wpisując Get-Disk | Select Number, FriendlyName, LogicalSectorSize, PhysicalSectorSize , a następnie naciskając Enter. Ten problem występuje, gdy wartość PhysicalSectorSize nie jest 4096.
Dotyczy platform:
- Komputer stacjonarny Alienware
- Laptopy Alienware
- Komputery stacjonarne firmy Dell
- Notebooki firmy Dell
- Notebooki Dell Pro
- Komputery stacjonarne Dell Pro
- Komputery stacjonarne Dell Pro Max
- Notebooki Dell Pro Max
- Notebooki Dell Pro Rugged
- Notebooki Inspiron
- Komputer stacjonarny Inspiron
- Latitude
- OptiPlex
- Notebooki Precision
- Komputer stacjonarny Precision
- Laptopy XPS
Dyski SSD i numery części Dell (DPN), których dotyczy problem:
- SanDisk SN5000S
- 512 GB — DPN
2RF37- Oprogramowanie sprzętowe w wersji 34012143 lub niższej - 1 TB — DPN
645DW- Oprogramowanie sprzętowe w wersji 34012143 lub niższej - 2 TB — DPN
05GJH- Oprogramowanie sprzętowe w wersji 34012143 lub niższej
- 512 GB — DPN
- SanDisk SN5100S
- 512 GB — DPN
9D0TT- Oprogramowanie sprzętowe w wersji 35012201 lub niższej - 1 TB — DPN
F6R4V- Oprogramowanie sprzętowe w wersji 35012201 lub niższej - 2 TB — DPN
CJ5M9- Oprogramowanie sprzętowe w wersji 35012201 lub niższej
- 512 GB — DPN
- SanDisk SN7100S
- 256 GB — DPN
6DJG6- Oprogramowanie sprzętowe w wersji 76012001 lub niższej - 512 GB — DPN
WYMVY- Oprogramowanie sprzętowe w wersji 76012101 lub niższej - 1 TB — DPN
78KXH- Oprogramowanie sprzętowe w wersji 76012101 lub niższej
- 256 GB — DPN
- SanDisk SN8000S inny niż SED
- 512 GB — DPN
DVK06- Oprogramowanie sprzętowe w wersji 63012102 lub niższej - 1 TB — DPN
H1CNH- Oprogramowanie sprzętowe w wersji 63012102 lub niższej - 2 TB — DPN
50KMR- Oprogramowanie sprzętowe w wersji 63012102 lub niższej
- 512 GB — DPN
- SanDisk SN8000S SED
- 512 GB — DPN
N1KT3- Oprogramowanie sprzętowe w wersji 63112102 lub niższej - 1 TB — DPN
0XH6P- Oprogramowanie sprzętowe w wersji 63112102 lub niższej - 2 TB — DPN
4PF9M- Oprogramowanie sprzętowe w wersji 63112102 lub niższej - 4 TB — DPN
4FN86- Oprogramowanie sprzętowe w wersji 63112102 lub niższej
- 512 GB — DPN
Dotyczy systemu operacyjnego:
- Windows 11
Aplikacja, której dotyczy problem:
- SQL Server 2022
- SQL Server 2019
- SQL Server 2017
- SQL Server 2016
Ursache
Przyczyną tego błędu jest problem między sterownikiem Inbox Storage systemu Windows 11 a dyskami twardymi.
Lösung
Rozwiązanie długoterminowe
- Utwórz kopię zapasową wszystkich danych osobistych. Aby uzyskać więcej informacji, zapoznaj się z: Tworzenie kopii zapasowych i odzyskiwanie danych
- Podłącz zasilacz sieciowy, jeśli w notebooku są uruchamiane aktualizacje.
- SanDisk SN5000S (numer części Dell (DPN)
2RF37,645DWi05GJH): Problem można rozwiązać, aktualizując oprogramowanie wewnętrzne dysku SSD SanDisk SN5000S do wersji 3401.2144, A04 lub nowszej. Aby pobrać i zainstalować oprogramowanie wewnętrzne, zapoznaj się z artykułem: Pobieranie i instalowanie sterowników i oprogramowania wewnętrznego firmy Dell - SanDisk SN7100S (DPN
66DJG6): Problem można rozwiązać, aktualizując oprogramowanie wewnętrzne dysku SSD SanDisk SN7100S do wersji 7601.2002, A01 lub nowszej. Aby pobrać i zainstalować oprogramowanie wewnętrzne, zapoznaj się z artykułem: Pobieranie i instalowanie sterowników i oprogramowania wewnętrznego firmy Dell - SanDisk SN7100S (DPN
WYMVYi78KXH): Aktualizacja oprogramowania wewnętrznego dysku SSD SanDisk SN7100S do wersji 7601.2102, A01 lub nowszej rozwiązuje problem. Aby pobrać i zainstalować oprogramowanie wewnętrzne, zapoznaj się z artykułem: Pobieranie i instalowanie sterowników i oprogramowania wewnętrznego firmy Dell - SanDisk SN8000S bez SED (DPN
DVK06,H1CNHi50KMR): Aktualizacja oprogramowania wewnętrznego dysku SSD SanDisk SN8000s do wersji 6301.2103, A03 lub nowszej rozwiązuje problem. Aby pobrać i zainstalować oprogramowanie wewnętrzne, zapoznaj się z artykułem: Pobieranie i instalowanie sterowników i oprogramowania wewnętrznego firmy Dell - SanDisk SN8000S SED (DPN
N1KT3,0xH6P,4PF9Mi4FN86): Aktualizacja oprogramowania wewnętrznego dysku SSD SanDisk SN8000s do wersji 6311.2103, A03 lub nowszej rozwiązuje problem. Aby pobrać i zainstalować oprogramowanie wewnętrzne, zapoznaj się z artykułem: Pobieranie i instalowanie sterowników i oprogramowania wewnętrznego firmy Dell
Obejście problemu
Jeśli dysk twardy nie został jeszcze wymieniony powyżej z długoterminowym rozwiązaniem, skontaktuj się z firmą Microsoft, aby obejść ten problem. Zapoznaj się z krokami rozwiązywania błędów rozmiaru sektora dysku w sekcji SQL Server artykułu Rozwiązywanie problemów z rozmiarem sektora dysku systemu operacyjnego większym niż 4 KB.