Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products
  • Manage your Dell EMC sites, products, and product-level contacts using Company Administration.

Réparation d’un chargeur de démarrage EFI sur un disque dur GPT pour les systèmes d’exploitation Windows sur votre ordinateur Dell

Summary: Cet article fournit des informations sur la manière de résoudre les problèmes liés au chargeur de démarrage EFI qui ne démarre pas correctement sur un disque dur GPT. Il fournit des instructions pour différents systèmes d’exploitation Windows. ...

This article may have been automatically translated. If you have any feedback regarding its quality, please let us know using the form at the bottom of this page.

Article Content


Symptoms

Cause

Introduction

 

La plupart des personnes qui rencontrent des problèmes de démarrage sous des systèmes d’exploitation Windows choisissent de réinstaller le système d’exploitation plutôt que de tenter de résoudre le problème de démarrage proprement dit.

Cet article explique comment réparer le chargeur de démarrage EFI (Extensible Firmware Interface) sur un disque dur GPT (GUID [Globally Unique Identifiers] Partition Table).

Cette solution fonctionne uniquement pour les systèmes d’exploitation installés sur un BIOS (Basic Input/Output System) de l’UEFI (Unified Extensible Firmware Interface).


Retour au début


Resolution

Réparation de votre chargeur de démarrage EFI

 

Windows 7 et Windows 8 s’installent généralement sur un BIOS hérité qui utilise l’enregistrement de démarrage principal (MBR). Cependant, Windows 11 et Windows 10 ont été conçus pour être installés sur le BIOS UEFI à l’aide du chargeur de démarrage EFI et du GPT.

Remarque : si vous tentez de réparer la racine d’un disque dur, vous risquez de perdre toutes les données du disque que vous n’avez pas encore sauvegardées. Il est conseillé de toujours effectuer une sauvegarde complète avant d’intervenir sur un disque ou sur son système d’exploitation.

La structure GPT traite d’un grand nombre des problèmes résolus par la commande Bootsect dans le MBR. Toutefois, les instructions suivantes vous permettent de réparer le chargeur de démarrage EFI :

Windows 11

Si vous disposez du support d’installation :

  1. Insérez le support (DVD/USB) dans votre ordinateur personnel et redémarrez.

  2. Démarrez à partir du support.

  3. Cliquez sur Réparer l’ordinateur.

  4. Sélectionnez Résolution des problèmes.

  5. Sélectionnez Options avancées.

  6. Sélectionnez Invite de commandes dans le menu :

    1. Saisissez et exécutez la commande suivante :

      diskpart

    2. Saisissez et exécutez la commande suivante :

      select disk 0

    3. Saisissez et exécutez la commande suivante :

      list vol

  7. Vérifiez que la partition EFI (EPS, EFI System Partition) utilise le système de fichiers FAT32. Attribuez-lui une lettre de lecteur qui n’est pas encore utilisée :

    1. Saisissez et exécutez la commande suivante :

      select vol

    2. Saisissez et exécutez la commande suivante :

      assign letter=

    3. Saisissez et exécutez la commande suivante :

      exit

 
Remarque : accédez aux informations à la fin de cette section d’instructions.
 

Si vous ne disposez pas du support d’installation :

  1. Utilisez l’une des méthodes décrites dans l’article suivant pour démarrer à partir du menu Options de démarrage avancées Windows :

  2. Sélectionnez Réparer votre ordinateur dans le menu qui s’affiche.

  3. Sélectionnez Invite de commande dans l’onglet Options avancées de l’écran Résolution des problèmes :

    1. Saisissez et exécutez la commande suivante :

      diskpart

    2. Saisissez et exécutez la commande suivante :

      select disk 0

    3. Saisissez et exécutez la commande suivante :

      list vol

  4. Vérifiez que la partition EFI (EPS) utilise le système de fichiers FAT32 et attribuez-lui une lettre de lecteur (attribuez une lettre qui n’est pas déjà utilisée) :

    1. Saisissez et exécutez la commande suivante :

      select vol

    2. Saisissez et exécutez la commande suivante :

      assign letter=

    3. Saisissez et exécutez la commande suivante :

      exit

  5. Pour réparer l’enregistrement de démarrage, procédez comme suit :

    1. Saisissez et exécutez la commande suivante :

      cd /d :\EFI\Microsoft\Boot\

    2. Saisissez et exécutez la commande suivante :

      bootrec /FixBoot

Windows 10

Si vous disposez du support d’installation :

  1. Insérez le support (DVD/USB) dans votre ordinateur personnel et redémarrez.

  2. Démarrez à partir du support.

  3. Cliquez sur Réparer l’ordinateur.

  4. Sélectionnez Résolution des problèmes.

  5. Sélectionnez Options avancées.

  6. Sélectionnez Invite de commandes dans le menu :

    1. Saisissez et exécutez la commande suivante :

      diskpart

    2. Saisissez et exécutez la commande suivante :

      sel disk 0

    3. Saisissez et exécutez la commande suivante :

      list vol

  7. Vérifiez que la partition EFI (EPS, EFI System Partition) utilise le système de fichiers FAT32. Attribuez-lui une lettre de lecteur qui n’est pas encore utilisée :

    1. Saisissez et exécutez la commande suivante :

      sel vol

    2. Saisissez et exécutez la commande suivante :

      assign letter :

    3. Saisissez et exécutez la commande suivante :

      exit

Remarque : si vous utilisez Windows 10 (version 1709 ou plus récente), ignorez l’étape 8 et passez directement aux informations figurant à la fin de cette section d’instructions.
 
  1. Pour réparer l’enregistrement de démarrage, procédez comme suit :

    1. Saisissez et exécutez la commande suivante :

      cd /d :\EFI\Microsoft\Boot\

    2. Saisissez et exécutez la commande suivante :

      bootrec /FixBoot

 

Si vous ne disposez pas du support d’installation :

  1. Utilisez l’une des méthodes décrites dans l’article suivant pour démarrer à partir du menu Options de démarrage avancées Windows :

  2. Sélectionnez Réparer votre ordinateur dans le menu qui s’affiche.

  3. Sélectionnez Invite de commande dans l’onglet Options avancées de l’écran Résolution des problèmes :

    1. Saisissez et exécutez la commande suivante :

      diskpart

    2. Saisissez et exécutez la commande suivante :

      sel disk 0

    3. Saisissez et exécutez la commande suivante :

      list vol

  4. Vérifiez que la partition EFI (EPS) utilise le système de fichiers FAT32 et attribuez-lui une lettre de lecteur (attribuez une lettre qui n’est pas déjà utilisée) :

    1. Saisissez et exécutez la commande suivante :

      sel vol

    2. Saisissez et exécutez la commande suivante :

      assign letter=:

    3. Saisissez et exécutez la commande suivante :

      exit

  5. Pour réparer l’enregistrement de démarrage, procédez comme suit :

    1. Saisissez et exécutez la commande suivante :

      cd /d :\EFI\Microsoft\Boot\

    2. Saisissez et exécutez la commande suivante :

      bootrec /FixBoot

Windows 8 et Windows 8.1

Si vous disposez du support d’installation :

  1. Insérez le support (DVD/USB) dans votre ordinateur personnel et redémarrez.

  2. Démarrez à partir du support.

  3. Cliquez sur Réparer l’ordinateur.

  4. Sélectionnez Résolution des problèmes.

  5. Sélectionnez Invite de commandes dans le menu :

    1. Saisissez et exécutez la commande suivante :

      diskpart

    2. Saisissez et exécutez la commande suivante :

      sel disk 0

    3. Saisissez et exécutez la commande suivante :

      list vol

  6. Vérifiez que la partition EFI (EPS, EFI System Partition) utilise le système de fichiers FAT32. Attribuez-lui une lettre de lecteur qui n’est pas encore utilisée :

    1. Saisissez et exécutez la commande suivante :

      sel vol

    2. Saisissez et exécutez la commande suivante :

      assign letter=:

    3. Saisissez et exécutez la commande suivante :

      exit

  7. Pour réparer l’enregistrement de démarrage, procédez comme suit :

    1. Saisissez et exécutez la commande suivante :

      cd /d :\EFI\Microsoft\Boot\

    2. Saisissez et exécutez la commande suivante :

      bootrec /FixBoot

Si vous ne disposez pas du support d’installation :

  1. Redémarrez votre ordinateur personnel.

  2. Appuyez rapidement sur la touche F8> une fois l’ordinateur sous tension, mais avant que l’écran de démarrage Windows ne s’affiche.

    Plusieurs tentatives peuvent être nécessaires. Le temps alloué pour cette opération a été réduit par rapport à Windows 7.

  3. Sélectionnez Réparer votre ordinateur dans le menu qui s’affiche.

  4. Sélectionnez Invite de commande dans l’écran Résolution des problèmes :

    1. Saisissez et exécutez la commande suivante :

      diskpart

    2. Saisissez et exécutez la commande suivante :

      sel disk 0

    3. Saisissez et exécutez la commande suivante :

      list vol

  5. Vérifiez que la partition EFI (EPS) utilise le système de fichiers FAT32. Attribuez-lui une lettre de lecteur qui n’est pas encore utilisée :

    1. Saisissez et exécutez la commande suivante :

      sel vol

    2. Saisissez et exécutez la commande suivante :

      assign letter=:

    3. Saisissez et exécutez la commande suivante :

      exit

  6. Pour réparer l’enregistrement de démarrage, procédez comme suit :

    1. Saisissez et exécutez la commande suivante :

      cd /d :\EFI\Microsoft\Boot\

    2. Saisissez et exécutez la commande suivante :

      bootrec /FixBoot

Windows 7

Si vous disposez du support d’installation :

  1. Insérez le support (DVD/USB) dans votre ordinateur personnel et redémarrez.

  2. Démarrez à partir du support.

  3. Cliquez sur Réparer l’ordinateur.

  4. Sélectionnez le système d’exploitation, puis cliquez sur Suivant.

  5. Sélectionnez Invite de commandes dans le menu :

    1. Saisissez et exécutez la commande suivante :

      diskpart

    2. Saisissez et exécutez la commande suivante :

      sel disk 0

    3. Saisissez et exécutez la commande suivante :

      list vol

  6. Vérifiez que la partition EFI (EPS, EFI System Partition) utilise le système de fichiers FAT32. Attribuez-lui une lettre de lecteur qui n’est pas encore utilisée :

    1. Saisissez et exécutez la commande suivante :

      sel vol

    2. Saisissez et exécutez la commande suivante :

      assign letter=:

    3. Saisissez et exécutez la commande suivante :

      exit

  7. Pour réparer l’enregistrement de démarrage, procédez comme suit :

    1. Saisissez et exécutez la commande suivante :

      cd /d :\EFI\Microsoft\Boot\

    2. Saisissez et exécutez la commande suivante :

      bootrec /FixBoot

Si vous ne disposez pas du support d’installation :

  1. Redémarrez votre ordinateur personnel.

  2. Appuyez rapidement sur la touche F8> une fois l’ordinateur sous tension, mais avant que l’écran de démarrage Windows ne s’affiche.

  3. Sélectionnez Réparer votre ordinateur dans le menu qui s’affiche.

  4. Sélectionnez Invite de commandes dans les Options de récupération.

    1. Saisissez et exécutez la commande suivante :

      diskpart

    2. Saisissez et exécutez la commande suivante :

      sel disk 0

    3. Saisissez et exécutez la commande suivante :

      list vol

  5. Vérifiez que la partition EFI (EPS) utilise le système de fichiers FAT32 et attribuez-lui une lettre de lecteur qui n’est pas déjà utilisée.

    1. Saisissez et exécutez la commande suivante :

      sel vol

    2. Saisissez et exécutez la commande suivante :

      assign letter=:

    3. Saisissez et exécutez la commande suivante :

      exit

  6. Pour réparer l’enregistrement de démarrage, procédez comme suit :

    1. Saisissez et exécutez la commande suivante :

      cd /d :\EFI\Microsoft\Boot\

    2. Saisissez et exécutez la commande suivante :

      bootrec /FixBoot

Windows 11 et Windows 10 (version 1709 et versions ultérieures) :

  1. Reconstruisez le magasin BCD.

    1. Commencez par exécuter la commande ci-dessous pour sauvegarder l’ancien BCD :

      ren BCD BCD.bak

    2. Recréez-le ensuite à l’aide de la commande suivante :

      bcdboot c:\Windows /s : /f ALL (Vous pouvez ajouter un commutateur avant /s pour les paramètres régionaux de l’ordinateur : /l . Par défaut, l’anglais américain /l en-us est utilisé.)

    3. bootrec /rebuildbcd

Windows 10 (avant la version 1709), Windows 8 et Windows 7 :

  1. Reconstruisez le magasin BCD.

    1. Commencez par exécuter la commande ci-dessous pour sauvegarder l’ancien BCD :

      ren BCD BCD.old

    2. Recréez-le ensuite à l’aide de la commande suivante :

      bcdboot c:\Windows /l en-us /s : All


Retour au début


 

Réparation de votre MBR (enregistrement de démarrage principal)

 

Ces étapes s’appliquent à tout disque existant, utilisé comme disque de démarrage sur un système d’exploitation Windows récent.

  1. Pour accéder au menu de démarrage, appuyez sur la touche F12 quand l’écran de démarrage Dell s’affiche. Ce menu vous permet de démarrer à partir du support d’installation de Windows, d’un disque amorçable ou d’un lecteur Flash.

  2. Cliquez sur le lien Réparer votre ordinateur en bas de l’écran Installer maintenant.

  3. Cliquez sur Dépanner.

  4. Sélectionnez Invite de commandes.

  5. Saisissez les trois commandes suivantes tour à tour, puis, après chacune d’elle, appuyez sur la touche Entrée :

    bootrec /fixmbr

    bootrec /fixboot

    bootrec /rebuildbcd

  6. Redémarrez l’ordinateur après avoir retiré le support d’installation pour vérifier si la réparation a fonctionné.

 

Si vous avez besoin d’une aide supplémentaire, contactez le support technique.

 

  Contactez-nous  


Retour au début


Additional Information

Articles recommandés

Voici quelques articles recommandés sur ce sujet qui peuvent vous intéresser.


Support hors garantie Hors garantie ? Aucun problème. Consultez le site Web Dell.com/support, puis saisissez votre numéro de série Dell et consultez nos offres.

Remarque : les offres sont uniquement disponibles pour les clients qui possèdent un ordinateur personnel aux États-Unis, au Canada, au Royaume-Uni, en France, en Allemagne, en Chine et au Japon. Serveur et stockage non applicable.

Article Properties


Affected Product

Inspiron, Latitude, Vostro, XPS, Fixed Workstations

Last Published Date

27 Apr 2023

Version

13

Article Type

Solution