Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Create and access a list of your products
  • Manage your Dell EMC sites, products, and product-level contacts using Company Administration.

Excessive Hard Drive Free Space Decreasing Over Time on Dell Computers

Summary: Some Dell computers running Windows 10 or Windows 11 may experience a reduction in available hard drive free space over time. This can occur within days, weeks, or months depending on the size of the hard drive and amount of stored data. ...

This article may have been automatically translated. If you have any feedback regarding its quality, please let us know using the form at the bottom of this page.

Article Content


Symptoms

The symptom is the hard drive used space is increasing over time. When a customer experiences an unusual amount of hard drive storage, it is observed that Windows System Protection settings changed automatically wherein the Max Usage slider moved to 100%.

The Windows System Protection settings window can be accessed by: In the Windows search bar, search for View Advanced System Settings in Windows and then open it. Go to the System Protection tab and then click the Configure button.

System Protection tab and Configure button
Figure 1: System Protection tab and Configure button

Disk Space Usage - Max Usage slider 100%
Figure 2: Disk Space Usage - Max Usage slider 100%

The Windows System Protection Disk Space Usage - Max Usage Slider has moved from 0% to 100%. This change impacts the Current Usage bytes by going from 0 bytes to an increasing hard drive storage space amount. To further explain this, see Figure 3 and 4 showing a Dell computer change from the Before symptom (Figure 3) to the After symptom (Figure 4).

Before example, system protection disabled
Figure 3: Before example, system protection disabled

After example, max usage jumped to 100%
Figure 4: After example, max usage jumped to 100%

When the Windows System Protection Disk Space Usage - Max Usage Slider goes to 100%, the hard drive free space continues to decrease over time to where the user will notice a degradation in performance.

Cause

The root cause of the issue is that the MaxSize parameter of the Windows Volume Shadow Copy Service (VSS) is not initially set.

Not having MaxSize initially set leaves the VSS in an "undefined" state, causing it to inadvertently become unbounded when an application like Dell SupportAssist OS Recovery attempts to read VSS data. As a result, the Windows System Protection Settings forces the Disk Space Usage Max Usage Slider to 100%. This mirrors the unlimited amount of Volume Shadow Copies and ultimately fills up the computer’s hard drive space.

Resolution

There are two options that the user can follow to resolve the issue of hard drive free space decreasing over time. Customers must only choose one option.

Option 1: Set the Windows System Protection Disk Space Usage Max Usage Slider to 2%

  1. In the Windows search bar, search and then open View Advanced System Settings.
  2. Go to the System Protection tab and then click the Configure button (Figure 5).

System Protection tab and Configure button
Figure 5: System Protection tab and Configure button

  1. Click the Delete button to delete all restore points for this drive (Figure 6).
  2. Move the Max Usage Slider to 2%.
  3. Click the OK button to save the changes.

Deleting all restore points and setting Max Usage to 2%
Figure 6: Deleting all restore points and setting Max Usage to 2%

Option 2 (Advanced Users): Change the VSS MaxSize parameter from unbounded to 2%

The VSS MaxSize parameter can be set by opening an administrative Command Prompt window and typing in the following command:

vssadmin resize shadowstorage /For=C: /On=C: /MaxSize=2%

Setting the VSS MaxSize parameter to 2%
Figure 7: Setting the VSS MaxSize parameter to 2%

Press Enter after typing the command and then read the response to confirm that changes are successful. A response stating, "Successfully resized the shadow copy storage association" confirms success.

Article Properties


Affected Product

SupportAssist for Home PCs, SupportAssist OS Recovery, SupportAssist for Business PCs

Last Published Date

12 May 2023

Version

6

Article Type

Solution