Skip to main content

Dell Dock WD19 or WD19S Power Button LED Stop Working After Undocking and Re-docking to XPS 13 9300

Summary: This article provides information about the Dell Dock WD19 or WD19S Power Button LED turning off after undocking and re-docking to the XPS 13 9300.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Dell Dock WD19 or WD19S users may find that the power button LED turns off and stops functioning when they attempt to undock and immediately re-dock to XPS 13 9300. However, it does not impact the USB2, USB3, DisplayPort, HDMI, LAN, or Audio functionality.

Affected Configurations:

  • Dell Dock WD19 with XPS 13 9300
  • Dell Dock WD19S with XPS 13 9300

Cause

This is working as designed. Dell Docking Electronic and Communication (EC) delays for a period of time for USB Hub to begin initialization when you attach or detach the dock to the computer. If you detach the Docking Station from the computer and connect immediately, the docking station fails to initialize and does not function properly. This applies to all Dell Docking stations.

Resolution

Remove the dock and wait for a few seconds before reinserting it into the computer.

Affected Products

Dell Dock WD19, Dell Dock – WD19S, XPS 13 9300
Article Properties
Article Number: 000130941
Article Type: Solution
Last Modified: 17 Apr 2025
Version:  9
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.