PowerStore: A falha do serviço NTPD resulta em uma reinicialização do nó

Summary: Uma reinicialização inesperada do nó pode ser observada ao usar svc_ntp_ctl comando.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Uma reinicialização inesperada do nó poderá ser observada se o comando svc_ntp_ctl --set for usado nos seguintes cenários:
  • Executado várias vezes em um nó por meio de várias sessões paralelas ou em um curto período
  • Executado várias vezes em ambos os nós em paralelo ou em um curto período de tempo
O mesmo sintoma pode ocorrer se o comando svc_ntp_ctl --set for executado ao aplicar atualizações de configuração do servidor NTP por meio da WebUI, da API REST ou do PSTCLI.

O nó é reinicializado e se recupera automaticamente.

Cause

O comando svc_ntp_ctl --set pode não vincular a porta ntpd internamente se outro processo estiver segurando a porta executando comandos simultâneos svc_ntp_ctl --set ou por uma solicitação de atualização do servidor NTP.
No PowerStoreOS 3.0 e 3.2, o serviço ntpd tenta reiniciar imediatamente após uma falha, portanto, ele esgotará rapidamente sua contagem de reinicialização nessa condição e declarará que o serviço falhou.
Devido ao projeto da política de ha de orquestração, o sistema iniciou proativamente uma reinicialização do nó quando o serviço ntpd falhou como parte das ações de auto-recuperação.

Resolution

Esse problema foi corrigido no PowerStoreOS 3.5.

Solução temporária para evitar que esse problema ocorra
Para evitar que o problema ocorra, execute o comando svc_ntp_ctl --set , um de cada vez, em um equipamento, somente quando necessário.
Além disso, não execute o comando svc_ntp_ctl --set ao aplicar atualizações de configuração do servidor NTP por meio da interface do usuário do PowerStore Manager, da API REST ou do PSTCLI.

Additional Information

Affected Products

PowerStore
Article Properties
Article Number: 000215670
Article Type: Solution
Last Modified: 14 Jun 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.