AppSync:Appsync-backup.bat處於偵錯模式 My Stop 回應,並顯示訊息:無法建立 Keycloak 目錄

Summary: 處於除錯模式的Appsync-backup.bat可能會停止回應,並顯示訊息:無法建立 keycloak 目錄:C:\EMC\AppSync\jboss\datastore\data\AppSync_Keycloak

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

如果產品用於安裝的磁碟機上存在任何這些資料夾,執行 AppSync 資料庫備份的任何功能可能會停止回應。 
\EMC\AppSync\jboss\datastore\data\AppSync_Lockbox
 \EMC\AppSync\jboss\datastore\data\AppSync_Keycloak
 \EMC\AppSync\jboss\datastore\data\configFiles
 \EMC\AppSync\jboss\datastore\data\AppSync_Ese
 \EMC\AppSync\jboss\datastore\data\AppSync_LIC
以偵錯模式從 <install dir>\backup-assistant 資料夾執行appsync-backup.bat,例如:
appsync-backup -d
在假設「C」為安裝磁碟機時停止回應並出現下列錯誤:
 Failed to create keycloak directory :C:\EMC\AppSync\jboss\datastore\data\AppSync_Keycloak

Cause

Appsync-backup.bat在未定義陣列的資料庫上執行,且已知該陣列會停止回應 AppSync 4.4 及更新版本,則會保留下列資料夾 (假設安裝磁碟機為 C:):
C:\EMC\AppSync\jboss\datastore\data\AppSync_Lockbox
C:\EMC\AppSync\jboss\datastore\data\AppSync_Keycloak
C:\EMC\AppSync\jboss\datastore\data\configFiles
C:\EMC\AppSync\jboss\datastore\data\AppSync_Ese
C:\EMC\AppSync\jboss\datastore\data\AppSync_LIC
這會導致 appsync-backup.bat 公用程式的後續運行停止回應,即使在升級期間固有地運行也是如此。但是,以偵錯模式手動執行時,會顯示錯誤:
Failed to create keycloak directory :C:\EMC\AppSync\jboss\datastore\data\AppSync_Keycloak

Resolution

刪除下列資料夾:
C:\EMC\AppSync\jboss\datastore\data\AppSync_Lockbox
C:\EMC\AppSync\jboss\datastore\data\AppSync_Keycloak
C:\EMC\AppSync\jboss\datastore\data\configFiles
C:\EMC\AppSync\jboss\datastore\data\AppSync_Ese
C:\EMC\AppSync\jboss\datastore\data\AppSync_LIC

Products

AppSync
Article Properties
Article Number: 000200777
Article Type: Solution
Last Modified: 14 May 2026
Version:  7
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.