Error "discoverDevices" del comando "discoverDevices" de SRA "No se pudo conectar al host de administración de arreglos" en el sitio principal

Summary: El comando "discoverDevices" de Storage Replication Adapter (SRA) falla y muestra el mensaje "No se pudo conectar al host de administración de arreglos" en el sitio principal.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Error en los registros de SrdfSRA desde cualquiera de los sitios:

[03/23 16:12:54  08332                      0114  SymapiSession::Init                      ] Initializing SYMAPI session for remote server [1xx.1x.2.1:2707]
[03/23 16:12:54  08332                      0120  SymapiSession::Init                      ] SymInit() [ReadModifyNowrite]
[03/23 16:12:58  08332                      0130  SymapiSession::Init                      ] [ERROR]: Failed to perform SymInit().
 
[ERROR]: [SYMAPI_C_NET_OPR_ERROR : A remote send or receive operation failed]
[03/23 16:12:58  08332                      0025  SymapiSession::SymapiSession             ] [ERROR]: Failed to initialize Symapi session

Error en el registro storsrvd de Solutions Enabler:

03/23/2022 16:12:55.835  : ANR0151E Common Name in client certificate not valid: expected "SrmHostname", received "storsrvd fac838c410cd"

Or

03/23/2022 16:12:55.835  : ANR0151E Common Name in client certificate not valid: expected "SrmHostname", received "storsrvd 1xx.1x.2.1"

Cause

Las causas de este problema pueden ser:
  • Un firewall bloqueado: cada host docker de Site Recovery Manager (SRM) o SRA debe poder conectarse al demonio storsrvd de ambos hosts de Solutions Enabler (SE). El puerto predeterminado es 2707.
  • El nombre de host o la IP del sistema de nombre de dominio (DNS) no se resolvieron correctamente.
  • Un certificado de cliente incorrecto
  • Todos los dispositivos de Remote Data Facility (RDF) están en modo de copia adaptable. SRA ignora todos los dispositivos RDF en la copia adaptable.

Resolution

El equipo de firewall del usuario debe abrir el puerto 2707 (u otro puerto si el usuario cambió el puerto storsrvd predeterminado).

Hay tres opciones para resolver el certificado del cliente:
  • Configure storsrvd en el servidor para no verificar (ignorar) las variables de certificado del cliente en el símbolo del sistema de la línea de comandos:
  1. Abra installdir/symapi/config/daemon_options y configure la variable como se muestra a continuación; luego, reinicie el demonio storsrvd:
storsrvd:SECURITY_CLT_SECURE_LVL  = NOVERIFY
  • Configure storsrvd en el servidor para usar conexiones no seguras:
  1. Abra installDir/symapi/config/options y configure la variable como se muestra a continuación y, a continuación, reinicie el demonio storsrvd:
SYMAPI_SECURITY_LEVEL = NONSECURE
  • Actualice el certificado de Solutions Enabler en el docker de SRA:
  1. Inicie sesión en el docker de SRM como "admin".
  2. Cambiar a usuario raíz
su root
  1. Conectarse a la estación acoplable
Captura de pantalla de la conexión a Docker
  1. Compruebe el nombre de host actual del certificado de SE
Comprobar el nombre de host actual
  1. Si el certificado no enumera el nombre de host, cree un certificado nuevo
Crear un nuevo certificado
  1. La contraseña de Lockbox es "dockerID@SELockbox1". En este ejemplo, es '0c6837ce4e7b@SELockbox1'.

Additional Information

Comprobaciones de solución de problemas:
  • Compruebe la configuración del arreglo.
  • Intente usar la IP y el nombre de host para descartar problemas de DNS.
  • Verifique que el demonio de RDF esté en funcionamiento en ambos lados y habilitado en el archivo de opciones.
  • Verifique que las credenciales de usuario de vCenter estén presentes
symcfg auth list -vmware
  • Verifique que el entorno tenga una red abierta.
  • Compruebe que el puerto 2707 esté escuchando, descarte problemas de firewall.
  • Asegúrese de que no haya problemas de enlace de RDF.
Article Properties
Article Number: 000167652
Article Type: Solution
Last Modified: 14 Feb 2024
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.