VxRail:VxRail 主机故障处理指南 按顺序重新启动

Summary: 本文总结了顺序重新启动预检查步骤和重新启动步骤中的常见故障原因,并提供了解决问题的建议操作。

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

VxRail 7.0.480 引入了主机按顺序重新启动功能。

显示主机顺序重新启动功能的屏幕

在重新启动开始之前,会运行预检查。这些设计旨在防止潜在故障。
如果在重新启动过程中遇到错误,则将跳过主机,并继续执行下一个主机。

如果在预检查或重新启动期间报告任何问题,请按照本文解决问题。

Cause

各种错误可能会导致预检查或重新启动失败,请参阅本文下面的更多详细信息。

Resolution

预检查步骤中可能出现的错误和建议的操作。

错误消息 建议的操作
DRS 未完全启用。 将 DRS 自动化级别设置为“完全自动化”。确保您已在 vCenter 中安装执行此操作所需的 vSphere 许可证。DRS 功能是该功能的最低要求。
在此主机上找到了使用 vGPU 运行的虚拟机。 请参阅 VxRail:将主机置于维护模式以解决问题时,具有 vGPU 的虚拟机迁移失败
计划的时间应少于 7 天。 将计划的重新启动时间设置为 7 天内。
主机处于维护模式。 在所选主机上禁用维护模式。重新启动过程会在重新启动之前将主机置于维护模式。
主机-虚拟机相关性规则阻止虚拟机迁移到另一个主机。请禁用规则或关闭虚拟机。 通过转至 VxRail 群集 > 配置 > 配置 > 虚拟机/主机规则,检查 vCenter 中故障主机的虚拟机与主机关联性规则。如果有规则将该虚拟机限制为单个主机,请与虚拟机管理员讨论。如果要对该主机使用此功能,请禁用该规则或关闭虚拟机。
当前群集的主机数不应少于 2 个(或 3 个)。 确保群集中没有主机处于维护模式。如果有,您可能需要将主机退出维护模式,以将活动主机的数量提高到大于 2(或 3)。
重新启动被阻止, <因为lock_owner> 已启动锁定。

另一项 VxRail 操作仍在进行,这会阻止重新启动继续。等待上一个操作完成。

提醒:戴尔不建议在两次部分升级之间执行主机顺序重新启动。对于确认风险并希望自行承担重新启动风险的用户,请联系戴尔技术支持以获取帮助。

vSAN 群集未处于正常运行状态。 在 vCenter 中的 Skyline 运行状况下查看 vSAN 群集运行状况。有关 Skyline 运行状况故障处理的更多详细信息,请参阅此 VMware 文档。(外部链接)
vSAN 群集正在重新同步。 转至群集监测vSAN重新同步对象并检查详细信息。您可能需要等到重新同步完成后再执行重新启动。
无法使用 vCenter 连接到主机。 检查主机与 vCenter 之间的连接。如果主机状态为“not responding”,则必须对主机与 vCenter 之间的连接问题进行故障处理。
虚拟机在此主机上的非共享数据存储区上运行。 关闭虚拟机、挂起虚拟机或将虚拟机迁移到另一个不打算重新启动的主机。或者,将虚拟机的存储迁移到群集中的其他主机可以访问的共享数据存储区。

 

重新启动步骤中可能出现的错误和建议的操作。

错误消息 建议的操作
未能进入维护模式。 要查看进入维护模式的失败原因,请单击vSphere ClientTask > Console。修复问题并重试进入维护模式。或者,请参阅如何从 vSAN 角度检查 ESXi 维护模式状态 ,了解有关维护模式的更多详细信息。
主机处于维护模式。 要将主机退出维护模式,请右键单击主机,然后选择维护模式 > 退出维护模式。主机退出维护模式后,在配置 > VxRail > 主机页面上选择重,重新启动过程将再次运行。
无法启动主机 这可能是因为主机在重新启动后启动至 ESXi 时出现问题。从 iDRAC 打开服务器控制台,以查看服务器启动至 ESXi 的状态。
重新启动达到超时 单个主机重新启动超时设置为 20 分钟,如果由于环境问题重新启动需要更多时间才能完成,请联系戴尔技术支持以增加超时值。
Article Properties
Article Number: 000216816
Article Type: Solution
Last Modified: 26 May 2026
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.