PowerStore: PUHC to Prevent System Instability Due to Issue During Disk Firmware Upgrade

Summary: A new Pre-Upgrade Health Check (PUHC) was introduced in PowerStoreOS 4.1 and 4.2 to proactively prevent system instability. Instability is caused by a drive firmware upgrade issue associated with drives running firmware versions VPV1ET10 or VPV1ET0K. ...

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Symptoms

When transitioning from firmware version VPV1ET10 or VPV1ET10K to firmware version VPV1ET13, a drive may stop responding during the "Activate" phase of the firmware upgrade process if at a critical time the drive receives an "Identity" command from the PowerStore Platform Manager (PM). This behavior is intermittent due to the periodic nature of the PowerStore PM poller and the short timing window during which the drive firmware upgrade process is vulnerable to this issue.

Systems with drives running firmware VPV1ET10 or VPV1ET0K must first upgrade drive firmware to version VPV1ET13 before initiating an upgrade to PowerStoreOS version 4.1 or 4.2.
  • This Pre-Upgrade Health Check (PUHC) blocks upgrades from PowerStoreOS versions 3.x or 4.0.x to PowerStoreOS versions 4.1 or 4.2 if drives with firmware VPV1ET10 or VPV1ET0K are detected.
    • Systems meeting the above criteria must first upgrade drive firmware to version VPV1ET13 before initiating an upgrade to PowerStoreOS version 4.1 or 4.2
  • This PUHC also blocks a disk firmware upgrade if drives are running firmware VPV1ET10 or VPV1ET0K and the appliance is running PowerStoreOS versions 4.1.0.0, 4.1.0.1, 4.1.0.2, or 4.2.0.0 
    • Systems meeting the above criteria must first upgrade to a PowerStoreOS version that mitigates this issue.

If PUHC detects the criteria above, the PowerStore Manager UI displays the following message:

message screen

Impact

Systems with drives running firmware versions VPV1ET10 or VPV1ET0K are at elevated risk of experiencing instability during a drive firmware upgrade to firmware version VPV1ET13 when the appliance is running PowerStoreOS version 4.1 or 4.2. Systems affected by this issue can experience unplanned downtime requiring manual intervention. 

Cause

During the firmware "Activate" phase, when transitioning from version VPV1ET10 or VPV1ET10K to version VPV1ET13, the drive may stop responding if an Identify command is issued within a critical timing window. 

Resolution

Upgrade drives running firmware versions VPV1ET10 or VPV1ET0K to firmware version VPV1ET13 before upgrading the appliance to PowerStoreOS version 4.1 or 4.2. Once drive firmware is on version VPV1ET13, the drive is no longer vulnerable to this issue. 

A system running PowerStoreOS versions 4.1.0.0, 4.1.0.1, 4.1.0.2, or 4.2.0.0 with drives running firmware versions VPV1ET10 or VPV1ET0K must upgrade to a PowerStoreOS version that mitigates the issue. 

This issue is addressed within PowerStoreOS
 versions 4.1.0.3 and 4.3.0. Refer to PowerStore, Info Hub - Product Documentation and Videos for PowerStoreOS Release Notes.

Affected Products

PowerStore 1000T, PowerStore 1200T, PowerStore 3000T, PowerStore 3200T, PowerStore 5000T, PowerStore 5200T, PowerStore 7000T, PowerStore 9000T, PowerStore 9200T
Article Properties
Article Number: 000367346
Article Type: Solution
Last Modified: 02 Dec 2025
Version:  2
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