PowerStore: PUHC zur Vermeidung von Systeminstabilität aufgrund von Problemen während des Festplattenfirmwareupgrades
Summary: Eine neue Integritätsprüfung vor dem Upgrade (Pre-Upgrade Health Check, PUHC) wurde in PowerStoreOS 4.1 und 4.2 eingeführt, um Systeminstabilität proaktiv zu verhindern. Instabilität wird durch ein Problem mit dem Upgrade der Laufwerksfirmware im Zusammenhang mit Laufwerken verursacht, auf denen Firmwareversionen VPV1ET10 oder VPV1ET0K ausgeführt werden. ...
Symptoms
Systeme mit Laufwerken, auf denen Firmware VPV1ET10 oder VPV1ET0K ausgeführt wird, müssen zunächst ein Upgrade der Laufwerksfirmware auf Version VPV1ET13 durchführen, bevor ein Upgrade auf PowerStoreOS Version 4.1 oder 4.2 initiiert wird.
- Dieser Health Check vor dem Upgrade (Pre-Upgrade Health Check, PUHC) blockiert Upgrades von PowerStoreOS-Versionen 3.x oder 4.0.x auf PowerStoreOS-Versionen 4.1 oder 4.2, wenn Laufwerke mit Firmware-VPV1ET10 oder -VPV1ET0K erkannt werden.
- Systeme, die die oben genannten Kriterien erfüllen, müssen zunächst ein Upgrade der Laufwerksfirmware auf Version VPV1ET13 durchführen, bevor ein Upgrade auf PowerStoreOS Version 4.1 oder 4.2 initiiert wird
- Diese PUHC blockiert auch ein Upgrade der Festplattenfirmware, wenn auf Laufwerken Firmware VPV1ET10 oder VPV1ET0K ausgeführt wird und auf der Appliance die PowerStoreOS-Versionen 4.1.0.0, 4.1.0.1, 4.1.0.2 oder 4.2.0.0 ausgeführt werden
- Systeme, die die oben genannten Kriterien erfüllen, müssen zunächst auf eine PowerStoreOS-Version aktualisiert werden, die dieses Problem behebt.
Wenn PUHC die oben genannten Kriterien erkennt, zeigt die PowerStore Manager-Benutzeroberfläche die folgende Meldung an:

Auswirkungen
Bei Systemen mit Laufwerken, auf denen die Firmwareversion VPV1ET10 oder VPV1ET0K ausgeführt wird, besteht ein erhöhtes Risiko, dass während eines Upgrades der Laufwerksfirmware auf Firmwareversion VPV1ET13 Instabilität auftritt, wenn auf der Appliance PowerStoreOS-Version 4.1 oder 4.2 ausgeführt wird. Bei Systemen, die von diesem Problem betroffen sind, können ungeplante Ausfallzeiten auftreten, die eine manuelle Intervention erfordern.
Cause
Während der Firmware-Aktivierungsphase beim Wechsel von Version VPV1ET10 oder VPV1ET10K zu Version VPV1ET13 reagiert das Laufwerk möglicherweise nicht mehr, wenn ein Identifizierungsbefehl innerhalb eines kritischen Zeitfensters ausgegeben wird.
Resolution
Aktualisieren Sie Laufwerke, auf denen Firmwareversionen VPV1ET10 oder VPV1ET0K ausgeführt werden, auf Firmwareversion VPV1ET13, bevor Sie die Appliance auf PowerStoreOS-Version 4.1 oder 4.2 aktualisieren. Sobald sich die Laufwerksfirmware auf Version VPV1ET13 befindet, ist das Laufwerk nicht mehr anfällig für dieses Problem.
Ein System, auf dem die PowerStoreOS-Versionen 4.1.0.0, 4.1.0.1, 4.1.0.2 oder 4.2.0.0 mit Laufwerken ausgeführt werden, auf denen die Firmwareversionen VPV1ET10 oder VPV1ET0K ausgeführt werden, muss auf eine PowerStoreOS-Version aktualisiert werden, die das Problem verringert.
Dieses Problem wird in den PowerStoreOS-Versionen 4.1.0.3 und 4.3.0 behoben. Weitere Informationen zu PowerStoreOS-Versionshinweisen finden Sie unter PowerStore, Info Hub – Produktdokumentation und Videos .