PowerStore : PUHC pour éviter l’instabilité du système due à un problème lors de la mise à niveau du firmware de disque
Summary: Un nouveau bilan de santé préalable à la mise à niveau (Pre-Upgrade Health Check, PUHC) a été introduit dans PowerStoreOS 4.1 et 4.2 afin d’éviter proactivement l’instabilité du système. L’instabilité est due à un problème de mise à niveau du firmware de disque associé à des disques exécutant les versions de firmware VPV1ET10 ou VPV1ET0K. ...
Symptoms
Les systèmes dotés de disques exécutant le firmware VPV1ET10 ou VPV1ET0K doivent d’abord mettre à niveau le firmware du disque vers la version VPV1ET13 avant de lancer une mise à niveau vers PowerStoreOS version 4.1 ou 4.2.
- Ce bilan de santé préalable à la mise à niveau (PUHC) bloque les mises à niveau à partir de PowerStoreOS versions 3.x ou 4.0.x vers PowerStoreOS versions 4.1 ou 4.2 si des disques avec firmware VPV1ET10 ou VPV1ET0K sont détectés.
- Les systèmes répondant aux critères ci-dessus doivent d’abord mettre à niveau le firmware du disque vers la version VPV1ET13 avant de lancer une mise à niveau vers PowerStoreOS version 4.1 ou 4.2
- Ce PUHC bloque également une mise à niveau du firmware de disque si les lecteurs exécutent le firmware VPV1ET10 ou VPV1ET0K et que l’appliance exécute PowerStoreOS versions 4.1.0.0, 4.1.0.1, 4.1.0.2 ou 4.2.0.0
- Les systèmes répondant aux critères ci-dessus doivent d’abord effectuer une mise à niveau vers une version de PowerStoreOS qui atténue ce problème.
Si PUHC détecte les critères ci-dessus, l’interface utilisateur de PowerStore Manager affiche le message suivant :

Impact
Les systèmes équipés de disques exécutant les versions VPV1ET10 ou VPV1ET0K du firmware sont exposés à un risque élevé d’instabilité lors d’une mise à niveau du firmware vers la version VPV1ET13 du firmware lorsque l’appliance exécute PowerStoreOS version 4.1 ou 4.2. Les systèmes affectés par ce problème peuvent subir des interruptions de service non planifiées nécessitant une intervention manuelle.
Cause
Lors de la phase d’activation du firmware, lors du passage de la version VPV1ET10 ou VPV1ET10K à la version VPV1ET13, le disque peut cesser de répondre si une commande d’identification est émise dans une fenêtre de temps critique.
Resolution
Mettez à niveau les disques exécutant les versions VPV1ET10 ou VPV1ET0K du firmware vers la version VPV1ET13 du firmware avant de mettre à niveau l’appliance vers PowerStoreOS version 4.1 ou 4.2. Une fois que le firmware de disque est à la version VPV1ET13, le disque n’est plus vulnérable à ce problème.
Un système exécutant PowerStoreOS versions 4.1.0.0, 4.1.0.1, 4.1.0.2 ou 4.2.0.0 avec des disques exécutant les versions de firmware VPV1ET10 ou VPV1ET0K doit effectuer une mise à niveau vers une version de PowerStoreOS qui atténue le problème.
Ce problème est résolu dans les versions 4.1.0.3 et 4.3.0 de PowerStoreOS. Pour obtenir les notes de mise à jour de PowerStoreOS, reportez-vous à PowerStore, Info Hub - Documentation produit et vidéos .