Data Protection Advisor (DPA) : La demande de collecte de données PPDM échoue avec la fonction interceptée InvalidStatusException

Résumé: La demande de collecte de données PPDM échoue avec la fonction de message interceptée InvalidStatusException

Cet article concerne Cet article ne concerne pas Cet article n’est associé à aucun produit spécifique. Toutes les versions du produit ne sont pas identifiées dans cet article.

Symptômes

La section History de la demande de collecte de données de PPDM Job Monitor contient le message d’état suivant :
Function jobmonitor caught ProcessingException

Le même message se produit dans le dpaagent.log après avoir demandé une réponse API au serveur PPDM :
ERR 12669.12677 20210211:071804 com.emc.dpa.agent.mo - execute() : Function jobmonitor caught InvalidStatusException

Cause

La demande d’API avant l’ERR n’a pas répondu avec l’état attendu.
Le dpaagent.log bas de débogage affiche la requête API qui a généré l’exception :

DBG1 12669.12677 20210211:071704 com.emc.dpa.agent.co - get() : GET [/api/v2/assets ?pageSize=5000&page=1]
ERR 12669.12677 20210211:071804 com.emc.dpa.agent.mo - execute() : Function jobmonitor caught InvalidStatusException


À l’aide d’un client REST, la requête /api/v2/assets ?pageSize=5000 générait le message suivant à partir du serveur PPDM après 60 secondes :

{ « reason » : « Gateway Timeout Error. », « remediation » : « Réessayez l’opération plus tard. », « code » : 504, « chemin » : « /api/v2/assets », « timestamp » : 1613473517745 }

L’erreur de délai d’expiration de la passerelle provient de PPDM après 60 secondes, quels que soient les délais d’expiration définis sur la demande DPA.
La demande d’API /api/v2/assets ?pageSize=100 renvoie avec succès des informations à partir du même serveur PPDM.

Résolution

DPA fonctionne comme prévu.
Le serveur PPDM renvoie un état inattendu pour la demande d’API en raison d’un problème de performance.
Ce problème doit être étudié du côté de PPDM.

Pour plus d’informations, contactez le support technique Dell.

Produits

Data Protection Advisor
Propriétés de l’article
Numéro d’article: 000184325
Type d’article: Solution
Dernière modification: 27 May 2026
Version:  5
Trouvez des réponses à vos questions auprès d’autres utilisateurs Dell
Services de support
Vérifiez si votre appareil est couvert par les services de support.