Dell Automatisierungsplattform: Beheben von 504-Gateway-Fehlern auf Bereitstellungs- und Blueprintseiten

Summary: In diesem Artikel wird ein seltenes Problem beschrieben, bei dem die Seiten "Bereitstellungen" und "Blueprints" nicht geladen werden können, was zu einem 504-Gateway-Timeout-Fehler führt. Der Fehler hängt möglicherweise mit dem nginx-Server zusammen. Ein Workaround wurde bereitgestellt, um das Problem zu beheben. ...

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Symptoms

  • Die Seiten Bereitstellungen und Blueprints können nicht geladen werden.
  • Ein 504-Gateway-Timeout-Fehler wird angezeigt.
  • Die Fehlermeldung geht von nginx/1.25.4.

Fehlermeldung: Bei der Fehlermeldung handelt es sich um eine HTML-Seite mit folgendem Inhalt:

<html> <head><title>504 Gateway Time-out</title></head> <body> <center><h1>504 Gateway Time-out</h1></center> <hr><center>nginx/1.25.4</center> </body> </html> <!- a padding to disable MSIE and Chrome friendly error page -> <!- a padding to disable MSIE and Chrome friendly error
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Cause

Die Ursache des Problems ist derzeit unbekannt, es wird jedoch vermutet, dass es mit dem nginx-Server zusammenhängt.

Resolution

Problemumgehung: Starten Sie den nginx-Server neu, um das Problem zu beheben. Dadurch sollten die Seiten "Bereitstellungen" und "Blueprints" korrekt geladen werden können.

Um den nginx-Pod neu zu starten, führen Sie die folgenden Schritte auf dem Dell Automation Platform-Cluster aus:

Identifizieren Sie den Namen des fusion-nginx-Pods, indem Sie den folgenden Befehl ausführen. Dadurch wird der Pod-Name angezeigt, ähnlich wie in der Beispielausgabe:

# kubectl get pods -A | grep fusion-nginx
hzp                fusion-nginx-758ddd5f7c-g6dfj                       2/2     Running            2 (66d ago)       93d

Löschen Sie den Pod mit dem folgenden Befehl. Ersetzend <pod_name> mit dem Namen des Pods (z. B. fusion-nginx-758ddd5f7c-g6dfj) und <namespace> mit dem richtigen Orchestrator-Namespace (z. B. hzp

# kubectl delete pod fusion-nginx-758ddd5f7c-g6dfj -n hzp
pod "fusion-nginx-758ddd5f7c-g6dfj" deleted

Der Kubernetes-Scheduler startet den nginx-Pod unmittelbar nach dem Löschen automatisch neu. Sie können das Löschen und Neustarten des Pods überprüfen, indem Sie die Ausgabe des Löschbefehls überprüfen. Daraufhin sollte eine Meldung angezeigt werden, die darauf hinweist, dass der Pod gelöscht wurde.

 

Fehlerbehebung: Dieses Problem wird von der Dell Automation Platform-Entwicklung untersucht.

Affected Products

Dell Automation Platform, NativeEdge Solutions, Dell Automation Platform Components, NativeEdge
Article Properties
Article Number: 000391508
Article Type: Solution
Last Modified: 14 Nov 2025
Version:  1
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