Platforma automatyzacji Dell: Rozwiązywanie błędów bramy 504 na stronach wdrożeń i projektów

Summary: W tym artykule opisano rzadki problem polegający na tym, że nie można załadować stron Wdrożenia i strategie, co powoduje błąd przekroczenia limitu czasu bramy 504. Błąd jest potencjalnie związany z serwerem nginx. W celu rozwiązania tego problemu zapewniono obejście problemu. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  • Nie można załadować stron Deployments i Blueprints.
  • Wyświetlany jest błąd przekroczenia limitu czasu bramy 504.
  • Komunikat o błędzie pochodzi z nginx/1.25.4.

Komunikat o błędzie: Komunikat o błędzie dotyczy strony HTML o następującej treści:

<html> <head><title>504 Gateway Time-out</title></head> <body> <center><h1>504 Gateway Time-out</h1></center> <hr><center>nginx/1.25.4</center> </body> </html> <!- a padding to disable MSIE and Chrome friendly error page -> <!- a padding to disable MSIE and Chrome friendly error
page -> <!- a padding to disable MSIE and Chrome friendly error page -> <!- a padding to disable MSIE and Chrome friendly error page -> <!- a padding to disable MSIE and Chrome friendly error page -> <!- a padding to disable MSIE and Chrome friendly error page ->

Cause

Główna przyczyna problemu jest obecnie nieznana, ale podejrzewa się, że jest związana z serwerem nginx.

Resolution

Obejście problemu: Aby rozwiązać problem, uruchom ponownie serwer nginx. Powinno to umożliwić prawidłowe załadowanie stron Wdrożenia i Projekty.

Aby ponownie uruchomić zasobnik nginx, wykonaj następujące kroki w klastrze Dell Automation Platform:

Zidentyfikuj nazwę zasobnika fusion-nginx, uruchamiając polecenie. Spowoduje to wyświetlenie nazwy zasobnika, podobnie jak w przykładowych danych wyjściowych:

# kubectl get pods -A | grep fusion-nginx
hzp                fusion-nginx-758ddd5f7c-g6dfj                       2/2     Running            2 (66d ago)       93d

Usuń zasobnik za pomocą poniższego polecenia. Wymiana <pod_name> z nazwą zasobnika (na przykład fusion-nginx-758ddd5f7c-g6dfj) oraz <namespace> z poprawną przestrzenią nazw programu Orchestrator (na przykład hzp

# kubectl delete pod fusion-nginx-758ddd5f7c-g6dfj -n hzp
pod "fusion-nginx-758ddd5f7c-g6dfj" deleted

Harmonogram Kubernetes automatycznie uruchomi zasobnik nginx natychmiast po usunięciu. Możesz zweryfikować usunięcie zasobnika i ponowne uruchomienie, sprawdzając dane wyjściowe polecenia usuwania. Powinien zostać wyświetlony komunikat wskazujący, że zasobnik został usunięty.

 

Rozwiązanie: Ten problem jest badany przez programistów platformy Dell Automation Platform.

Affected Products

Dell Automation Platform, NativeEdge Solutions, Dell Automation Platform Components, NativeEdge
Article Properties
Article Number: 000391508
Article Type: Solution
Last Modified: 14 Nov 2025
Version:  1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.