NMM: La sauvegarde SQL échoue avec l’erreur ERROR : nsrsqlsv reporting a bad page

Summary: La sauvegarde de NetWorker Module for Microsoft (NMM) échoue lorsque le client SQL exécutant Module for Microsoft Applications (NMM) et la base de données CHECKSUM sont activés pour la vérification de page. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

La session de sauvegarde d’une base de données SQL échoue via NetWorker et ne peut pas être ignorée.
NMM signale les erreurs suivantes à nsrsqlsv Connectez-vous côté client sous nsr/applogs path :

nsrsqlsv: Microsoft SQL server documentation provides details about the following SQL Server Provider error:
nsrsqlsv: BACKUP 'DB-name' detected an error on page (1:#) in file 'DB-name.mdf'.
nsrsqlsv: (Error: 3043)

Cause

Lorsque la configuration du client SQL a sélectionné la base de données CHECKSUM dans NMC :
Sélectionner l’option « Effectuer la somme de contrôle avant l’écriture sur le support » dans l’assistant client,
OU utiliser les propriétés manuelles du client -k paramètre ajouté au champ de commande de sauvegarde comme "nsrsqlsv -k» dans une ressource client. 

Resolution

Désactivez l’attribut CHECKSUM :

1 de la base de données SQL. Connectez-vous à NetWorker Management Console (NMC).
2. Accédez à l’onglet Protection et cliquez sur Clients.
3. Ajustez la configuration du client SQL à partir de NMC. Le client peut être modifié à l’aide de l’une des méthodes suivantes :

Assistant Modifier le client :

un. Cliquez avec le bouton droit de la souris sur le client, puis cliquez sur Assistant Modifier le client.
B. Dans le volet Spécifier les options de sauvegarde, continuez à décocher la case Effectuer une somme de contrôle avant d’écrire sur le support

L’option Effectuer la somme de contrôle avant l’écriture sur le support est désélectionnée

Modifiez les propriétés du client :

un. Cliquez avec le bouton droit de la souris, puis sélectionnez Modify Client Properties.
B. Dans l’onglet Applications et modules, décochez l’icône «-k' dans le champ Commande de sauvegarde .


4. Exécutez à nouveau la sauvegarde.

Additional Information

Pour confirmer que cet échec de sauvegarde NMM n’est pas lié au problème NetWorker, demandez à l’administrateur de base de données SQL d’effectuer les opérations suivantes : 

  • Testez la même sauvegarde de base de données SQL à l’aide de l’outil SQL NATIVE, à partir de SQL Server Management Studio (SSMS) T-SQL comme :
    • BASE DE DONNÉES DE SAUVEGARDE [nameofDB] à DIsk='somediskpathwithspace' avec CHECKSUM
    • Remarque :  La base de données de sauvegarde TSQL est définie par défaut sur NO_CHECKSUM.

Affected Products

NetWorker Family, NetWorker, NetWorker Module, NetWorker Module for Microsoft
Article Properties
Article Number: 000194757
Article Type: Solution
Last Modified: 13 Jan 2026
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.