Data Protection Central Internal LDAP werkt niet na IDPA-upgrade

Summary: Na de IDPA-upgrade werkt LDAP van de Data Protection Central (DPC)-server niet.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Interne LDAP werkt niet:

  • Identiteitsbron is aanwezig, maar wordt weergegeven als niet-verbonden
  • De groep is ook verdwenen uit de identificeerbare bron
  • Er wordt een fout opgetreden bij het toevoegen van een rol

In het /var/log/dpc/iam/iam-provider/keycloak.log (als root) worden de volgende certificaatfouten weergegeven:

2024-10-21 17:17:53,937 ERROR [org.keycloak.services] (executor-thread-17) KC-SERVICES0055: Error when connecting to LDAP: <ACM FQDN>:636: javax.naming.CommunicationException: <AMC FQDN>:636 [Root exception is javax.net.ssl.SSLHandshakeException: PKIX path validation failed: java.security.cert.CertPathValidatorException: signature check failed]

In het /var/log/dpc/iam/iam-service/iam-service.log (als root) worden de volgende fouten bij het toevoegen van LDAP-groepen weergegeven:

2024-10-21 13:22:44,810 INFO https-jsse-nio-9922-exec-9 c.e.c.s.s.IndetitySourceService LDAP instance Id: ae45949d-40dd-46ee-8136-bc40e0d32644 . Adding group role mapping for [cn=dp_admin,ou=Group,dc=idpa,dc=local]

In het /var/log/dpc/elg/elg.log, worden ook fouten bij het toevoegen van groepen gezien:

2024-10-21 13:22:44,949 ERROR https-jsse-nio-9922-exec-9 c.e.c.s.s.GlobalExceptionHnalder IdentitySourceException:com.emc.clp.security.exception.IdentitySourceException: Failed to create group role mapping. Received error for ldap mapper group [MapperGroup(cn=dp_admin,ou=Group,dc=idpa,dc=local] creation.

Cause

Na het upgraden van IDPA kan de DPC-server geen verbinding maken met de ACM LDAP-server of de groep toevoegen. 

Resolution

Procedure:

  1. Meld u als beheerder aan bij de DPC CLI met behulp van SSH or PuTTY als su - naar rootgebruiker.
  2. Voer de volgende opdrachten uit:
service dp-iam restart
service msm-elg restart
  1. Meld u aan bij de DPC-gebruikersinterface en ga naar Identiteitsbronnen voor beheer>.

Het menu DPC UI wordt weergegeven voor: Identiteitsbronnen voor beheer >

  1. Voeg de identiteitsbron voor de ACM LDAP-server toe:

Identiteitsbron, vul de onderstaande informatie in
 

Type = LDAP

Use SSL = select

Server Address = <ACM FQDN> (Use actual ACM Fully Qualified Domain Name)

Port = 636

Domain = dc=idpa,dc=local

Query User = uid=idpauser,ou=People,dc=idpa,dc=local

Query Password = idpauser password
  1. Klik op de knop Volgende en vervolgens op de knop Opslaan op het volgende scherm.
  2. Markeer de LDAP-server en klik op de knop |<- om de navigatiekolom te openen. Voer het volgende in voor Naam van groepszoekopdracht en klik op de knop Groep toevoegen:
cn=dp_admin,ou=group,dc=idpa,dc=local

 

Voer het volgende in voor

Zodra de identiteitsbron en de groep zijn toegevoegd, werkt u de ldapIntegrationStatus.xml op de ACM-server met het volgende proces.

  1.  Meld u aan bij de ACM CLI met PuTTY or SSH als root en ga naar de volgende map:
/usr/local/dataprotection/var/configmgr/server_data/config
  1. Maak een back-up van de ldpaIntgrationStatus.xml met de volgende opdracht:
cp ldapIntegrationStatus.xml ldpaIntegrationStatus.xml.backup
  1. Bewerken ldpaIntegrationStatus.xml door het te openen in vi. Zoek de DATA_PROTECTION_CENTRAL component tag en stel deze in op INTEGRATED als dit niet het geval is. Het zou er als volgt uit moeten zien:
        <component>
            <id>DATA_PROTECTION_CENTRAL</id>
            <status>INTEGRATED</status>
        </component>
  1. Sla deze wijziging op door op escape te drukken en vervolgens te typen :x.

Probeer u nu aan te melden bij de DPC-gebruikersinterface met idpauser rekening. 

Als het aanmelden mislukt, neemt u contact op met Dell Support voor hulp bij dit probleem.

Article Properties
Article Number: 000269136
Article Type: Solution
Last Modified: 11 Dec 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.