Wewnętrzny protokół LDAP Data Protection Central nie działa po uaktualnieniu IDPA

Summary: Po uaktualnieniu IDPA protokół LDAP serwera Data Protection Central (DPC) nie działa.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Wewnętrzny protokół LDAP nie działa:

  • Źródło tożsamości jest dostępne, jednak jest wyświetlane jako rozłączone
  • Grupa zniknęła również ze źródła identyfikacji
  • Podczas próby dodania pojawia się błąd mapowania ról

W /var/log/dpc/iam/iam-provider/keycloak.log (jako root) widoczne są następujące błędy certyfikatów:

2024-10-21 17:17:53,937 ERROR [org.keycloak.services] (executor-thread-17) KC-SERVICES0055: Error when connecting to LDAP: <ACM FQDN>:636: javax.naming.CommunicationException: <AMC FQDN>:636 [Root exception is javax.net.ssl.SSLHandshakeException: PKIX path validation failed: java.security.cert.CertPathValidatorException: signature check failed]

W /var/log/dpc/iam/iam-service/iam-service.log (jako root), widoczne są następujące błędy dodawania grupy LDAP:

2024-10-21 13:22:44,810 INFO https-jsse-nio-9922-exec-9 c.e.c.s.s.IndetitySourceService LDAP instance Id: ae45949d-40dd-46ee-8136-bc40e0d32644 . Adding group role mapping for [cn=dp_admin,ou=Group,dc=idpa,dc=local]

W /var/log/dpc/elg/elg.log, widoczne są również błędy dodawania grup:

2024-10-21 13:22:44,949 ERROR https-jsse-nio-9922-exec-9 c.e.c.s.s.GlobalExceptionHnalder IdentitySourceException:com.emc.clp.security.exception.IdentitySourceException: Failed to create group role mapping. Received error for ldap mapper group [MapperGroup(cn=dp_admin,ou=Group,dc=idpa,dc=local] creation.

Cause

Po uaktualnieniu IDPA serwer DPC nie może połączyć się z serwerem LDAP ACM ani dodać grupy. 

Resolution

Procedura:

  1. Zaloguj się do interfejsu wiersza poleceń DPC jako administrator za pomocą polecenia: SSH or PuTTY i su - do użytkownika root.
  2. Uruchom następujące polecenia:
service dp-iam restart
service msm-elg restart
  1. Zaloguj się do interfejsu użytkownika DPC i przejdź do administracyjnych >źródeł tożsamości.

Wyświetla menu interfejsu użytkownika DPC dla: Źródła tożsamości administracyjnych >

  1. Dodaj źródło tożsamości dla serwera LDAP ACM:

Źródło tożsamości, wypełnij informacje jak poniżej
 

Type = LDAP

Use SSL = select

Server Address = <ACM FQDN> (Use actual ACM Fully Qualified Domain Name)

Port = 636

Domain = dc=idpa,dc=local

Query User = uid=idpauser,ou=People,dc=idpa,dc=local

Query Password = idpauser password
  1. Kliknij przycisk Dalej, a następnie przycisk Zapisz na następnym ekranie.
  2. Podświetl serwer LDAP i kliknij przycisk |<- , aby otworzyć pasek boczny. W polu Nazwa wyszukiwania grupy wpisz następujące informacje, a następnie kliknij przycisk Add Group:
cn=dp_admin,ou=group,dc=idpa,dc=local

 

wpisz następujące wartości w polu

Po dodaniu źródła tożsamości i grupy zaktualizuj plik ldapIntegrationStatus.xml na serwerze ACM z następującym procesem.

  1.  Zaloguj się do interfejsu wiersza poleceń ACM za pomocą PuTTY or SSH jako root i przejdź do następującego katalogu:
/usr/local/dataprotection/var/configmgr/server_data/config
  1. Wykonaj kopię zapasową ldpaIntgrationStatus.xml przy użyciu następującego polecenia:
cp ldapIntegrationStatus.xml ldpaIntegrationStatus.xml.backup
  1. Edycja ldpaIntegrationStatus.xml otwierając go w vi. Wyszukiwanie DATA_PROTECTION_CENTRAL component i ustaw go na INTEGRATED, jeśli nie jest. Powinno to wyglądać następująco:
        <component>
            <id>DATA_PROTECTION_CENTRAL</id>
            <status>INTEGRATED</status>
        </component>
  1. Zapisz zmianę, naciskając Escape, a następnie wpisując :x.

Teraz spróbuj zalogować się do interfejsu użytkownika DPC za pomocą polecenia idpauser rachunek. 

Jeśli logowanie nie powiedzie się, skontaktuj się z działem pomocy technicznej firmy Dell , aby uzyskać pomoc w rozwiązaniu tego problemu.

Article Properties
Article Number: 000269136
Article Type: Solution
Last Modified: 11 Dec 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.