Data Protection Central: L'accesso all'interfaccia utente ha esito negativo con "401 Unauthorized"

Summary: Dopo un aggiornamento di DPC o IDPA, gli utenti potrebbero non essere in grado di accedere all'interfaccia utente del Data Protection Center (DPC). L'errore di accesso è il risultato di un problema di sincronizzazione tra il servizio IAM (Identity and Access Management) e Keycloak. ...

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Symptoms

  • L'accesso all'interfaccia utente di DPC ha esito negativo con un errore 401 Unauthorized .

  • Nel registro di servizio IAM vengono visualizzati i seguenti errori (/var/log/dpc/iam/iam-service/iam-services.log):

    • WebClientRequestException: finishConnect(..) failed: Connection refused: iam-provider:<IPv6>:8443
      IAMExchangeException(errorMessage=Cannot get admin access token, httpStatus=401 UNAUTHORIZED)

Cause

Il problema è causato da un errore di sincronizzazione delle password tra il servizio IAM e il provider di identità Keycloak.
Ciò impedisce al servizio IAM di ottenere il token di accesso amministratore necessario, con conseguente errore di accesso.

Resolution

Questo problema richiede l'intervento del supporto Dell.
Per risolvere il problema:

  1. Non tentare di riavviare i servizi o modificare manualmente le configurazioni IAM/Keycloak.
  2. Aprire una Service Request con il Supporto Dell e fare riferimento a questo articolo della Knowledge Base (#000375379) per accelerare la risoluzione.

Il Supporto Dell esegue le operazioni back-end necessarie per ripristinare la sincronizzazione e risolvere il problema di accesso.

Affected Products

Data Protection Central
Article Properties
Article Number: 000375379
Article Type: Solution
Last Modified: 05 Nov 2025
Version:  1
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