Windows Server : Le contrôleur de domaine ne parvient pas à démarrer avec un code d’arrêt 0xC00002E2
Summary: Un contrôleur de domaine (DC) Active Directory peut ne pas démarrer dans Windows et afficher des 0xC00002E2 d’arrêt. Cela peut se produire pour plusieurs raisons, dont deux sont abordées dans cet article. ...
Symptoms
Un contrôleur de domaine concerné ne parvient pas à démarrer Windows en mode normal et le code d’arrêt 0xC00002E2 s’affiche. Le contrôleur de domaine peut démarrer en mode de réparation des services d’annuaire (DSRM).
Cause
Cette erreur peut avoir plusieurs causes :
- Le volume qui contient la base de données AD n’a pas suffisamment d’espace disponible.
- Le rôle ADDS a été supprimé sans que le contrôleur de domaine ait été correctement rétrogradé au préalable.
- La base de données AD est corrompue. Cet article ne traite pas de la corruption de la base de données AD.
Resolution
Cause 1 : Le volume qui contient la base de données AD n’a pas suffisamment d’espace disponible.
Il s’agit de la cause la plus simple et la moins destructrice du problème. La solution consiste à localiser la base de données AD et à libérer de l’espace sur le volume qui la contient. Le fichier de base de données (ntds.dit) est situé à l’adresse suivante : C:\Windows\NTDS par défaut, mais c’est peut-être ailleurs. Pour localiser la base de données dans DSRM, exécutez ces commandes dans l’ordre :
ntdsutil
activate instance ntds
files
info
Le résultat affiche l’emplacement du fichier de base de données et d’autres informations, y compris la quantité d’espace disponible sur le volume :
Drive Information:
C:\ NTFS (Fixed Drive ) free(110.5 Gb) total(126.2 Gb)
DS Path Information:
Database : C:\WINDOWS\NTDS\ntds.dit - 40.0 Mb
Backup dir : C:\WINDOWS\NTDS\dsadata.bak
Working dir: C:\WINDOWS\NTDS
Log dir : C:\WINDOWS\NTDS - 50.0 Mb total
edbtmp.log - 10.0 Mb
edbres00002.jrs - 10.0 Mb
edbres00001.jrs - 10.0 Mb
edb00001.log - 10.0 Mb
edb.log - 10.0 Mb
Saisissez quit deux fois pour quitter l’utilitaire Ntdsutil. Si l’espace libre du volume est faible, déterminez si d’autres fichiers stockés sur le même volume peuvent être supprimés ou déplacés vers un autre volume.
Cause 2 : Le rôle ADDS a été supprimé sans que le contrôleur de domaine ait été correctement rétrogradé au préalable.
Un contrôleur de domaine doit toujours être correctement rétrogradé avant que le rôle ADDS ne lui soit retiré. Server Manager et PowerShell empêchent la suppression du rôle si le contrôleur de domaine n’a pas été rétrogradé. Cependant dism et d’autres commandes peuvent supprimer des rôles ou des fonctionnalités sans effectuer au préalable les vérifications des conditions préalables. Pour vérifier si cela s’est produit, démarrez dans DSRM et lancez la console Services. Si les services de domaine Active Directory ne sont pas répertoriés, certains composants essentiels d’Active Directory ont été supprimés.
Si le contrôleur de domaine concerné est le seul du domaine, la fonctionnalité normale ne peut être restaurée qu’en restaurant une sauvegarde de l’état du système du contrôleur de domaine. Si aucune sauvegarde de l’état du système n’est disponible, le contrôleur de domaine doit être rétrogradé de force. Cela supprime le domaine, qui doit ensuite être recréé. Voir PowerEdge : Comment forcer la rétrogradation d’un contrôleur de domaine Active Directory pour connaître les étapes à suivre pour forcer une rétrogradation.
Important : Si la rétrogradation échoue avec l’erreur « Le service spécifié n’existe pas en tant que service installé », exécutez la commande suivante :
dism /online /enable-feature /featurename:DirectoryServices-DomainController
Redémarrez le serveur en mode DSRM et redémarrez la rétrogradation forcée. Une fois le serveur rétrogradé, redémarrez en mode normal. Le domaine peut ensuite être recréé.
S’il existe d’autres contrôleurs de domaine dans le domaine, procédez à une rétrogradation forcée du contrôleur de domaine concerné (voir la remarque ci-dessus). Après l’avoir rétrogradé, supprimez ses métadonnées d’Active Directory. Le serveur peut ensuite être promu en contrôleur de domaine.
Cause 3 : La base de données AD est corrompue.
Dans de rares cas, une corruption de la base de données AD peut entraîner ce code d’arrêt. (Le code d’arrêt 0xC00002E1 presque identique est plus courant.) Le dépannage de la corruption de la base de données AD n’entre pas dans le cadre de cet article, bien qu’il existe d’autres ressources en ligne qui traitent de ce problème.