PowerProtect : Échec de la tâche de copie de Cloud Snapshot Manager avec une erreur lors du traitement de la demande
Summary: PowerProtect : La tâche de copie de Cloud Snapshot Manager échoue avec l’erreur suivante : {"errors » :[{"code » :1004,"message » :"Erreur rencontrée lors du traitement de la demande. »,"details » :"Erreur rencontrée lors du traitement de la demande."}]} ...
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Les tâches de copie pour copier des snapshots d’Amazon Web Services (AWS) vers Data Domain Virtual Edition (DDVE) échouent avec un message d’erreur similaire au message suivant :
Les journaux AWS CloudFormation affichent des messages d’erreur similaires à ce qui suit :
"Error occured fetching session from csm proxy : Error: {"errors":[{"code":1004,"message":"Error encountered while processing the request.","details":"Error encountered while processing the request."}]} Error code: 3041" Il n’existe aucun cluster AWS ECS et les définitions de tâches sont créées dans le compte AWS.
Les journaux AWS CloudFormation affichent des messages d’erreur similaires à ce qui suit :
# TaskDefinition CREATE_FAILED Resource handler returned message: "Invalid request provided: Create TaskDefinition: User: arn:aws:sts::sideID:assumed-role/CSMRole/xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx is not authorized to perform: ecs:TagResource on resource: arn:aws:ecs:ZONE:sideID:task-definition/csm-xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx_proxyTaskDefinition:* because no identity-based policy allows the ecs:TagResource action (Service: AmazonECS; Status Code: 400; Error Code: AccessDeniedException; Request ID: xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx; Proxy: null)" (RequestToken: 0d5dea1c-e158-e5e2-0080-1e2c521679dc, HandlerErrorCode: InvalidRequest)Un message semblable au message suivant s’affiche :
# Cluster CREATE_FAILED Resource handler returned message: "Error occurred during operation 'CreateCluster SDK error: User: arn:aws:sts::sideID:assumed-role/CSMRole/xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx is not authorized to perform: ecs:TagResource on resource: arn:aws:ecs:ZONE:sideID:cluster/csm-xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx_proxyCluster because no identity-based policy allows the ecs:TagResource action (Service: AmazonECS; Status Code: 400; Error Code: AccessDeniedException; Request ID: xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx; Proxy: null)'." (RequestToken: xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx, HandlerErrorCode: GeneralServiceException)
Cause
Autorisation AWS
ecs:TagResource est absente de la politique IAM attribuée au rôle utilisé par Cloud Snapshot Manager.Resolution
Mettez à jour la politique IAM attribuée au rôle utilisé par Cloud Snapshot Manager.
Le lien vers la documentation suivant peut être utilisé pour trouver les étapes à suivre pour créer ou mettre à jour des politiques IAM : Aide en ligne de PowerProtect Cloud Snapshot Manager | Dell US
Sous l’onglet JSON, apportez les modifications comme indiqué dans l’image ci-dessous :
Affected Products
Cloud Snapshot Manager, PowerProtect Cloud SnapshotArticle Properties
Article Number: 000223744
Article Type: Solution
Last Modified: 29 ago 2025
Version: 2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.