PowerProtect:Cloud Snapshot Managerのコピー ジョブがリクエストの処理中にエラーが発生して失敗する
Summary: PowerProtect:Cloud Snapshot Managerのコピー ジョブが次のエラーで失敗する: {"errors":[{"code":1004,"message":"リクエストの処理中にエラーが発生しました。","details":"リクエストの処理中にエラーが発生しました。"}]}
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Symptoms
Amazon Web Services (AWS)からData Domain Virtual Edition (DDVE)にスナップショットをコピーするためのコピー ジョブが、次のようなエラー メッセージで失敗します。
AWS CloudFormationログには、次のようなエラー メッセージが表示されます。
"Error occured fetching session from csm proxy : Error: {"errors":[{"code":1004,"message":"Error encountered while processing the request.","details":"Error encountered while processing the request."}]} Error code: 3041" AWS ECSクラスターはなく、タスク定義はAWSアカウントで作成されます
AWS CloudFormationログには、次のようなエラー メッセージが表示されます。
# TaskDefinition CREATE_FAILED Resource handler returned message: "Invalid request provided: Create TaskDefinition: User: arn:aws:sts::sideID:assumed-role/CSMRole/xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx is not authorized to perform: ecs:TagResource on resource: arn:aws:ecs:ZONE:sideID:task-definition/csm-xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx_proxyTaskDefinition:* because no identity-based policy allows the ecs:TagResource action (Service: AmazonECS; Status Code: 400; Error Code: AccessDeniedException; Request ID: xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx; Proxy: null)" (RequestToken: 0d5dea1c-e158-e5e2-0080-1e2c521679dc, HandlerErrorCode: InvalidRequest)次のようなメッセージが表示されます。
# Cluster CREATE_FAILED Resource handler returned message: "Error occurred during operation 'CreateCluster SDK error: User: arn:aws:sts::sideID:assumed-role/CSMRole/xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx is not authorized to perform: ecs:TagResource on resource: arn:aws:ecs:ZONE:sideID:cluster/csm-xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx_proxyCluster because no identity-based policy allows the ecs:TagResource action (Service: AmazonECS; Status Code: 400; Error Code: AccessDeniedException; Request ID: xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx; Proxy: null)'." (RequestToken: xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx, HandlerErrorCode: GeneralServiceException)
Cause
AWSアクセス許可
ecs:TagResource Cloud Snapshot Managerによって使用されるロールに割り当てられたIAMポリシーにありません。Resolution
Cloud Snapshot Managerによって使用されるロールに割り当てられているIAMポリシーを更新します。
次のドキュメント リンクを使用して、IAMポリシーを作成または更新する手順を見つけることができます。PowerProtect Cloud Snapshot Managerオンライン ヘルプ |Dell US
JSONタブで、次の図に示すように変更を加えます。
Affected Products
Cloud Snapshot Manager, PowerProtect Cloud SnapshotArticle Properties
Article Number: 000223744
Article Type: Solution
Last Modified: 29 ago 2025
Version: 2
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