Påloggingsinformasjon for PowerProtect Data Manager Hyper-V

Summary: Denne KB-artikkelen beskriver kontokrav for å legge til en Hyper-V-server eller klyngeressurskilde i PowerProtect Data Manager.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Følgende tillatelser må tilordnes til brukerkontoen for Active Directory-domenet (AD) for å kjøre sikkerhetskopiering og gjenoppretting av Hyper-V Virtual Machine (VM) når du legger til Hyper-V-serveren eller klyngeressurskilden ved hjelp av domenebrukeren:

Frittstående:

  • Lokal administratorgruppe
  • Hyper-V Administrator Group
  • Brukere av ekstern administrasjon
  • Eksterne skrivebordsbrukere

Klynge:

  • Lokal administratorgruppe
  • Gruppe for Hyper-V-administrator
  • Brukere av ekstern administrasjon
  • Eksterne skrivebordsbrukere
  • Lese-/skrivetilgang til klyngen 
    Grant-clusteraccess -user <Domain\user> -Full

Selv om tillatelser er gitt, kan ikke gjenoppretting på filnivå (FLR) montere sikkerhetskopien med følgende feil:

2025-06-30T12:50:51.928Z ERROR [98d1d5f0658a4101;b774b4be3e4a26b8] - Exception occurred while handling flrAttach request: ADHP0002 
2025-06-30T12:50:51.928Z ERROR [98d1d5f0658a4101;b774b4be3e4a26b8] - Inner exception: Connecting to remote server hyperv-01 failed with the following error message : Access is denied. For more information, see the about_Remote_Troubleshooting Help topic. 
2025-06-30T12:50:51.941Z INFO [98d1d5f0658a4101;b774b4be3e4a26b8] - Pluginservice attach response: 
{
  "DiskControllers": null,
  "Status": "FAILURE",
  "Error": {
    "Code": 400,
    "ExtendedInfo": "",
    "Path": "",
    "Reason": "Attach operation cannot be completed because an Exception error occurred.",
    "Remediation": "To troubleshoot the issue:\n1) In the PowerProtect Data Manager UI, go to the Jobs window and click Export log and review the log file for more details.\n2) Retry the operation.\nIf the issue persists, contact Dell Customer Support.",
    "Timestamp": 638868882519312362,
    "MessageId": "ARHV0033",
    "MessageArgs": null,
    "MessageTemplate": null,
    "Message": "ADHP0002"
  }
} 

Cause

Kontoen som ble brukt for å legge til Hyper-V-formatet som ble brukt, var <brukernavn> uten prefiks.

Under FLR legger den til maskinnavnet foran brukernavnet for tilkoblingen. Dette resulterer i å bruke den lokale kontoen (vertsnavn\brukernavn) i stedet for domenekontoen (domene\brukernavn).

Den lokale kontoen har ikke de nødvendige tillatelsene.

For å bekrefte, sjekk om en winrm-tilkobling fra utenfor programmet kan utføres eller ikke.

Bruk PowerShell-skriptet som inneholder kommandoer for å opprette en winrm-tilkobling manuelt.
Rediger skriptvariablene for å legge til detaljene for Hyper-V-serveren - FQDN / IP, brukernavn og passord for sikkerhetskopiering.
Kjør dette skriptet i PowerShell ISE på Hyper-V-serveren (eiernoden til den virtuelle målmaskinen) som FLR-feilen ses for.

Prøv skriptet ved hjelp av et fullstendig kvalifisert domenenavn (FQDN), IP-adresse og kort navn. Sjekk deretter hvilken kombinasjon winrm-tilkoblingen fungerer for denne Hyper-V-serveren. Prøv dette for den lokale kontoen og domenekontoen,

Prøv også å skrive inn både ntstyle-brukernavnet og UPN-stilen (User Principal Name) i brukernavnfeltet.
Ntstyle: domene\administrator
UPN: adminitrator@domain.com
 

Resolution

For en domenebruker må brukerlegitimasjonen være i ett av følgende formater:

username@domain.comeller ntname\brukernavn

Endre brukerstilen i administrasjonslegitimasjonen for brukergrensesnittet > i PowerProtect Data Manager>

Additional Information

Fra PowerShell-skriptet: 

$hostName="10.125.xx.xx" # example: "mywindowsvm.westus.cloudapp.azure.com ( IP /FQDN of the HYPERV server)"
$winrmPort = "5986"
$cred = New-Object System.Management.Automation.PSCredential("netbiosname\Username", (ConvertTo-SecureString 'Password123' -AsPlainText -Force))
# Connect to the machine
$sessionOptions = New-PSSessionOption -SkipCACheck -SkipCNCheck -SkipRevocationCheck
Enter-PSSession -ComputerName $hostName -Port $winrmPort -Credential $cred  -UseSSL -SessionOption


 

Article Properties
Article Number: 000359505
Article Type: Solution
Last Modified: 20 ene 2026
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.