Unable to Turn on Dell Pro Plus Earbuds EB525 Upon Arrival
Summary: Learn how to turn on Dell Pro Plus Earbuds EB525 if they are unable to be turned on upon arrival.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
The Dell Pro Plus Earbuds EB525 may not turn on when attempting to use them for the first time.
Affected Product:
- Dell Pro Plus Earbuds EB525
Cause
The earbud is in shipping mode to protect the battery from accidental activation during transportation.
Resolution
To resolve the issue with the Dell Pro Plus Earbuds EB525 not turning on, follow these steps:
- Ensure that the earbuds are placed inside the case with the lid closed.
- Charge the case for five seconds.
- Charging the earbuds in the case activates the earbuds and allows them to turn on.
Affected Products
Dell Pro Plus Earbuds EB525Article Properties
Article Number: 000370926
Article Type: Solution
Last Modified: 25 Sept 2025
Version: 1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.