Bluetooth Device Disconnects and Reconnects on a Dell Pro Laptop
Summary: Learn about the sudden disconnect of the Bluetooth device when it is used on a Dell Pro laptop.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Dell Premier keyboard or mouse may disconnect after 15 minutes of the connection. It may then recover on its own after a few minutes.
Affected Platforms:
- Dell Pro 13 Plus PB13250
- Dell Pro 13 Premium PA13250
- Dell Pro 14 Plus PB14250
- Dell Pro 14 Premium PA14250
- Dell Pro 16 Plus PB16250
Affected Devices:
- Dell Pro Premium Collaboration Keyboard KB900
- Dell Pro Premium Mouse MS900
Cause
The Bluetooth controller was getting doorbell interrupt but not getting sleep control status bit set when the driver transitioned from D3 to D0.
Resolution
Updating to Intel BE2xx/AX4xx/AX2xx/9xxx Bluetooth Driver version 23.130.0.3, A46 or later on the computer resolves the issue. To download and install the driver, refer to How to Download and Install Dell Drivers and Firmware.
Affected Products
Dell Pro Premium Collaboration Keyboard KB900, Dell Pro Premium Mouse MS900, Dell Pro 13 Premium PA13250, Dell Pro 14 Premium PA14250, Dell Pro 13 Plus PB13250, Dell Pro 14 Plus PB14250, Dell Pro 16 Plus PB16250Article Properties
Article Number: 000286954
Article Type: Solution
Last Modified: 11 Jun 2025
Version: 8
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.