Dell Wireless Audio Devices Not Shown in Display and Peripheral Manager when Using Dell Pair
Summary: Learn about Dell wireless audio devices not being recognized in Dell Display and Peripheral Manager or has intermittent sound in the headset when a wireless audio device is paired to the computer through Dell Pair application. ...
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Note: Dell Support for Dell Pair ended on March 26, 2026, reference End of Security Support for the Dell Pair Application.
Affected Products:
- Dell Display and Peripheral Manager
- Dell Premier Wireless ANC Headset - WL7024
- Dell Pro Plus Wireless ANC Headset - WL5024
- Dell Pro Wireless Headset - WL3024
- Dell Pro Plus Wireless Speakerphone - SL525
- Dell Pro Plus Earbuds - EB525
Symptoms:
When a wireless audio device is paired to the computer through the Dell Pair application:
- Dell wireless audio devices are not recognized in Dell Display and Peripheral Manager
- Dell headsets have intermittent audio
Cause
Dell Pair does not support LE Audio capabilities.
Resolution
To resolve this issue, the user can pair the wireless device manually using the Windows Bluetooth manager or they can use Swift Pair for Dell Wireless Audio Device paring.
For more detailed information about manual Pairing or Swift Paring, reference the Dell knowledge base article, How to Pair Dell Bluetooth Devices in Windows 11 and Windows 10.
Affected Products
Dell Display and Peripheral Manager, Dell Pro Plus Earbuds EB525, Dell Pro Plus Wireless Speakerphone SL525, Dell Pro Wireless Headset WL3024, Dell Pro Plus Wireless ANC Headset WL5024, Dell Pro Premium Wireless ANC Headset WL7024Article Properties
Article Number: 000388585
Article Type: Solution
Last Modified: 08 Apr 2026
Version: 5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.